summaryrefslogtreecommitdiff
path: root/net-irc/kvirc/kvirc-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-22 11:30:24 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-22 11:30:24 +0100
commitd56d144655e3785864da43c9acb6c228ef9360ae (patch)
treeb769b599a558483f82e9a057c41f1edd29626dd1 /net-irc/kvirc/kvirc-9999.ebuild
parentfab849d1daed0ba7f2ac497d07985c3dbb692543 (diff)
gentoo resync : 22.06.2019
Diffstat (limited to 'net-irc/kvirc/kvirc-9999.ebuild')
-rw-r--r--net-irc/kvirc/kvirc-9999.ebuild33
1 files changed, 18 insertions, 15 deletions
diff --git a/net-irc/kvirc/kvirc-9999.ebuild b/net-irc/kvirc/kvirc-9999.ebuild
index 543e5042b440..b37c64f007b3 100644
--- a/net-irc/kvirc/kvirc-9999.ebuild
+++ b/net-irc/kvirc/kvirc-9999.ebuild
@@ -1,10 +1,12 @@
-# Copyright 2009-2018 Arfrever Frehtes Taifersar Arahesis
+# Copyright 2009-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+# True Authors: Arfrever Frehtes Taifersar Arahesis
+
+EAPI="7"
PYTHON_COMPAT=(python2_7)
-inherit cmake-utils flag-o-matic gnome2-utils python-single-r1 xdg-utils
+inherit cmake-utils flag-o-matic python-single-r1 xdg-utils
if [[ "${PV}" == "9999" ]]; then
inherit git-r3
@@ -13,8 +15,6 @@ if [[ "${PV}" == "9999" ]]; then
KVIRC_GIT_REVISION=""
KVIRC_GIT_SOURCES_DATE=""
else
- inherit vcs-snapshot
-
KVIRC_GIT_REVISION=""
KVIRC_GIT_SOURCES_DATE="${PV#*_pre}"
KVIRC_GIT_SOURCES_DATE="${KVIRC_GIT_SOURCES_DATE:0:4}-${KVIRC_GIT_SOURCES_DATE:4:2}-${KVIRC_GIT_SOURCES_DATE:6:2}"
@@ -28,13 +28,17 @@ else
SRC_URI="https://github.com/kvirc/KVIrc/archive/${KVIRC_GIT_REVISION}.tar.gz -> ${P}.tar.gz"
fi
-LICENSE="kvirc"
+LICENSE="GPL-2+"
SLOT="0"
KEYWORDS=""
IUSE="audiofile +dbus dcc_video debug doc gsm kde +nls oss +perl +phonon profile +python spell +ssl theora webkit"
REQUIRED_USE="audiofile? ( oss ) python? ( ${PYTHON_REQUIRED_USE} )"
-RDEPEND="dev-qt/qtcore:5
+BDEPEND="virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+ kde? ( kde-frameworks/extra-cmake-modules:5 )
+ nls? ( sys-devel/gettext )"
+DEPEND="dev-qt/qtcore:5
dev-qt/qtgui:5
dev-qt/qtmultimedia:5
dev-qt/qtnetwork:5
@@ -68,14 +72,13 @@ RDEPEND="dev-qt/qtcore:5
media-libs/libvorbis
)
webkit? ( dev-qt/qtwebkit:5 )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- doc? ( app-doc/doxygen )
- kde? ( kde-frameworks/extra-cmake-modules:5 )
- nls? ( sys-devel/gettext )"
-RDEPEND="${RDEPEND}
+RDEPEND="${DEPEND}
gsm? ( media-sound/gsm )"
+if [[ "${PV}" != "9999" ]]; then
+ S="${WORKDIR}/KVIrc-${KVIRC_GIT_REVISION}"
+fi
+
DOCS=()
pkg_setup() {
@@ -138,11 +141,11 @@ src_configure() {
}
pkg_postinst() {
- gnome2_icon_cache_update
xdg_desktop_database_update
+ xdg_icon_cache_update
}
pkg_postrm() {
- gnome2_icon_cache_update
xdg_desktop_database_update
+ xdg_icon_cache_update
}