summaryrefslogtreecommitdiff
path: root/net-irc/konversation/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
commit38423c67c8a23f6a1bc42038193182e2da3116eb (patch)
tree04e2cf4bd43601b77daa79fe654e409187093c5e /net-irc/konversation/files
parent623ee73d661e5ed8475cb264511f683407d87365 (diff)
gentoo resync : 25.04.2020
Diffstat (limited to 'net-irc/konversation/files')
-rw-r--r--net-irc/konversation/files/konversation-1.7.5-QElapsedTimer.patch81
-rw-r--r--net-irc/konversation/files/konversation-1.7.5-kf5bookmarks-5.69.patch51
-rw-r--r--net-irc/konversation/files/konversation-1.7.5-kf5windowsystem-5.63.patch37
-rw-r--r--net-irc/konversation/files/konversation-1.7.5-qt-5.15.patch31
-rw-r--r--net-irc/konversation/files/konversation-1.7.5-unused-kemoticons.patch112
5 files changed, 312 insertions, 0 deletions
diff --git a/net-irc/konversation/files/konversation-1.7.5-QElapsedTimer.patch b/net-irc/konversation/files/konversation-1.7.5-QElapsedTimer.patch
new file mode 100644
index 000000000000..74fd23e58d3c
--- /dev/null
+++ b/net-irc/konversation/files/konversation-1.7.5-QElapsedTimer.patch
@@ -0,0 +1,81 @@
+From 0efede7857a86f729bec0fdfd1789f7faf23d957 Mon Sep 17 00:00:00 2001
+From: David Faure <faure@kde.org>
+Date: Thu, 28 Nov 2019 17:41:33 +0100
+Subject: Port to QElapsedTimer; remove unused default constructor
+
+Tested by printing out the value of age(), works like before.
+---
+ src/irc/ircqueue.cpp | 8 ++++++++
+ src/irc/ircqueue.h | 18 +++++++-----------
+ 2 files changed, 15 insertions(+), 11 deletions(-)
+
+diff --git a/src/irc/ircqueue.cpp b/src/irc/ircqueue.cpp
+index 1101623..3cc33a5 100644
+--- a/src/irc/ircqueue.cpp
++++ b/src/irc/ircqueue.cpp
+@@ -19,6 +19,14 @@
+
+ #include "server.h"
+
++IRCMessage::IRCMessage(const QString &str)
++ : s(str) //, codec(QTextCodec::codecForName("utf8"))
++{
++ t.start();
++}
++
++////
++
+ int IRCQueue::EmptyingRate::nextInterval(int, int elapsed)
+ {
+ if (!isValid())
+diff --git a/src/irc/ircqueue.h b/src/irc/ircqueue.h
+index 3f7f0c8..7a91776 100644
+--- a/src/irc/ircqueue.h
++++ b/src/irc/ircqueue.h
+@@ -19,6 +19,7 @@
+ #include <QObject>
+ #include <QList>
+ #include <QTime>
++#include <QElapsedTimer>
+
+ class QTimer;
+ class Server;
+@@ -34,29 +35,24 @@ class Server;
+ */
+ struct IRCMessage
+ {
+- IRCMessage() : t(QTime::currentTime()) //, codec(QTextCodec::codecForName("utf8"))
+- {} ///< this constructor required for QValueList, do not use
+-
+ /**
+ Make a new IRCMessage with timestamp of QTime::currentTime().
+
+ Note the constructor takes a QString, not a const QString& or a QString *. If you want to modify the
+ contained text, put it back with setText.
+ */
+- IRCMessage(QString i) : s(i), t(QTime::currentTime()) //, codec(QTextCodec::codecForName("utf8"))
+- {}
++ IRCMessage(const QString &str);
+
+- QString text() { return s; }
+- int age() { return t.elapsed(); }
+- QTime time() { return t; }
+- void setText(QString text) { s=text; }
++ QString text() const { return s; }
++ int age() const { return t.elapsed(); } // in milliseconds
++ void setText(const QString &text) { s=text; }
+ private:
+ QString s;
+- QTime t;
++ QElapsedTimer t;
+
+ //FIXME wire this up
+ //QTextCodec* codec;
+- //operator const char * () const { return codec->fromUnicode(text()); }
++ //operator QByteArray () const { return codec->fromUnicode(text()); }
+
+ };
+
+--
+cgit v1.1
+
diff --git a/net-irc/konversation/files/konversation-1.7.5-kf5bookmarks-5.69.patch b/net-irc/konversation/files/konversation-1.7.5-kf5bookmarks-5.69.patch
new file mode 100644
index 000000000000..2c36f69aa99c
--- /dev/null
+++ b/net-irc/konversation/files/konversation-1.7.5-kf5bookmarks-5.69.patch
@@ -0,0 +1,51 @@
+From 57df81cd8a11c4dbe170f9d81abd5b35b4887e0b Mon Sep 17 00:00:00 2001
+From: Ahmad Samir <a.samirh78@gmail.com>
+Date: Fri, 17 Apr 2020 13:14:26 +0200
+Subject: Adapt the code to KBookmarkMenu-5.69 changes
+
+Test Plan:
+Bookmarks menu still works, and the bookmark actions still show in the
+shortcuts editor dialog.
+
+Reviewers: #konversation, psn
+
+Reviewed By: #konversation, psn
+
+Subscribers: #konversation
+
+Differential Revision: https://phabricator.kde.org/D28911
+---
+ src/bookmarkhandler.cpp | 8 ++++++++
+ 1 file changed, 8 insertions(+)
+
+diff --git a/src/bookmarkhandler.cpp b/src/bookmarkhandler.cpp
+index 5a70591..74b51ff 100644
+--- a/src/bookmarkhandler.cpp
++++ b/src/bookmarkhandler.cpp
+@@ -21,7 +21,10 @@ Copyright (C) 2002 Carsten Pfeiffer <pfeiffer@kde.org>
+ #include "connectionmanager.h"
+ #include "viewer/viewcontainer.h"
+
++#include <KActionCollection>
++#include <kbookmarks_version.h>
+ #include <KBookmarkMenu>
++#include <QMenu>
+ #include <QStandardPaths>
+
+
+@@ -41,7 +44,12 @@ m_mainWindow(mainWindow)
+ manager->setEditorOptions(i18n("Konversation Bookmarks Editor"), false);
+ manager->setUpdate( true );
+
++#if KBOOKMARKS_VERSION < QT_VERSION_CHECK(5, 69, 0)
+ m_bookmarkMenu = new KBookmarkMenu(manager, this, menu, m_mainWindow->actionCollection());
++#else
++ m_bookmarkMenu = new KBookmarkMenu(manager, this, menu);
++ m_mainWindow->actionCollection()->addActions(menu->actions());
++#endif
+ }
+
+ KonviBookmarkHandler::~KonviBookmarkHandler()
+--
+cgit v1.1
+
diff --git a/net-irc/konversation/files/konversation-1.7.5-kf5windowsystem-5.63.patch b/net-irc/konversation/files/konversation-1.7.5-kf5windowsystem-5.63.patch
new file mode 100644
index 000000000000..cf93b3b66def
--- /dev/null
+++ b/net-irc/konversation/files/konversation-1.7.5-kf5windowsystem-5.63.patch
@@ -0,0 +1,37 @@
+From 4295aba5c02533040723d140e062aebd231b3f18 Mon Sep 17 00:00:00 2001
+From: David Faure <faure@kde.org>
+Date: Thu, 28 Nov 2019 12:56:34 +0100
+Subject: Port away from deprecated KWindowSystem API (with ifdefs)
+
+---
+ src/application.cpp | 6 ++++++
+ 1 file changed, 6 insertions(+)
+
+diff --git a/src/application.cpp b/src/application.cpp
+index 4667c24..538624b 100644
+--- a/src/application.cpp
++++ b/src/application.cpp
+@@ -50,6 +50,7 @@
+ #include <KTextEdit>
+ #include <KSharedConfig>
+ #include <KStartupInfo>
++#include <kwindowsystem_version.h>
+
+ using namespace Konversation;
+
+@@ -1392,7 +1393,12 @@ void Application::handleActivate(const QStringList& arguments)
+
+ newInstance(m_commandLineParser);
+
++#if KWINDOWSYSTEM_VERSION <= QT_VERSION_CHECK(5, 62, 0)
+ KStartupInfo::setNewStartupId(mainWindow, KStartupInfo::startupId());
++#else
++ mainWindow->setAttribute(Qt::WA_NativeWindow, true);
++ KStartupInfo::setNewStartupId(mainWindow->windowHandle(), KStartupInfo::startupId());
++#endif
+ mainWindow->show();
+ mainWindow->raise();
+ }
+--
+cgit v1.1
+
diff --git a/net-irc/konversation/files/konversation-1.7.5-qt-5.15.patch b/net-irc/konversation/files/konversation-1.7.5-qt-5.15.patch
new file mode 100644
index 000000000000..a17c0a432314
--- /dev/null
+++ b/net-irc/konversation/files/konversation-1.7.5-qt-5.15.patch
@@ -0,0 +1,31 @@
+From f88c73cf278da9907496eab0777903f942c50cb9 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Tue, 21 Apr 2020 10:34:49 +0200
+Subject: [PATCH] Fix build with Qt 5.15 (missing header)
+
+Test Plan: Build succeeds with Qt 5.15.0_beta4
+
+Reviewers: #konversation, psn
+
+Reviewed By: #konversation, psn
+
+Differential Revision: https://phabricator.kde.org/D29038
+---
+ src/viewer/viewtree.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/viewer/viewtree.cpp b/src/viewer/viewtree.cpp
+index eeee8fb4..04ec4e54 100644
+--- a/src/viewer/viewtree.cpp
++++ b/src/viewer/viewtree.cpp
+@@ -21,6 +21,7 @@
+ #include <QFontDatabase>
+ #include <QGuiApplication>
+ #include <QPainter>
++#include <QPainterPath>
+ #include <QItemSelectionModel>
+ #include <QStyleHints>
+ #include <QToolTip>
+--
+2.26.1
+
diff --git a/net-irc/konversation/files/konversation-1.7.5-unused-kemoticons.patch b/net-irc/konversation/files/konversation-1.7.5-unused-kemoticons.patch
new file mode 100644
index 000000000000..d856a17215a9
--- /dev/null
+++ b/net-irc/konversation/files/konversation-1.7.5-unused-kemoticons.patch
@@ -0,0 +1,112 @@
+From 271da4bd1e584026fc24d93474ca6cf9e50fa6d7 Mon Sep 17 00:00:00 2001
+From: David Edmundson <kde@davidedmundson.co.uk>
+Date: Mon, 16 Sep 2019 18:18:49 +0100
+Subject: Drop effectively unused kemoticons support
+
+Summary:
+Konversation only supported emoticons if config value EnableEmotIcons
+was true. This by default was false and there is no UI for configuring
+this, making it effectively unused.
+
+This appears to be deliberate from the code comments.
+
+This helps clear up some KEmoticon library usage for future KF6
+transitioning.
+
+UTF-8 emoticons work correctly.
+
+Test Plan: Compiles
+
+Differential Revision: https://phabricator.kde.org/D24000
+---
+ src/CMakeLists.txt | 2 --
+ src/config/konversation.kcfg | 8 --------
+ src/viewer/ircview.cpp | 3 ---
+ 3 files changed, 13 deletions(-)
+
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index c2077b3..89616a6 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -138,7 +138,6 @@ set(viewer_SRCS
+ viewer/topiclabel.cpp
+ viewer/awaylabel.cpp
+ viewer/editnotifydialog.cpp
+- viewer/emoticons.cpp
+ viewer/images.cpp
+ viewer/quickbutton.cpp
+ viewer/searchbar.cpp
+@@ -224,7 +223,6 @@ target_link_libraries(konversation
+ KF5::Bookmarks
+ KF5::ConfigWidgets
+ KF5::Crash
+- KF5::Emoticons
+ KF5::I18n
+ KF5::IdleTime
+ KF5::NotifyConfig
+diff --git a/src/config/konversation.kcfg b/src/config/konversation.kcfg
+index 1d59eaf..3f0b7a6 100644
+--- a/src/config/konversation.kcfg
++++ b/src/config/konversation.kcfg
+@@ -844,14 +844,6 @@
+ <label></label>
+ <whatsthis></whatsthis>
+ </entry>
+- <entry key="EnableEmotIcons" type="Bool">
+- <default>false</default>
+- <label>Enable emoticons</label>
+- </entry>
+- <entry key="EmotIconTheme" type="String">
+- <default>Default</default>
+- <label>Emoticons theme</label>
+- </entry>
+ </group>
+ <group name="PreferencesDialog">
+ <entry name="PreferencesDialogSize" key="Size" type="Size">
+diff --git a/src/viewer/ircview.cpp b/src/viewer/ircview.cpp
+index c129f61..15f78ca 100644
+--- a/src/viewer/ircview.cpp
++++ b/src/viewer/ircview.cpp
+@@ -20,7 +20,6 @@
+ #include "application.h"
+ #include "highlight.h"
+ #include "sound.h"
+-#include "emoticons.h"
+ #include "notificationhandler.h"
+
+ #include <QDrag>
+@@ -1214,8 +1213,6 @@ QString IRCView::filter(const QString& line, const QString& defaultColor, const
+ QLatin1String("\">") + filteredLine + QLatin1String("</font>");
+ }
+
+- filteredLine = Konversation::Emoticons::parseEmoticons(filteredLine);
+-
+ return filteredLine;
+ }
+
+--
+cgit v1.1
+
+From f1e6ec37b9a9ead194606795ed23a1ec70a784cc Mon Sep 17 00:00:00 2001
+From: Peter Simonsson <peter.simonsson@gmail.com>
+Date: Tue, 7 Apr 2020 16:37:53 +0200
+Subject: Remove KEmoticons from dependencies as it's not used
+
+---
+ CMakeLists.txt | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 5315dbd..19facd8 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -24,7 +24,6 @@ find_package(KF5 ${KF5_MIN_VERSION} REQUIRED
+ CoreAddons
+ Crash
+ DocTools
+- Emoticons
+ I18n
+ IdleTime
+ NotifyConfig
+--
+cgit v1.1