summaryrefslogtreecommitdiff
path: root/net-irc/ircstats/ircstats-1.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-02-16 12:59:29 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-02-16 12:59:29 +0000
commit79599515788b85b18aa655e7b7f8cc05c1bbddd8 (patch)
treeade7cb031f363fad64c77139dea7aa3d81908537 /net-irc/ircstats/ircstats-1.2.ebuild
parent6bc2e4d7c5906e46a8f275a876ead6ec41aca5bb (diff)
gentoo resync : 16.02.1018
Diffstat (limited to 'net-irc/ircstats/ircstats-1.2.ebuild')
-rw-r--r--net-irc/ircstats/ircstats-1.2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-irc/ircstats/ircstats-1.2.ebuild b/net-irc/ircstats/ircstats-1.2.ebuild
new file mode 100644
index 000000000000..d50345072372
--- /dev/null
+++ b/net-irc/ircstats/ircstats-1.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils toolchain-funcs
+
+MY_P="IRCStats-${PV}"
+
+DESCRIPTION="IRCStats is a Linux log analyzer"
+HOMEPAGE="https://humdi.net/ircstats/"
+SRC_URI="https://humdi.net/ircstats/${MY_P}.tgz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+S="${WORKDIR}"/${MY_P}
+
+src_compile() {
+ default
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dobin ircstats
+ insinto /usr/share/ircstats
+ doins -r html languages colors
+ dodoc CHANGES README TODO ircstats.cfg
+}
+
+pkg_postinst() {
+ elog "The IRCStats files have been installed in /usr/share/ircstats"
+ elog "You can find an example ircstats.cfg in /usr/share/doc/${PF}"
+}