summaryrefslogtreecommitdiff
path: root/net-irc/ircii/ircii-20210314-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-03 22:39:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-03 22:39:47 +0100
commit7f0ccc917c7abe6223784c703d86cd14755691fb (patch)
tree8c6793f68896b341e22f33d7e6cef88e481f4a8b /net-irc/ircii/ircii-20210314-r1.ebuild
parent9aa80713372911cec499b3adb2cd746790920916 (diff)
gentoo resync : 03.07.2021
Diffstat (limited to 'net-irc/ircii/ircii-20210314-r1.ebuild')
-rw-r--r--net-irc/ircii/ircii-20210314-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-irc/ircii/ircii-20210314-r1.ebuild b/net-irc/ircii/ircii-20210314-r1.ebuild
new file mode 100644
index 000000000000..81b72ece0e57
--- /dev/null
+++ b/net-irc/ircii/ircii-20210314-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="An IRC and ICB client that runs under most UNIX platforms"
+SRC_URI="https://ircii.warped.com/${P}.tar.bz2
+ https://ircii.warped.com/old/${P}.tar.bz2"
+HOMEPAGE="http://eterna.com.au/ircii/"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
+
+DEPEND="sys-libs/ncurses:0=
+ virtual/libcrypt:=
+ virtual/libiconv"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-manpage-path.patch" )
+
+src_configure() {
+ tc-export CC
+ default
+}
+
+src_install() {
+ # Still needed as of 20210314, otherwise man dirs don't exist at the right time
+ emake -j1 DESTDIR="${D}" install
+
+ dodoc ChangeLog INSTALL NEWS README \
+ doc/Copyright doc/crypto doc/VERSIONS doc/ctcp
+}