summaryrefslogtreecommitdiff
path: root/net-irc/ii/ii-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-11 19:55:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-11 19:55:43 +0100
commit185fa19bbf68a4d4dca534d2b46729207a177f16 (patch)
treea8a537b82fda83a0799c2ca9887f212558363aa7 /net-irc/ii/ii-9999.ebuild
parentc8fd0d84af0bfd1949542adc2cbb735b1d28f9ed (diff)
gentoo resync : 11.05.2021
Diffstat (limited to 'net-irc/ii/ii-9999.ebuild')
-rw-r--r--net-irc/ii/ii-9999.ebuild23
1 files changed, 9 insertions, 14 deletions
diff --git a/net-irc/ii/ii-9999.ebuild b/net-irc/ii/ii-9999.ebuild
index 0cb5a9d7e15b..265a788ad43b 100644
--- a/net-irc/ii/ii-9999.ebuild
+++ b/net-irc/ii/ii-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit git-r3 toolchain-funcs
DESCRIPTION="A minimalist FIFO and filesystem-based IRC client"
@@ -10,19 +10,12 @@ EGIT_REPO_URI="https://git.suckless.org/ii"
LICENSE="MIT"
SLOT="0"
-KEYWORDS=""
src_prepare() {
default
- sed -i \
- -e '/^CFLAGS/{s: -Os::g; s:= :+= :g}' \
- -e '/^CC/d' \
- -e '/^LDFLAGS/{s:-s::g; s:= :+= :g}' \
- config.mk || die
- sed -i \
- -e 's|@${CC}|$(CC)|g' \
- Makefile || die
+ sed -i -e '/^LDFLAGS/{s:-s::g; s:= :+= :g}' \
+ -e '/^CFLAGS/{s: -Os::g; s:= :+= :g}' config.mk || die
}
src_compile() {
@@ -30,7 +23,9 @@ src_compile() {
}
src_install() {
- dobin ii
- dodoc CHANGES FAQ README
- doman *.1
+ emake \
+ DESTDIR="${D}" \
+ PREFIX="${EPREFIX}"/usr \
+ DOCPREFIX="${EPREFIX}"/usr/share/doc/${PF} \
+ install
}