summaryrefslogtreecommitdiff
path: root/net-irc/emech/emech-3.0.99_p3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-03 22:39:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-03 22:39:47 +0100
commit7f0ccc917c7abe6223784c703d86cd14755691fb (patch)
tree8c6793f68896b341e22f33d7e6cef88e481f4a8b /net-irc/emech/emech-3.0.99_p3.ebuild
parent9aa80713372911cec499b3adb2cd746790920916 (diff)
gentoo resync : 03.07.2021
Diffstat (limited to 'net-irc/emech/emech-3.0.99_p3.ebuild')
-rw-r--r--net-irc/emech/emech-3.0.99_p3.ebuild90
1 files changed, 0 insertions, 90 deletions
diff --git a/net-irc/emech/emech-3.0.99_p3.ebuild b/net-irc/emech/emech-3.0.99_p3.ebuild
deleted file mode 100644
index 68daec2e5664..000000000000
--- a/net-irc/emech/emech-3.0.99_p3.ebuild
+++ /dev/null
@@ -1,90 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit readme.gentoo-r1 toolchain-funcs
-
-DESCRIPTION="UNIX compatible IRC bot programmed in the C language"
-HOMEPAGE="http://www.energymech.net/"
-SRC_URI="http://www.energymech.net/files/${P/_/}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc x86"
-
-IUSE="debug session tcl"
-S="${WORKDIR}/${P/_/}"
-
-DOC_CONTENTS="You can find a compressed sample config file at /usr/share/doc/${PF}"
-
-src_prepare() {
- eapply "${FILESDIR}/${P}-buildfix.patch"
-
- sed -i \
- -e 's: "help/":"/usr/share/energymech/help/":' \
- -e 's: "messages/":"/usr/share/energymech/messages/":' \
- src/config.h.in || die
- # Respect CFLAGS and LDFLAGS
- sed -i \
- -e '/^LFLAGS/s/\$(PIPEFLAG)/\0 \$(OPTIMIZE) \$(LDFLAGS)/' \
- -e '/^GDBFLAG/d' \
- -e '/^PIPEFLAG/d' \
- src/Makefile.in || die
-
- eapply_user
-}
-
-myconf() {
- tc-export CC
- echo ./configure $*
- ./configure $* || die "./configure failed"
-}
-
-src_configure() {
- myconf \
- --with-alias \
- --with-botnet \
- --with-bounce \
- --with-ctcp \
- --with-dccfile \
- --with-dynamode \
- --with-dyncmd \
- --with-greet \
- --with-ircd_ext \
- --with-md5 \
- --with-newbie \
- --with-note \
- --with-notify \
- --with-rawdns \
- --with-seen \
- --with-stats \
- --with-telnet \
- --with-toybox \
- --with-trivia \
- --without-uptime \
- --with-web \
- --with-wingate \
- --without-profiling \
- --without-redirect \
- $(use_with tcl) \
- $(use_with session) \
- $(use_with debug)
-}
-
-src_compile() {
- emake -C src CC="$(tc-getCC)" OPTIMIZE="${CFLAGS}"
-}
-
-src_install() {
- dobin src/energymech
-
- insinto /usr/share/energymech
- doins -r help
-
- insinto /usr/share/energymech/messages
- doins messages/*.txt
-
- dodoc sample.* README* TODO VERSIONS CREDITS checkmech
- readme.gentoo_create_doc
-}