summaryrefslogtreecommitdiff
path: root/net-irc/emech/emech-3.0.99_p20221123.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-11 15:23:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-11 15:23:05 +0000
commit1c8855d83ff1cb8040f3fccdb1e5d2f47e1d308d (patch)
treed93dddda8aad302287cadca1622f0a6fdb89d977 /net-irc/emech/emech-3.0.99_p20221123.ebuild
parent583acea08c150460a36d3ee1a4800c33b9b19103 (diff)
gentoo auto-resync : 11:12:2022 - 15:23:05
Diffstat (limited to 'net-irc/emech/emech-3.0.99_p20221123.ebuild')
-rw-r--r--net-irc/emech/emech-3.0.99_p20221123.ebuild90
1 files changed, 90 insertions, 0 deletions
diff --git a/net-irc/emech/emech-3.0.99_p20221123.ebuild b/net-irc/emech/emech-3.0.99_p20221123.ebuild
new file mode 100644
index 000000000000..f7107601febc
--- /dev/null
+++ b/net-irc/emech/emech-3.0.99_p20221123.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit readme.gentoo-r1 toolchain-funcs
+
+GIT_COMMIT="62b62c8388fac3b3715c5d6539e1d704b16fa2d6"
+
+DESCRIPTION="UNIX compatible IRC bot programmed in C"
+HOMEPAGE="https://github.com/EnergyMech/energymech"
+SRC_URI="https://github.com/EnergyMech/energymech/archive/${GIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/energymech-${GIT_COMMIT}"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="debug session tcl"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="virtual/libcrypt:="
+DEPEND="${RDEPEND}"
+
+DOC_CONTENTS="You can find a compressed sample config file at /usr/share/doc/${PF}"
+
+PATCHES=( "${FILESDIR}/${P}-fix-Wreturn-type.patch" )
+src_prepare() {
+ default
+
+ sed -i \
+ -e 's:"help/":"/usr/share/energymech/help/":' \
+ src/config.h.in || die
+ # Respect CFLAGS and LDFLAGS
+ sed -i \
+ -e '/^LFLAGS/s/\$(PIPEFLAG)/\0 \$(OPTIMIZE) \$(LDFLAGS)/' \
+ -e '/^GDBFLAG/d' \
+ -e '/^PIPEFLAG/d' \
+ src/Makefile.in || die
+}
+
+src_configure() {
+ tc-export CC
+ myconf=(
+ --with-alias
+ --with-botnet
+ --with-bounce
+ --with-ctcp
+ --with-dccfile
+ --with-dynamode
+ --with-dyncmd
+ --with-greet
+ --with-ircd_ext
+ --with-md5
+ --with-newbie
+ --with-note
+ --with-notify
+ --with-rawdns
+ --with-seen
+ --with-stats
+ --with-telnet
+ --with-toybox
+ --with-trivia
+ --without-uptime
+ --with-web
+ --with-wingate
+ --without-profiling
+ --without-redirect
+ $(use_with tcl)
+ $(use_with session)
+ $(use_with debug)
+ )
+ # not econf because we don't use autotools
+ ./configure "${myconf[@]}" || die "Configure failed"
+}
+
+src_compile() {
+ emake -C src CC="$(tc-getCC)" OPTIMIZE="${CFLAGS}"
+}
+
+src_install() {
+ dobin src/energymech
+
+ insinto /usr/share/energymech
+ doins -r help
+
+ insinto /usr/share/energymech/messages
+ doins common/*.txt
+
+ dodoc sample.* README* TODO VERSIONS CREDITS checkmech
+ readme.gentoo_create_doc
+}