summaryrefslogtreecommitdiff
path: root/net-irc/eggdrop/eggdrop-1.9.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-17 03:38:00 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-17 03:38:00 +0000
commit49b666612bff71976bd8e3cfda8c68e793c0e3ce (patch)
treedc55f15212704db247401b3f1dfe21c39886bb5e /net-irc/eggdrop/eggdrop-1.9.2.ebuild
parentcdda1ab7293bc67061befd2b34a4ed761e887042 (diff)
gentoo auto-resync : 17:12:2022 - 03:37:59
Diffstat (limited to 'net-irc/eggdrop/eggdrop-1.9.2.ebuild')
-rw-r--r--net-irc/eggdrop/eggdrop-1.9.2.ebuild72
1 files changed, 0 insertions, 72 deletions
diff --git a/net-irc/eggdrop/eggdrop-1.9.2.ebuild b/net-irc/eggdrop/eggdrop-1.9.2.ebuild
deleted file mode 100644
index 31868072cbc1..000000000000
--- a/net-irc/eggdrop/eggdrop-1.9.2.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit readme.gentoo-r1
-
-MY_P="${PN}-${PV/_rc/rc}"
-DESCRIPTION="An IRC bot extensible with C or TCL"
-HOMEPAGE="https://www.eggheads.org/"
-SRC_URI="https://ftp.eggheads.org/pub/eggdrop/source/${PV:0:3}/${MY_P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~riscv ~sparc ~x86"
-LICENSE="GPL-2+"
-SLOT="0"
-IUSE="debug doc ipv6 ssl static"
-
-DEPEND="
- dev-lang/tcl:0=
- ssl? ( dev-libs/openssl:0= )
-"
-RDEPEND="
- sys-apps/gentoo-functions
- ${DEPEND}
-"
-
-DOCS=( AUTHORS FEATURES INSTALL NEWS README THANKS UPGRADING )
-
-src_configure() {
- econf $(use_enable ssl tls) \
- $(use_enable ipv6 ipv6)
-
- emake config
-}
-
-src_compile() {
- local target
-
- if use static && use debug; then
- target="sdebug"
- elif use static; then
- target="static"
- elif use debug; then
- target="debug"
- fi
-
- emake ${target}
-}
-
-src_install() {
- emake DEST="${D}"/opt/eggdrop install
-
- use doc && HTML_DOCS=( doc/html/. )
- rm -r "${D}"/opt/eggdrop/doc/html || die
- DOC_CONTENTS="
- Additional documentation can be found
- in ${EPREFIX}/opt/eggdrop/doc
- "
- readme.gentoo_create_doc
- einstalldocs
-
- dobin "${FILESDIR}"/eggdrop-installer
- doman doc/man1/eggdrop.1
-}
-
-pkg_postinst() {
- # Only display this for new installs
- if [[ -z ${REPLACING_VERSIONS} ]]; then
- elog "Please run ${EPREFIX}/usr/bin/eggdrop-installer to install your eggdrop bot."
- fi
-}