summaryrefslogtreecommitdiff
path: root/net-irc/cgiirc/cgiirc-0.5.10.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-irc/cgiirc/cgiirc-0.5.10.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-irc/cgiirc/cgiirc-0.5.10.ebuild')
-rw-r--r--net-irc/cgiirc/cgiirc-0.5.10.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/net-irc/cgiirc/cgiirc-0.5.10.ebuild b/net-irc/cgiirc/cgiirc-0.5.10.ebuild
new file mode 100644
index 000000000000..33ab17fa90d5
--- /dev/null
+++ b/net-irc/cgiirc/cgiirc-0.5.10.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+EAPI=5
+
+inherit webapp eutils
+
+DESCRIPTION="A perl/CGI program to use IRC from a web browser"
+HOMEPAGE="http://cgiirc.org/"
+SRC_URI="http://cgiirc.org/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+need_httpd_cgi
+
+pkg_setup() {
+ webapp_pkg_setup
+ elog "Note that file locations have changed."
+ elog "CGI:IRC will be installed into cgi-bin/${P}"
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ ecvs_clean
+}
+
+src_install() {
+ webapp_src_preinst
+
+ local docs="README cgiirc.config.full ipaccess.example"
+
+ dodoc docs/{CHANGES,TODO} ${docs}
+ dohtml docs/help.html
+ rm -rf docs/ ${docs}
+
+ insinto "${MY_CGIBINDIR}"/${P}
+ doins -r .
+ fperms +x "${MY_CGIBINDIR}"/${P}/irc.cgi
+
+ webapp_configfile "${MY_CGIBINDIR}"/${P}/cgiirc.config
+ webapp_src_install
+}