summaryrefslogtreecommitdiff
path: root/net-irc/atheme-services/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-irc/atheme-services/files
reinit the tree, so we can have metadata
Diffstat (limited to 'net-irc/atheme-services/files')
-rw-r--r--net-irc/atheme-services/files/atheme-services-7.2.9-configure-logdir.patch25
-rw-r--r--net-irc/atheme-services/files/atheme-services-7.2.9-fix-docdir.patch13
-rw-r--r--net-irc/atheme-services/files/atheme-services.initd27
3 files changed, 65 insertions, 0 deletions
diff --git a/net-irc/atheme-services/files/atheme-services-7.2.9-configure-logdir.patch b/net-irc/atheme-services/files/atheme-services-7.2.9-configure-logdir.patch
new file mode 100644
index 000000000000..d57af2d9f445
--- /dev/null
+++ b/net-irc/atheme-services/files/atheme-services-7.2.9-configure-logdir.patch
@@ -0,0 +1,25 @@
+diff --git a/dist/atheme.conf.example b/dist/atheme.conf.example
+index ac3ed54dd..be1c2db50 100644
+--- a/dist/atheme.conf.example
++++ b/dist/atheme.conf.example
+@@ -1909,17 +1909,17 @@ ldap {
+ * This block logs all account and channel registrations and drops,
+ * and account and channel setting changes to var/account.log.
+ */
+-logfile "var/account.log" { register; set; };
++logfile "/var/log/atheme/account.log" { register; set; };
+
+ /*
+ * This block logs all command use to var/commands.log.
+ */
+-logfile "var/commands.log" { commands; };
++logfile "/var/log/atheme/commands.log" { commands; };
+
+ /*
+ * This block logs all security auditing information.
+ */
+-logfile "var/audit.log" { denycmd; };
++logfile "/var/log/atheme/audit.log" { denycmd; };
+
+ /*
+ * You can log to IRC channels, and even split it by category, too.
diff --git a/net-irc/atheme-services/files/atheme-services-7.2.9-fix-docdir.patch b/net-irc/atheme-services/files/atheme-services-7.2.9-fix-docdir.patch
new file mode 100644
index 000000000000..e7d4bb2695fc
--- /dev/null
+++ b/net-irc/atheme-services/files/atheme-services-7.2.9-fix-docdir.patch
@@ -0,0 +1,13 @@
+diff --git a/extra.mk.in b/extra.mk.in
+index 39053e48a..e47b27246 100644
+--- a/extra.mk.in
++++ b/extra.mk.in
+@@ -82,7 +82,7 @@ libdir ?= @libdir@
+ CFLAGS ?= @CFLAGS@
+ INSTALL_LIB ?= @INSTALL_LIB@
+ RUNDIR ?= @RUNDIR@
+-DOCDIR ?= @DOCDIR@
++DOCDIR ?= @docdir@
+ localstatedir ?= @localstatedir@
+ docdir ?= @docdir@
+ GREP ?= @GREP@
diff --git a/net-irc/atheme-services/files/atheme-services.initd b/net-irc/atheme-services/files/atheme-services.initd
new file mode 100644
index 000000000000..46a868380aa3
--- /dev/null
+++ b/net-irc/atheme-services/files/atheme-services.initd
@@ -0,0 +1,27 @@
+#!/sbin/openrc-run
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+extra_started_commands="reload"
+
+command="/usr/bin/atheme-services"
+command_user="atheme-services"
+pidfile="/var/run/atheme/atheme.pid"
+
+name="Atheme IRC Services"
+
+depend() {
+ need net
+ use ircd
+ provide irc-services
+}
+
+start_pre() {
+ checkpath -d "/var/run/atheme" -o atheme-services
+}
+
+reload() {
+ ebegin "Reloading ${SVCNAME}"
+ start-stop-daemon --signal HUP --pidfile "${pidfile}"
+ eend $?
+}