summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-07-01 08:00:51 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-07-01 08:00:51 +0100
commitd1c14e94a73fba924761cdad7298f3e48c6bc160 (patch)
tree60b97f0d81b3b06b06acc48ff8856d7c4afa2989 /net-im
parentd5ee59790ee8298b8599b0aa0fa21a98b972a44d (diff)
gentoo auto-resync : 01:07:2024 - 08:00:50
Diffstat (limited to 'net-im')
-rw-r--r--net-im/Manifest.gzbin9076 -> 9071 bytes
-rw-r--r--net-im/discord/Manifest3
-rw-r--r--net-im/discord/discord-0.0.58-r2.ebuild (renamed from net-im/discord/discord-0.0.58.ebuild)28
-rw-r--r--net-im/discord/files/launcher.sh17
4 files changed, 33 insertions, 15 deletions
diff --git a/net-im/Manifest.gz b/net-im/Manifest.gz
index a89fc3994791..b2342c3469d3 100644
--- a/net-im/Manifest.gz
+++ b/net-im/Manifest.gz
Binary files differ
diff --git a/net-im/discord/Manifest b/net-im/discord/Manifest
index 8f4a112f928a..405e61ab5a13 100644
--- a/net-im/discord/Manifest
+++ b/net-im/discord/Manifest
@@ -1,3 +1,4 @@
+AUX launcher.sh 356 BLAKE2B 8602814acb3c62bb04ed77050c1de8443db4cd03a5b213b882b5491f8df32a56b5d3091b573c9be09d3561c3ad8e88ae862aa0b0e098b15d6d46fc4f2bbb057d SHA512 dac1c622889630b5db7dd9d77684a0ad36e20796d6212bf89bdca69a51ea58f670b87a2f55c24c9f8f27aa04a50d0bcc868df3ec813b525f1c838b078fd30740
DIST discord-0.0.58.tar.gz 103212154 BLAKE2B 62b9d598c101c885cd87277020d1d1182fd288b4c3883f1f8b16f12fe62df81725dcc70167c644eb4195a0e6019004033f4775e37ae24382ff4eadddf0f0d465 SHA512 8efab6f4a476c05b620f3e95c082ae3f5423a2aaab310687f8b67711b0b34e7c82105e8c9ea5d4e0b92fc368443bc6a0e8970143d28ef7cb2d5f9e05f85b038d
-EBUILD discord-0.0.58.ebuild 3721 BLAKE2B eb82434169d7778ddba7a810dd18938a0b59c78c96bc40f94d2cdb2e650c88cce36b522e5ee6b1305b4d84d39b33d4124b3957c8803f87365e5d6ce12ae7d448 SHA512 dd2bb48a78953299459f3f8e48ff6cc9eb55b975623d1662b00d1b07a66b3bae1291d4be5f8aa09dea3b7a132643c9c58c977b0c6f0b331b7869eaaf4cbf2432
+EBUILD discord-0.0.58-r2.ebuild 3772 BLAKE2B 21587307a6c3f5511a3666f81ebfb8a9169c58939895cc43fd86eb3e3e6c8dfae47886cfddc6b80a124c20ef07100243f8b1a8de33b3e8c96f8113cb533e9908 SHA512 77eb8d8e7d8661ff8a740c5038b9c68cfbd1ff2c00cdacb51371f969a54a4f6cabc6d09e7fbeb9fa627515feac4c5343d7c62793dbf4361e4a61591730effc26
MISC metadata.xml 506 BLAKE2B ff098a1c9341a94ebb21da57c3028d3d96e884e19e3adf2df8d50b694a1ca3eee61f5dfd90eaa557a0a0eee769fd11dfa7bbf63308386a11faa56d13687e33c3 SHA512 56baf0a5323057b4af83a7b7d760b2b1e071e15ca4eef6546eab4104fbdd026906f68d8023a3155f492d8d93cd7022c5d0017372cbaf2894b94bd253b2ce3665
diff --git a/net-im/discord/discord-0.0.58.ebuild b/net-im/discord/discord-0.0.58-r2.ebuild
index e7dde173394c..2f44019d1175 100644
--- a/net-im/discord/discord-0.0.58.ebuild
+++ b/net-im/discord/discord-0.0.58-r2.ebuild
@@ -15,7 +15,7 @@ CHROMIUM_LANGS="
inherit chromium-2 desktop linux-info optfeature unpacker xdg
DESCRIPTION="All-in-one voice and text chat for gamers"
-HOMEPAGE="https://discordapp.com"
+HOMEPAGE="https://discord.com/"
SRC_URI="https://dl.discordapp.net/apps/linux/${MY_PV}/${MY_PN}-${MY_PV}.tar.gz"
S="${WORKDIR}/${MY_PN^}"
@@ -81,21 +81,20 @@ src_prepare() {
pushd "locales/" >/dev/null || die "location change for language cleanup failed"
chromium_remove_language_paks
popd >/dev/null || die "location reset for language cleanup failed"
+
# fix .desktop exec location
- sed -i "/Exec/s:/usr/share/discord/Discord:${DESTDIR}/${MY_PN^}:" \
+ sed --in-place --expression "/^Exec=/s:/usr/share/discord/Discord:/usr/bin/${MY_PN}:" \
"${MY_PN}.desktop" ||
die "fixing of exec location on .desktop failed"
- # USE wayland
- if use wayland; then
- sed -i '/Exec/s/Discord/Discord --enable-features=UseOzonePlatform --ozone-platform=wayland/' \
- "${MY_PN}.desktop" ||
- die "sed failed for wayland"
- fi
- # USE seccomp
- if ! use seccomp; then
- sed -i '/Exec/s/Discord/Discord --disable-seccomp-filter-sandbox/' \
- "${MY_PN}.desktop" ||
- die "sed failed for seccomp"
+
+ # Update exec location in launcher
+ sed --expression "s:@@DESTDIR@@:${DESTDIR}:" \
+ "${FILESDIR}/launcher.sh" > "${T}/launcher.sh" || die "updating of exec location in launcher failed"
+
+ # USE seccomp in launcher
+ if use seccomp; then
+ sed --in-place --expression '/^SECCOMP=/s/false/true/' \
+ "${T}/launcher.sh" || die "sed failed for seccomp"
fi
}
@@ -123,7 +122,8 @@ src_install() {
# See #903616 and #890595
[[ -x chrome_crashpad_handler ]] && doins chrome_crashpad_handler
- dosym "${DESTDIR}/${MY_PN^}" "/usr/bin/${MY_PN}"
+ exeinto "/usr/bin"
+ newexe "${T}/launcher.sh" "discord" || die "failing to install launcher"
# https://bugs.gentoo.org/898912
if use appindicator; then
diff --git a/net-im/discord/files/launcher.sh b/net-im/discord/files/launcher.sh
new file mode 100644
index 000000000000..032524ae68e9
--- /dev/null
+++ b/net-im/discord/files/launcher.sh
@@ -0,0 +1,17 @@
+#!/bin/env bash
+# coding: UTF-8
+
+
+declare -a discord_parameters
+
+SECCOMP=false
+
+[[ ! "${SECCOMP}" ]] && discord_parameters+=( --disable-seccomp-filter-sandbox )
+
+[[ -n "${WAYLAND_DISPLAY}" ]] && discord_parameters+=(
+ --enable-features=UseOzonePlatform
+ --ozone-platform=wayland
+ --enable-wayland-ime
+)
+
+@@DESTDIR@@/Discord "${discord_parameters[@]}" "$@"