summaryrefslogtreecommitdiff
path: root/net-im/whatsie/whatsie-4.14.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-30 15:21:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-30 15:21:07 +0100
commit1c19f0d8d940b35f723e28d8a6ebe388cfacd1d8 (patch)
treeb2aa98b0377065abe57bb3c714b3dea02e87b036 /net-im/whatsie/whatsie-4.14.1.ebuild
parent70e4bd5c8f26b1f2baeb5146a841273b2cb15179 (diff)
gentoo auto-resync : 30:05:2023 - 15:21:06
Diffstat (limited to 'net-im/whatsie/whatsie-4.14.1.ebuild')
-rw-r--r--net-im/whatsie/whatsie-4.14.1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/net-im/whatsie/whatsie-4.14.1.ebuild b/net-im/whatsie/whatsie-4.14.1.ebuild
new file mode 100644
index 000000000000..cecf52d1bc2d
--- /dev/null
+++ b/net-im/whatsie/whatsie-4.14.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qmake-utils xdg
+
+DESCRIPTION="Qt Based WhatsApp Client"
+HOMEPAGE="https://github.com/keshavbhatt/whatsie"
+SRC_URI="https://github.com/keshavbhatt/whatsie/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${P}/src"
+
+KEYWORDS="~amd64"
+LICENSE="MIT"
+SLOT="0"
+
+QT_MIN="5.15"
+
+DEPEND="
+ x11-libs/libX11
+ x11-libs/libxcb:=
+ >=dev-qt/qtcore-${QT_MIN}:5
+ >=dev-qt/qtgui-${QT_MIN}:5
+ >=dev-qt/qtnetwork-${QT_MIN}:5
+ >=dev-qt/qtpositioning-${QT_MIN}:5
+ >=dev-qt/qtwebengine-${QT_MIN}:5[widgets]
+ >=dev-qt/qtwidgets-${QT_MIN}:5
+"
+
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ eqmake5
+}
+
+src_install() {
+ einstalldocs
+ INSTALL_ROOT="${ED}" emake install
+}