summaryrefslogtreecommitdiff
path: root/net-im/telegram-desktop/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-04 01:15:40 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-04 01:15:40 +0100
commitc1bd8495f43d1e8a084ac779db6e4623aaa8d6ad (patch)
treee149dfa502bb9b798db46039ff95a0ed656a5567 /net-im/telegram-desktop/files
parentab6ac5a7942816b5b14186dc53e1b17ea7df200a (diff)
gentoo auto-resync : 04:10:2022 - 01:15:40
Diffstat (limited to 'net-im/telegram-desktop/files')
-rw-r--r--net-im/telegram-desktop/files/tdesktop-4.0.2-fix-gcc12-cstdint.patch10
-rw-r--r--net-im/telegram-desktop/files/tdesktop-4.2.4-jemalloc-only-telegram.patch43
2 files changed, 43 insertions, 10 deletions
diff --git a/net-im/telegram-desktop/files/tdesktop-4.0.2-fix-gcc12-cstdint.patch b/net-im/telegram-desktop/files/tdesktop-4.0.2-fix-gcc12-cstdint.patch
deleted file mode 100644
index a3d67e0c9a1b..000000000000
--- a/net-im/telegram-desktop/files/tdesktop-4.0.2-fix-gcc12-cstdint.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/Telegram/ThirdParty/tgcalls/tgcalls/utils/gzip.h
-+++ b/Telegram/ThirdParty/tgcalls/tgcalls/utils/gzip.h
-@@ -2,6 +2,7 @@
- #define TGCALLS_UTILS_GZIP_H
-
- #include <absl/types/optional.h>
-+#include <cstdint>
- #include <vector>
-
- namespace tgcalls {
diff --git a/net-im/telegram-desktop/files/tdesktop-4.2.4-jemalloc-only-telegram.patch b/net-im/telegram-desktop/files/tdesktop-4.2.4-jemalloc-only-telegram.patch
new file mode 100644
index 000000000000..a7710e145443
--- /dev/null
+++ b/net-im/telegram-desktop/files/tdesktop-4.2.4-jemalloc-only-telegram.patch
@@ -0,0 +1,43 @@
+Only link jemalloc for the Telegram binary
+
+Some combination of factors is making the different codegen tools hang when
+jemalloc is linked for those, and they're ran under portage's sandbox. Since
+this is only used during build-time, and jemalloc is merely necessary to
+improve runtime memory use, it's unnecessary to use it for anything else.
+
+https://bugs.gentoo.org/802624
+
+--- tdesktop-4.2.4-full.orig/Telegram/CMakeLists.txt
++++ tdesktop-4.2.4-full/Telegram/CMakeLists.txt
+@@ -1478,6 +1478,14 @@
+ desktop-app::external_wayland_client
+ )
+ endif()
++
++ if (NOT DESKTOP_APP_DISABLE_JEMALLOC)
++ target_link_libraries(Telegram
++ INTERFACE
++ $<TARGET_OBJECTS:desktop-app::linux_jemalloc_helper>
++ $<LINK_ONLY:desktop-app::external_jemalloc>
++ )
++ endif()
+ endif()
+
+ if (build_macstore)
+--- tdesktop-4.2.4-full.orig/cmake/options_linux.cmake
++++ tdesktop-4.2.4-full/cmake/options_linux.cmake
+@@ -78,14 +78,6 @@
+ )
+ endif()
+
+-if (NOT DESKTOP_APP_DISABLE_JEMALLOC)
+- target_link_libraries(common_options
+- INTERFACE
+- $<TARGET_OBJECTS:desktop-app::linux_jemalloc_helper>
+- $<LINK_ONLY:desktop-app::external_jemalloc>
+- )
+-endif()
+-
+ if (DESKTOP_APP_USE_ALLOCATION_TRACER)
+ target_link_options(common_options
+ INTERFACE