summaryrefslogtreecommitdiff
path: root/net-im/telegram-desktop/files/tdesktop-3.4.8-jemalloc-only-telegram.patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /net-im/telegram-desktop/files/tdesktop-3.4.8-jemalloc-only-telegram.patch
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'net-im/telegram-desktop/files/tdesktop-3.4.8-jemalloc-only-telegram.patch')
-rw-r--r--net-im/telegram-desktop/files/tdesktop-3.4.8-jemalloc-only-telegram.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/net-im/telegram-desktop/files/tdesktop-3.4.8-jemalloc-only-telegram.patch b/net-im/telegram-desktop/files/tdesktop-3.4.8-jemalloc-only-telegram.patch
new file mode 100644
index 000000000000..e99cd2e4bf91
--- /dev/null
+++ b/net-im/telegram-desktop/files/tdesktop-3.4.8-jemalloc-only-telegram.patch
@@ -0,0 +1,31 @@
+Only link jemalloc for the Telegram binary
+
+Some combination of factors is making the different codegen tools hang when
+jemalloc is linked for those, and they're ran under portage's sandbox. Since
+this is only used during build-time, and jemalloc is merely necessary to
+improve runtime memory use, it's unnecessary to use it for anything else.
+
+--- tdesktop-3.4.8-full.orig/Telegram/CMakeLists.txt
++++ tdesktop-3.4.8-full/Telegram/CMakeLists.txt
+@@ -1331,6 +1331,11 @@
+ endif()
+ endif()
+ else()
++ target_link_libraries(Telegram
++ PRIVATE
++ desktop-app::external_jemalloc
++ )
++
+ if (NOT DESKTOP_APP_DISABLE_DBUS_INTEGRATION)
+ target_link_libraries(Telegram
+ PRIVATE
+--- tdesktop-3.4.8-full.orig/cmake/options_linux.cmake
++++ tdesktop-3.4.8-full/cmake/options_linux.cmake
+@@ -65,7 +65,6 @@
+
+ target_link_libraries(common_options
+ INTERFACE
+- desktop-app::external_jemalloc
+ ${CMAKE_DL_LIBS}
+ )
+