summaryrefslogtreecommitdiff
path: root/net-im/skypeforlinux
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-08 09:04:53 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-08 09:04:53 +0100
commit73c318acdaf6f8309d68bd266051e6dd1f1bd787 (patch)
tree2878053f3e7faed19a1f82c733d3bd29df69991e /net-im/skypeforlinux
parent2018227e9344edb9da15fc6a4a8298086cc2aa77 (diff)
gentoo resync : 08.06.2019
Diffstat (limited to 'net-im/skypeforlinux')
-rw-r--r--net-im/skypeforlinux/Manifest2
-rw-r--r--net-im/skypeforlinux/skypeforlinux-8.46.0.60.ebuild102
2 files changed, 104 insertions, 0 deletions
diff --git a/net-im/skypeforlinux/Manifest b/net-im/skypeforlinux/Manifest
index 69bcc7eb00b3..1237d8daeb9c 100644
--- a/net-im/skypeforlinux/Manifest
+++ b/net-im/skypeforlinux/Manifest
@@ -1,3 +1,5 @@
DIST skypeforlinux_8.45.0.41-1.x86_64.rpm 98085869 BLAKE2B 6ade91a30ce302adc0b1437508ccddad6505c97f5d26a8fc6afbf2a1670a201e450a158e5ba786e4a48f444482304bf19aa869990b7aad5aac1c56af8e338c73 SHA512 af1ff07cabce98058c7b9ca11456f57da2b49dd1c89cd12add03954e2ff7e591cc8254c9146c7b5137c414769357b7f57ff370a7803fa1b17ba34c4a87bb5ef2
+DIST skypeforlinux_8.46.0.60-1.x86_64.rpm 98406332 BLAKE2B 96cb9ce76ec5278254fa2891a82b66481d1dbbc75cde7f51fd9dab7cd681ccd5c34c5777c0e639166c2268e03b58fcc844961b589f8248b68374f17bec516a41 SHA512 679ef60427fc5435d14e54eea4bebdb93909dbab8aa7803994fa8fa9077a73c3b2366ea120a80a9a12aa5a23ee5e8a34b67232850686f6350a69e13fc5bce41a
EBUILD skypeforlinux-8.45.0.41.ebuild 3294 BLAKE2B 80c2ad78fdb0c777ee182171f30af1c19d42bf745a3f8fb7ca6b3ed3fa63f01bb46a3f039dc0aee30021b90b0c2dc0239e239e97277f4b3335d4a53d1ff31b52 SHA512 050abf41c4f63485b144e95123a5910f0663189e5abc03e6a6055c7a5c61c721de3d5a2c115402e0365dbf646bb517a5ef1416426af856f2ddcf25e4ca5dc887
+EBUILD skypeforlinux-8.46.0.60.ebuild 3290 BLAKE2B 6ba778ac15813855972a0f8a7841186e23b42766a465db44c825b699cf79e5a399c540c71ec0705b243bbe08c73c02efc9077495c4cf1f77edd8ef6e07463171 SHA512 50e044c7e7e5ae986d8465e9842dc8aebf8a888076c192ad4fcb0597010da224358f2ea7bf2e9de0f29108c6ae4563b6bc2af0337d29e2c45303d77a5f707b48
MISC metadata.xml 678 BLAKE2B 08cae428a7267eb18dd5bbb460dcb617a8eaaf33ccce7229f90e3031f526125922b84d445577e91620e01ccaf789109c331bb11a03362cec9c15ad85162f4b43 SHA512 5372348bd01b1e828c29866180e85e9230ade0aa36f23bfcc89fb10dbf7f1b92530ac00c9dd0fe9977061a660abf9780ab2e59069db2115fb2dacbc5e3ffd26a
diff --git a/net-im/skypeforlinux/skypeforlinux-8.46.0.60.ebuild b/net-im/skypeforlinux/skypeforlinux-8.46.0.60.ebuild
new file mode 100644
index 000000000000..df398450e030
--- /dev/null
+++ b/net-im/skypeforlinux/skypeforlinux-8.46.0.60.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MULTILIB_COMPAT=( abi_x86_64 )
+
+inherit desktop pax-utils rpm multilib-build xdg
+
+DESCRIPTION="Instant messaging client, with support for audio and video"
+HOMEPAGE="https://www.skype.com/"
+SRC_URI="https://repo.skype.com/rpm/stable/${PN}_${PV}-1.x86_64.rpm"
+
+LICENSE="Skype-TOS MIT MIT-with-advertising BSD-1 BSD-2 BSD Apache-2.0 Boost-1.0 ISC CC-BY-SA-3.0 CC0-1.0 openssl ZLIB APSL-2 icu Artistic-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+IUSE="pax_kernel"
+
+S="${WORKDIR}"
+QA_PREBUILT="*"
+RESTRICT="mirror bindist strip" #299368
+
+RDEPEND="
+ || (
+ sys-auth/elogind
+ sys-apps/systemd
+ )
+ app-crypt/libsecret[${MULTILIB_USEDEP}]
+ dev-libs/atk[${MULTILIB_USEDEP}]
+ dev-libs/expat[${MULTILIB_USEDEP}]
+ dev-libs/glib:2[${MULTILIB_USEDEP}]
+ dev-libs/nspr[${MULTILIB_USEDEP}]
+ dev-libs/nss[${MULTILIB_USEDEP}]
+ media-libs/alsa-lib[${MULTILIB_USEDEP}]
+ media-libs/fontconfig:1.0[${MULTILIB_USEDEP}]
+ media-libs/freetype:2[${MULTILIB_USEDEP}]
+ media-libs/libv4l[${MULTILIB_USEDEP}]
+ net-print/cups[${MULTILIB_USEDEP}]
+ sys-apps/dbus[${MULTILIB_USEDEP}]
+ sys-devel/gcc[cxx]
+ virtual/ttf-fonts
+ x11-libs/cairo[${MULTILIB_USEDEP}]
+ x11-libs/gdk-pixbuf:2[${MULTILIB_USEDEP}]
+ x11-libs/gtk+:3[${MULTILIB_USEDEP}]
+ x11-libs/libX11[${MULTILIB_USEDEP}]
+ x11-libs/libXScrnSaver[${MULTILIB_USEDEP}]
+ x11-libs/libXcomposite[${MULTILIB_USEDEP}]
+ x11-libs/libXcursor[${MULTILIB_USEDEP}]
+ x11-libs/libXdamage[${MULTILIB_USEDEP}]
+ x11-libs/libXext[${MULTILIB_USEDEP}]
+ x11-libs/libXfixes[${MULTILIB_USEDEP}]
+ x11-libs/libXi[${MULTILIB_USEDEP}]
+ x11-libs/libXrandr[${MULTILIB_USEDEP}]
+ x11-libs/libXrender[${MULTILIB_USEDEP}]
+ x11-libs/libXtst[${MULTILIB_USEDEP}]
+ x11-libs/libxcb[${MULTILIB_USEDEP}]
+ x11-libs/libxkbfile[${MULTILIB_USEDEP}]
+ x11-libs/pango[${MULTILIB_USEDEP}]"
+
+src_unpack() {
+ rpm_src_unpack ${A}
+}
+
+src_prepare() {
+ default
+ sed -e "s!^SKYPE_PATH=.*!SKYPE_PATH=${EPREFIX}/opt/skypeforlinux/skypeforlinux!" \
+ -i usr/bin/skypeforlinux || die
+ sed -e "s!^Categories=.*!Categories=Network;InstantMessaging;Telephony;!" \
+ -e "/^OnlyShowIn=/d" \
+ -i usr/share/applications/skypeforlinux.desktop || die
+}
+
+src_install() {
+ dodir /opt
+ cp -a usr/share/skypeforlinux "${D}"/opt || die
+
+ dobin usr/bin/skypeforlinux
+
+ dodoc usr/share/skypeforlinux/*.html
+ dodoc -r usr/share/doc/skypeforlinux/.
+ # symlink required for the "Help->3rd Party Notes" menu entry (otherwise frozen skype -> xdg-open)
+ dosym ${PF} usr/share/doc/skypeforlinux
+
+ doicon usr/share/pixmaps/skypeforlinux.png
+
+ local res
+ for res in 16 32 256 512; do
+ newicon -s ${res} usr/share/icons/hicolor/${res}x${res}/apps/skypeforlinux.png skypeforlinux.png
+ done
+
+ domenu usr/share/applications/skypeforlinux.desktop
+
+ if use pax_kernel; then
+ pax-mark -m "${ED}"/opt/skypeforlinux/skypeforlinux
+ pax-mark -m "${ED}"/opt/skypeforlinux/resources/app.asar.unpacked/node_modules/slimcore/bin/slimcore.node
+ ewarn "You have set USE=pax_kernel meaning that you intend to run"
+ ewarn "${PN} under a PaX enabled kernel. To do so, we must modify"
+ ewarn "the ${PN} binary itself and this *may* lead to breakage! If"
+ ewarn "you suspect that ${PN} is being broken by this modification,"
+ ewarn "please open a bug."
+ fi
+}