summaryrefslogtreecommitdiff
path: root/net-im/sendxmpp-amm/sendxmpp-amm-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-20 13:07:51 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-20 13:07:51 +0100
commit30114ae8ef07a32fea1e44a10b61f98c84142645 (patch)
tree1f5829906b913ee4637e04254cc50ffc1faab519 /net-im/sendxmpp-amm/sendxmpp-amm-9999.ebuild
parentaaa44376d7162304219748a3b6771d9a26fc80fe (diff)
gentoo auto-resync : 20:07:2023 - 13:07:51
Diffstat (limited to 'net-im/sendxmpp-amm/sendxmpp-amm-9999.ebuild')
-rw-r--r--net-im/sendxmpp-amm/sendxmpp-amm-9999.ebuild21
1 files changed, 18 insertions, 3 deletions
diff --git a/net-im/sendxmpp-amm/sendxmpp-amm-9999.ebuild b/net-im/sendxmpp-amm/sendxmpp-amm-9999.ebuild
index 782316d17024..c5dec761f9fd 100644
--- a/net-im/sendxmpp-amm/sendxmpp-amm-9999.ebuild
+++ b/net-im/sendxmpp-amm/sendxmpp-amm-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -13,7 +13,7 @@ if [[ "${PV}" == "9999" ]] || [[ -n "${EGIT_COMMIT_ID}" ]]; then
inherit git-r3
else
SRC_URI="https://github.com/flowdalic/${ORIG_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64"
+ KEYWORDS="amd64"
S="${WORKDIR}/${ORIG_PN}-${PV}"
fi
@@ -22,6 +22,21 @@ LICENSE="GPL-3+"
SLOT="0"
RDEPEND="
- dev-lang/ammonite-repl-bin
+ dev-lang/ammonite-repl-bin[scala2-13]
!net-im/sendxmpp
"
+
+src_prepare() {
+ default
+ # Ensure that the script is using the right Scala version.
+ sed -i '1 s;^.*$;#!/usr/bin/env amm-2.13;' sendxmpp.sc || die
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ default
+ newbin sendxmpp.sc sendxmpp
+}