summaryrefslogtreecommitdiff
path: root/net-im/sendxmpp-amm/sendxmpp-amm-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /net-im/sendxmpp-amm/sendxmpp-amm-9999.ebuild
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'net-im/sendxmpp-amm/sendxmpp-amm-9999.ebuild')
-rw-r--r--net-im/sendxmpp-amm/sendxmpp-amm-9999.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/net-im/sendxmpp-amm/sendxmpp-amm-9999.ebuild b/net-im/sendxmpp-amm/sendxmpp-amm-9999.ebuild
new file mode 100644
index 000000000000..ef6656d8a9fc
--- /dev/null
+++ b/net-im/sendxmpp-amm/sendxmpp-amm-9999.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ORIG_PN="${PN%-amm}"
+
+DESCRIPTION="Send XMPP (Jabber) messages via command line"
+HOMEPAGE="https://github.com/flowdalic/sendxmpp"
+
+if [[ "${PV}" == "9999" ]] || [[ -n "${EGIT_COMMIT_ID}" ]]; then
+ EGIT_REPO_URI="https://github.com/Flowdalic/${ORIG_PN}.git"
+ inherit git-r3
+ if [[ "${PV}" == "9999" ]]; then
+ MY_KEYWORDS=""
+ fi
+else
+ SRC_URI="https://github.com/flowdalic/${ORIG_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/${ORIG_PN}-${PV}"
+fi
+
+LICENSE="GPL-3+"
+
+SLOT="0"
+
+RDEPEND="
+ dev-lang/ammonite-repl-bin
+ !net-im/sendxmpp
+"