summaryrefslogtreecommitdiff
path: root/net-im/qtox
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-21 22:01:02 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-21 22:01:02 +0100
commit5b4f35741ef91e9b4a33e2bcc60f209927c6cc5d (patch)
tree50e96933fe16359ee4b5174ecb023721876f47f9 /net-im/qtox
parentb80ebc4dea5609f6644d0d64c5ace579df314923 (diff)
gentoo auto-resync : 21:10:2023 - 22:01:01
Diffstat (limited to 'net-im/qtox')
-rw-r--r--net-im/qtox/Manifest3
-rw-r--r--net-im/qtox/qtox-1.17.6-r2.ebuild90
-rw-r--r--net-im/qtox/qtox-9999.ebuild7
3 files changed, 95 insertions, 5 deletions
diff --git a/net-im/qtox/Manifest b/net-im/qtox/Manifest
index 6efd27cd1644..26a90a979642 100644
--- a/net-im/qtox/Manifest
+++ b/net-im/qtox/Manifest
@@ -1,4 +1,5 @@
DIST qTox-1.17.6.tar.gz 4777590 BLAKE2B d67ea8c1d5c478a791fd8594866130874c036f22ec9fd991e0f6c81fb7919824bba8e13675b0ffaf613188215a4fce6d07545476ab5565922b3989519aedd91f SHA512 840dfbca2cb1a3db4b5ab27cb408e183b152fcd87c0cb915ee58245e7c311b8682605e73497248072a5a48b239058b101a85235ed169d19606dc7bf61865f208
EBUILD qtox-1.17.6-r1.ebuild 1907 BLAKE2B e5990e06e0fea8bea9980144e83cdf1ea3248c6cb11121d200e4f86b532ad18c983cf6342357b9d2996660f8555a2afe808f3022477c84e5a3ae69039612afe3 SHA512 d8baf5cb15e0cf4107d160199fc4aa4d8c54be7fd181e4d48a75c95f4ca5d58350203e524a3bd93139b474efdb4f5208f5cd1c592f95555c51ca741595bf32c6
-EBUILD qtox-9999.ebuild 1974 BLAKE2B b6a41a47641cf6c9b675127f969d78d4c47a6bd7d52e77305b23e18cf917f29f38b610074cfc5ec3f790b1c63c87aa665f9ab89fa747d58dbc7c86ef9203874c SHA512 6ea3bec44d4e3efd9219017630d14a1b82ca528dfd2c866d2f92ed09b486bb948e2c746421d1adeae1c57be7a7321c71b6f54b557be93f3433054a6076cec5f0
+EBUILD qtox-1.17.6-r2.ebuild 1838 BLAKE2B 267765a38749f90944c163ed8a2824b50bb48d2de674eb6f43fdf60236722db3a384d255e974b617ab21060221da757bb8842a8fff3439916fd000bb626aeb61 SHA512 6f99be4e0a4d023d43c9fea6212a7add413b3e307410b07d585cc9c58db9814bc24f3388ecc52c2881dabd347d750461f7b9aa4a470f91bceb2eb2f5c0560544
+EBUILD qtox-9999.ebuild 1904 BLAKE2B 26aeae3d8cad449919a97dd1c0d06ae2d905922b53299076c93be1a5496824ad2476740ef8a916cc6feb69331f5e0e82da2592a942c24a37a598faae7c38667a SHA512 bae7201f518bddd60efb3eee8c01f60276940b0d253d2df70c69f7cb6cb48f19756e2368693d71eb7f091b4dc62506ac414832c5e2228821b3347f0f12ecf29d
MISC metadata.xml 525 BLAKE2B 31228a7dfbdc87a19acd0a33ad2a2189dfd6ed00fb2491261eea5f16cdf173292208aae764a737b0f78c8fb274ead0682956f752f7325853b407b22a84e21141 SHA512 c739994bb478780c5e58ef7a3cef231e2c0202907f04bd2f2889b39c8338ae342f702b1aa5f8d65cbae07709bbdbb810b79b6b685e27fca009a758ca5afe9f24
diff --git a/net-im/qtox/qtox-1.17.6-r2.ebuild b/net-im/qtox/qtox-1.17.6-r2.ebuild
new file mode 100644
index 000000000000..26c612874adc
--- /dev/null
+++ b/net-im/qtox/qtox-1.17.6-r2.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake xdg
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/qTox/qTox.git"
+else
+ MY_P="qTox-${PV}"
+ SRC_URI="https://github.com/qTox/qTox/releases/download/v${PV}/v${PV}.tar.gz -> ${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/qTox"
+fi
+
+DESCRIPTION="Instant messaging client using the encrypted p2p Tox protocol"
+HOMEPAGE="https://qtox.github.io/"
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="+spellcheck test X"
+
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+ virtual/pkgconfig
+"
+RDEPEND="
+ dev-db/sqlcipher
+ dev-libs/libsodium:=
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5[gif(+),jpeg,png,X(-)]
+ dev-qt/qtnetwork:5
+ dev-qt/qtopengl:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ media-gfx/qrencode:=
+ media-libs/libexif
+ media-libs/openal
+ media-video/ffmpeg:=[webp,v4l]
+ >=net-libs/tox-0.2.13:=[av]
+ spellcheck? ( kde-frameworks/sonnet:5 )
+ X? (
+ x11-libs/libX11
+ x11-libs/libXScrnSaver
+ )
+"
+DEPEND="${RDEPEND}
+ test? ( dev-qt/qttest:5 )
+ X? ( x11-base/xorg-proto )
+"
+
+DOCS=( CHANGELOG.md README.md doc/user_manual_en.md )
+
+src_prepare() {
+ cmake_src_prepare
+
+ # bug 628574
+ if ! use test; then
+ sed -i CMakeLists.txt -e "/include(Testing)/d" || die
+ sed -i cmake/Dependencies.cmake -e "/find_package(Qt5Test/d" || die
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DPLATFORM_EXTENSIONS=$(usex X)
+ -DUPDATE_CHECK=OFF
+ -DUSE_CCACHE=OFF
+ -DSPELL_CHECK=$(usex spellcheck)
+ -DSVGZ_ICON=ON
+ -DASAN=OFF
+ -DDESKTOP_NOTIFICATIONS=OFF
+ -DSTRICT_OPTIONS=OFF
+ )
+
+ [[ ${PV} != 9999 ]] && mycmakeargs+=( -DGIT_DESCRIBE=${PV} )
+
+ cmake_src_configure
+}
+
+src_test() {
+ # The excluded tests require network access.
+ cmake_src_test -E "test_(bsu|core)"
+}
diff --git a/net-im/qtox/qtox-9999.ebuild b/net-im/qtox/qtox-9999.ebuild
index fe8a64494ea3..efe18c5045f9 100644
--- a/net-im/qtox/qtox-9999.ebuild
+++ b/net-im/qtox/qtox-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -20,7 +20,7 @@ HOMEPAGE="https://qtox.github.io/"
LICENSE="GPL-3+"
SLOT="0"
-IUSE="notification +spellcheck test X"
+IUSE="+spellcheck test X"
RESTRICT="!test? ( test )"
@@ -46,7 +46,6 @@ RDEPEND="
>=net-libs/tox-0.2.13:=[av]
>=net-libs/toxext-0.0.3
>=net-libs/tox_extension_messages-0.0.3
- notification? ( x11-libs/snorenotify )
spellcheck? ( kde-frameworks/sonnet:5 )
X? (
x11-libs/libX11
@@ -78,7 +77,7 @@ src_configure() {
-DSPELL_CHECK=$(usex spellcheck)
-DSVGZ_ICON=ON
-DASAN=OFF
- -DDESKTOP_NOTIFICATIONS=$(usex notification)
+ -DDESKTOP_NOTIFICATIONS=OFF
-DSTRICT_OPTIONS=OFF
)