summaryrefslogtreecommitdiff
path: root/net-im/prosody
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /net-im/prosody
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'net-im/prosody')
-rw-r--r--net-im/prosody/Manifest2
-rw-r--r--net-im/prosody/prosody-0.11.13.ebuild102
2 files changed, 104 insertions, 0 deletions
diff --git a/net-im/prosody/Manifest b/net-im/prosody/Manifest
index 6ca8240206bf..cd3642707cec 100644
--- a/net-im/prosody/Manifest
+++ b/net-im/prosody/Manifest
@@ -3,5 +3,7 @@ AUX prosody.initd-r5 987 BLAKE2B 3e381f48cbc9c5361bdc6cb9ab4a13daf055cd35389036b
AUX prosody.service-r2 228 BLAKE2B 61741cb7ecf64777b516a1fcb4e8e8c5c7b9c5d92dafbf7f691c36910f41d0b81d701bf8f287aea89fa368071c0c94a38f56ff3134055eb01842b578d8b57991 SHA512 0499588d1fd6e970575785b4bdaf631428601bec8a57051558c1d4c82bc74462f17d7568b8d433b14f15c51c94b181f4240d9f4574d51dcfeda291f0a68eb6f1
AUX prosody.tmpfilesd-r1 36 BLAKE2B dfb5025508cc62b4cd53de35b83f47bfee61821fbfe3301c1b67a4324ab753067cd3ecd84f56ae9a0241395a50d90ce2ec49c9333dc3378798a290e638a56cf9 SHA512 13a99fb925f7c3584dbfcbc98b3b929b67e165f70d700a25a861e512becd8a21ca48ee385da67ead23beeb68a43aaa10a2cfd342d1b3184883fede5d985cb599
DIST prosody-0.11.12.tar.gz 439656 BLAKE2B 593bb24d7e84ed337e8d8a11b387ac50abd27ea62be0fd18e8c8441472c09565a6603ccb070250b620b3f50f4d1e33fad579f988e68250c083b8a9aa25a8e03b SHA512 cd03ee8b02ffaa478b5329d9942d833cfed2d8bf720bf580a2082d681e7d333bc34f45041cea7234bee75f1a0e7c07983a685fe2ac9b31d51a0dbb36e87ba5d2
+DIST prosody-0.11.13.tar.gz 439816 BLAKE2B 8ace9001fe93d6349c744d17c7bccbf18c8704615cea856efcadd2de54430a64241cf7930345163e7bb6067aa4731da15dde4fc7f3ddb868b0680facc5368230 SHA512 7616785536b7b51767a26963a80c961ef2403609e1e78dda3f88cf68c00d5bb899278c70a22b006b58c36c62cbb1bbd390a9298bad5b8d6524928a1cd5457813
EBUILD prosody-0.11.12.ebuild 2857 BLAKE2B 0d8254cac3b9616f02c374f308efaa073b77ca204952f788db5785409028b6dd8f162c7267f09de11e3327f83b434c23af57cda997594c2b4ec06f62d7cd091a SHA512 2603123885f1e0f696835c26a06e052b11998205d6cb78030222280760201f368facccd573fe767a2754ce0b378223a180fa3b545858a93aec715c7aa3f6d24d
+EBUILD prosody-0.11.13.ebuild 2859 BLAKE2B fc318edc0ee24b64b2a2dde1ee08f46cce57379e68cd9efcd1f9186fb51808bb58ab4d7b83b4ccbbaaf88632d4daca922e6e0136f6391567ea16d672750b20a7 SHA512 b594518da924cebc7d58a72aab64a3b10cc4d64f3056bd4f0ba34ac3087a773e4fc07db392842996beb619de0018aff196fa9f2283af9a9996b9e8cdd89e8a5e
MISC metadata.xml 670 BLAKE2B 448bf5ede2b6f09940c51fdff4642e18be22d9c3dac637271c7c8bcfde1b4af0853e2623c55c00efcd8757ef863ac37fdb895606e572911a62a1c9d5f32cc693 SHA512 6177b8e3d2ed1aeeae2f369dc693283a3f811953f71be0e004eea402aa421d89973dbefe79c8fd198e9f9f82e4b345552dc3a2c3597c05927dc1a518cacbaf1d
diff --git a/net-im/prosody/prosody-0.11.13.ebuild b/net-im/prosody/prosody-0.11.13.ebuild
new file mode 100644
index 000000000000..9a4dc0782f50
--- /dev/null
+++ b/net-im/prosody/prosody-0.11.13.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-{1..3} luajit )
+LUA_REQ_USE="deprecated(+)"
+
+inherit lua-single systemd tmpfiles toolchain-funcs
+
+DESCRIPTION="Prosody is a modern XMPP communication server"
+HOMEPAGE="https://prosody.im/"
+SRC_URI="https://prosody.im/downloads/source/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="icu +idn +libevent mysql postgres selinux +sqlite +ssl test +zlib"
+REQUIRED_USE="
+ ^^ ( icu idn )
+ ${LUA_REQUIRED_USE}
+"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ $(lua_gen_cond_dep 'dev-lua/luaexpat[${LUA_USEDEP}]')
+ $(lua_gen_cond_dep 'dev-lua/luafilesystem[${LUA_USEDEP}]')
+ $(lua_gen_cond_dep 'dev-lua/luasocket[${LUA_USEDEP}]')
+ net-im/jabber-base
+ icu? ( dev-libs/icu:= )
+ idn? ( net-dns/libidn:= )
+ libevent? ( $(lua_gen_cond_dep 'dev-lua/luaevent[${LUA_USEDEP}]') )
+ dev-libs/openssl:0=
+ lua_single_target_lua5-1? ( $(lua_gen_cond_dep 'dev-lua/lua-bit32[lua_targets_lua5-1(-)]') )
+ mysql? ( $(lua_gen_cond_dep 'dev-lua/luadbi[mysql,${LUA_USEDEP}]') )
+ postgres? ( $(lua_gen_cond_dep 'dev-lua/luadbi[postgres,${LUA_USEDEP}]') )
+ sqlite? ( $(lua_gen_cond_dep 'dev-lua/luadbi[sqlite,${LUA_USEDEP}]') )
+ ssl? ( $(lua_gen_cond_dep 'dev-lua/luasec[${LUA_USEDEP}]') )
+ zlib? ( $(lua_gen_cond_dep 'dev-lua/lua-zlib[${LUA_USEDEP}]') )
+ ${LUA_DEPS}
+"
+
+RDEPEND="
+ ${DEPEND}
+ selinux? ( sec-policy/selinux-jabber )
+"
+
+BDEPEND="
+ virtual/pkgconfig
+ test? ( $(lua_gen_cond_dep 'dev-lua/busted[${LUA_USEDEP}]') )
+"
+
+PATCHES=( "${FILESDIR}/${PN}-0.11.7-gentoo.patch" )
+
+src_prepare() {
+ default
+
+ # Set correct plugin path for optional net-im/prosody-modules package
+ sed -e "s/GENTOO_LIBDIR/$(get_libdir)/g" -i prosody.cfg.lua.dist || die
+}
+
+src_configure() {
+ local myeconfargs=(
+ --add-cflags="${CFLAGS}"
+ --add-ldflags="${LDFLAGS}"
+ --c-compiler="$(tc-getCC)"
+ --datadir="${EPREFIX}/var/spool/jabber"
+ --idn-library="$(usex idn 'idn' 'icu')"
+ --libdir="${EPREFIX}/usr/$(get_libdir)"
+ --linker="$(tc-getCC)"
+ --lua-version="$(usex lua_single_target_luajit '5.1' $(ver_cut 1-2 $(lua_get_version)))"
+ --no-example-certs
+ --ostype="linux"
+ --prefix="${EPREFIX}/usr"
+ --runwith="${ELUA}"
+ --sysconfdir="${EPREFIX}/etc/jabber"
+ --with-lua-include="${EPREFIX}/$(lua_get_include_dir)"
+ --with-lua-lib="${EPREFIX}/$(lua_get_cmod_dir)"
+ )
+
+ # Since the configure script is handcrafted,
+ # and yells at unknown options, do not use 'econf'.
+ ./configure "${myeconfargs[@]}" || die
+
+ rm makefile || die
+ mv GNUmakefile Makefile || die
+}
+
+src_install() {
+ default
+
+ keepdir /var/spool/jabber
+
+ newinitd "${FILESDIR}"/prosody.initd-r5 prosody
+ systemd_newunit "${FILESDIR}"/prosody.service-r2 prosody.service
+
+ newtmpfiles "${FILESDIR}"/prosody.tmpfilesd-r1 prosody.conf
+}
+
+pkg_postinst() {
+ tmpfiles_process prosody.conf
+}