summaryrefslogtreecommitdiff
path: root/net-im/prosody
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
commit93a93e9a3b53c1a73142a305ea1f8136846942ee (patch)
treeb9791a06ab3284e27b568412c59316c66240c682 /net-im/prosody
parent2771f79232c273bc2a57d23bf335dd81ccf6af28 (diff)
gentoo resync : 22.12.2021
Diffstat (limited to 'net-im/prosody')
-rw-r--r--net-im/prosody/Manifest2
-rw-r--r--net-im/prosody/prosody-0.11.11.ebuild102
2 files changed, 104 insertions, 0 deletions
diff --git a/net-im/prosody/Manifest b/net-im/prosody/Manifest
index 9351ad83fd23..2cbaaa5fa866 100644
--- a/net-im/prosody/Manifest
+++ b/net-im/prosody/Manifest
@@ -3,5 +3,7 @@ AUX prosody.initd-r5 987 BLAKE2B 3e381f48cbc9c5361bdc6cb9ab4a13daf055cd35389036b
AUX prosody.service-r2 228 BLAKE2B 61741cb7ecf64777b516a1fcb4e8e8c5c7b9c5d92dafbf7f691c36910f41d0b81d701bf8f287aea89fa368071c0c94a38f56ff3134055eb01842b578d8b57991 SHA512 0499588d1fd6e970575785b4bdaf631428601bec8a57051558c1d4c82bc74462f17d7568b8d433b14f15c51c94b181f4240d9f4574d51dcfeda291f0a68eb6f1
AUX prosody.tmpfilesd-r1 36 BLAKE2B dfb5025508cc62b4cd53de35b83f47bfee61821fbfe3301c1b67a4324ab753067cd3ecd84f56ae9a0241395a50d90ce2ec49c9333dc3378798a290e638a56cf9 SHA512 13a99fb925f7c3584dbfcbc98b3b929b67e165f70d700a25a861e512becd8a21ca48ee385da67ead23beeb68a43aaa10a2cfd342d1b3184883fede5d985cb599
DIST prosody-0.11.10.tar.gz 438888 BLAKE2B 590f97f4eb8a333701eca516de3c3bcee9cf093267d2000af03b48d32396a1be21a0cf2f8ff542e7fbcb8419138bab5cf411f71b17666593559004a8a9674367 SHA512 419d8f8465f1807015f0a52d8f35ee89892b0869084dae38b60fc833d63c3d70892d8e59ae00039cd15e0e25f46d042954896f51f8c0520650a877f5296707cb
+DIST prosody-0.11.11.tar.gz 439395 BLAKE2B d9662ff9e5a767aaee86c2b0762249c702e755191359ee276f37019ac98fab52d75a23590f0c3a14f3bfde356cc2bd9802e842e1f1a7ea5da8ec3d034fa028a0 SHA512 eb9851e1b279bef894d556ca6bc6210d1cd55e0c02a9d475f74e6e6b4a2dfef704fd3de77b71cff97909925c48c60940c34cfb541e6f3801e23e90ea21d119a9
EBUILD prosody-0.11.10.ebuild 2855 BLAKE2B 5ef0b0509a1785f01fd408585cbea1d9de23e65df65768eaa4f0e7e6aae65f321cc8e19c2a539283445b23034ba1a2238f14c7f51152d265c3d814668ac63ec2 SHA512 fdac2d0644f9e0f4f8544cca19ee3bedcecce696125d10af6709432f6001b0df02b24f57c6ad0367b2b89b67f03f6681e9a3d357f803c5c0a0db1956c1b7bba2
+EBUILD prosody-0.11.11.ebuild 2859 BLAKE2B 1843bcffff044c16f4ea44fc1d5df451348f670b0d0c5f044e8e6637fd461821cac7b48ab9b4eeb030fba823ec6b37792cc7be3718c92583f9cfc414df28d444 SHA512 685b158625923e67336104f6937f56ba742c7af66f7ccda252a162332efc7be054d731d26c9ffd354de3a4c19ad12e2317b4b0a87151614ede20251eae54b0fa
MISC metadata.xml 670 BLAKE2B 448bf5ede2b6f09940c51fdff4642e18be22d9c3dac637271c7c8bcfde1b4af0853e2623c55c00efcd8757ef863ac37fdb895606e572911a62a1c9d5f32cc693 SHA512 6177b8e3d2ed1aeeae2f369dc693283a3f811953f71be0e004eea402aa421d89973dbefe79c8fd198e9f9f82e4b345552dc3a2c3597c05927dc1a518cacbaf1d
diff --git a/net-im/prosody/prosody-0.11.11.ebuild b/net-im/prosody/prosody-0.11.11.ebuild
new file mode 100644
index 000000000000..c8a34767663f
--- /dev/null
+++ b/net-im/prosody/prosody-0.11.11.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-{1..3} luajit )
+LUA_REQ_USE="deprecated(+)"
+
+inherit lua-single systemd tmpfiles toolchain-funcs
+
+DESCRIPTION="Prosody is a modern XMPP communication server"
+HOMEPAGE="https://prosody.im/"
+SRC_URI="https://prosody.im/downloads/source/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="icu +idn +libevent mysql postgres selinux +sqlite +ssl test +zlib"
+REQUIRED_USE="
+ ^^ ( icu idn )
+ ${LUA_REQUIRED_USE}
+"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ $(lua_gen_cond_dep 'dev-lua/luaexpat[${LUA_USEDEP}]')
+ $(lua_gen_cond_dep 'dev-lua/luafilesystem[${LUA_USEDEP}]')
+ $(lua_gen_cond_dep 'dev-lua/luasocket[${LUA_USEDEP}]')
+ net-im/jabber-base
+ icu? ( dev-libs/icu:= )
+ idn? ( net-dns/libidn:= )
+ libevent? ( $(lua_gen_cond_dep 'dev-lua/luaevent[${LUA_USEDEP}]') )
+ dev-libs/openssl:0=
+ lua_single_target_lua5-1? ( $(lua_gen_cond_dep 'dev-lua/lua-bit32[lua_targets_lua5-1(-)]') )
+ mysql? ( $(lua_gen_cond_dep 'dev-lua/luadbi[mysql,${LUA_USEDEP}]') )
+ postgres? ( $(lua_gen_cond_dep 'dev-lua/luadbi[postgres,${LUA_USEDEP}]') )
+ sqlite? ( $(lua_gen_cond_dep 'dev-lua/luadbi[sqlite,${LUA_USEDEP}]') )
+ ssl? ( $(lua_gen_cond_dep 'dev-lua/luasec[${LUA_USEDEP}]') )
+ zlib? ( $(lua_gen_cond_dep 'dev-lua/lua-zlib[${LUA_USEDEP}]') )
+ ${LUA_DEPS}
+"
+
+RDEPEND="
+ ${DEPEND}
+ selinux? ( sec-policy/selinux-jabber )
+"
+
+BDEPEND="
+ virtual/pkgconfig
+ test? ( $(lua_gen_cond_dep 'dev-lua/busted[${LUA_USEDEP}]') )
+"
+
+PATCHES=( "${FILESDIR}/${PN}-0.11.7-gentoo.patch" )
+
+src_prepare() {
+ default
+
+ # Set correct plugin path for optional net-im/prosody-modules package
+ sed -e "s/GENTOO_LIBDIR/$(get_libdir)/g" -i prosody.cfg.lua.dist || die
+}
+
+src_configure() {
+ local myeconfargs=(
+ --add-cflags="${CFLAGS}"
+ --add-ldflags="${LDFLAGS}"
+ --c-compiler="$(tc-getCC)"
+ --datadir="${EPREFIX}/var/spool/jabber"
+ --idn-library="$(usex idn 'idn' 'icu')"
+ --libdir="${EPREFIX}/usr/$(get_libdir)"
+ --linker="$(tc-getCC)"
+ --lua-version="$(usex lua_single_target_luajit '5.1' $(ver_cut 1-2 $(lua_get_version)))"
+ --no-example-certs
+ --ostype="linux"
+ --prefix="${EPREFIX}/usr"
+ --runwith="${ELUA}"
+ --sysconfdir="${EPREFIX}/etc/jabber"
+ --with-lua-include="${EPREFIX}/$(lua_get_include_dir)"
+ --with-lua-lib="${EPREFIX}/$(lua_get_cmod_dir)"
+ )
+
+ # Since the configure script is handcrafted,
+ # and yells at unknown options, do not use 'econf'.
+ ./configure "${myeconfargs[@]}" || die
+
+ rm makefile || die
+ mv GNUmakefile Makefile || die
+}
+
+src_install() {
+ default
+
+ keepdir /var/spool/jabber
+
+ newinitd "${FILESDIR}"/prosody.initd-r5 prosody
+ systemd_newunit "${FILESDIR}"/prosody.service-r2 prosody.service
+
+ newtmpfiles "${FILESDIR}"/prosody.tmpfilesd-r1 prosody.conf
+}
+
+pkg_postinst() {
+ tmpfiles_process prosody.conf
+}