summaryrefslogtreecommitdiff
path: root/net-im/openmittsu/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
commitb7b97785ebbb2f11d24d14dab8b81ed274f4ce6a (patch)
tree9fd110f9fc996e8a4213eeda994a8c112491b86d /net-im/openmittsu/files
parent066d27181e9a797ad9f8fc43b49fc9a10ff2f707 (diff)
gentoo resync : 19.03.2019
Diffstat (limited to 'net-im/openmittsu/files')
-rw-r--r--net-im/openmittsu/files/openmittsu-0.9.13.32-fix-tests.patch11
-rw-r--r--net-im/openmittsu/files/openmittsu-0.9.9.48-disable-googletest.patch79
2 files changed, 11 insertions, 79 deletions
diff --git a/net-im/openmittsu/files/openmittsu-0.9.13.32-fix-tests.patch b/net-im/openmittsu/files/openmittsu-0.9.13.32-fix-tests.patch
new file mode 100644
index 000000000000..c89d24536ae9
--- /dev/null
+++ b/net-im/openmittsu/files/openmittsu-0.9.13.32-fix-tests.patch
@@ -0,0 +1,11 @@
+--- openmittsu-0.9.13.32-orig/CMakeLists.txt
++++ openmittsu-0.9.13.32/CMakeLists.txt
+@@ -570,7 +570,7 @@
+ target_link_libraries(openMittsu openMittsuCore Qt5::Core Qt5::Gui Qt5::Widgets Qt5::Network Qt5::Multimedia Qt5::MultimediaWidgets Qt5::Sql)
+ target_link_libraries(openMittsuVersionInfo Qt5::Core)
+ if (OPENMITTSU_ENABLE_TESTS)
+- target_link_libraries(openMittsuTests openMittsuCore Qt5::Core Qt5::Network Qt5::Multimedia Qt5::MultimediaWidgets Qt5::Sql gmock gtest)
++ target_link_libraries(openMittsuTests openMittsuCore Qt5::Core Qt5::Network Qt5::Multimedia Qt5::MultimediaWidgets Qt5::Sql gmock gtest pthread)
+ endif (OPENMITTSU_ENABLE_TESTS)
+
+ # Link against libc++abi if requested.
diff --git a/net-im/openmittsu/files/openmittsu-0.9.9.48-disable-googletest.patch b/net-im/openmittsu/files/openmittsu-0.9.9.48-disable-googletest.patch
deleted file mode 100644
index ceb162d5e6b1..000000000000
--- a/net-im/openmittsu/files/openmittsu-0.9.9.48-disable-googletest.patch
+++ /dev/null
@@ -1,79 +0,0 @@
-Disable googletest for now, in order to avoid accessing the network
-at configure time.
-
---- openmittsu-0.9.9.48-orig/CMakeLists.txt
-+++ openmittsu-0.9.9.48/CMakeLists.txt
-@@ -212,28 +212,6 @@
- # Add the binary dir include directory
- include_directories("${PROJECT_BINARY_DIR}/include")
-
--##########################################################
--#
--# Google Testing Framework
--#
--##########################################################
--# Download and unpack googletest at configure time
--configure_file("${PROJECT_SOURCE_DIR}/cmake/GoogleTest.cmake.in" googletest-download/CMakeLists.txt)
--execute_process(COMMAND "${CMAKE_COMMAND}" -G "${CMAKE_GENERATOR}" .
-- WORKING_DIRECTORY "${CMAKE_BINARY_DIR}/googletest-download" )
--execute_process(COMMAND "${CMAKE_COMMAND}" --build .
-- WORKING_DIRECTORY "${CMAKE_BINARY_DIR}/googletest-download" )
--
--# Prevent GoogleTest from overriding our compiler/linker options
--# when building with Visual Studio
--set(gtest_force_shared_crt ON CACHE BOOL "" FORCE)
--
--# Add googletest directly to our build. This adds
--# the following targets: gtest, gtest_main, gmock
--# and gmock_main
--add_subdirectory("${CMAKE_BINARY_DIR}/googletest-src"
-- "${CMAKE_BINARY_DIR}/googletest-build" EXCLUDE_FROM_ALL)
--
-
- # Main Sources
- file(GLOB OPENMITTSU_HEADERS ${PROJECT_SOURCE_DIR}/src/*.h)
-@@ -399,24 +377,17 @@
-
- add_executable(openMittsuVersionInfo ${OPENMITTSU_BUILDTOOLS_VERSIONINFO_HEADERS} ${OPENMITTSU_BUILDTOOLS_VERSIONINFO_SOURCES_CPP} ${OPENMITTSU_HEADERS_GENERATED} ${OPENMITTSU_SOURCES_GENERATED})
-
--add_executable(openMittsuTests ${OPENMITTSU_TEST_MAIN_FILE} ${OPENMITTSU_TEST_FILES}
-- ${OPENMITTSU_RESOURCESOURCES}
--)
--
- if (MSVC)
- set_target_properties(openMittsu PROPERTIES LINK_FLAGS_RELEASE "/SUBSYSTEM:WINDOWS")
- endif(MSVC)
-
- # Add target link dependencies
--target_link_libraries(openMittsuCore ${Libsodium_LIBRARIES} gtest)
-+target_link_libraries(openMittsuCore ${Libsodium_LIBRARIES})
- target_link_libraries(openMittsu ${LIBQRENCODE_LIBRARY})
-
--add_dependencies(openMittsuTests gtest)
--
- # Use the required modules from Qt 5.
- target_link_libraries(openMittsuCore Qt5::Core Qt5::Gui Qt5::Widgets Qt5::Network Qt5::Multimedia Qt5::Sql)
- target_link_libraries(openMittsu openMittsuCore Qt5::Core Qt5::Gui Qt5::Widgets Qt5::Network Qt5::Multimedia Qt5::Sql)
--target_link_libraries(openMittsuTests openMittsuCore Qt5::Core Qt5::Gui Qt5::Widgets Qt5::Network Qt5::Multimedia Qt5::Sql)
- target_link_libraries(openMittsuVersionInfo Qt5::Core)
-
- # Link against libc++abi if requested.
-@@ -424,7 +395,6 @@
- target_link_libraries(openMittsu "c++abi")
- target_link_libraries(openMittsuCore "c++abi")
- target_link_libraries(openMittsuVersionInfo "c++abi")
-- target_link_libraries(openMittsuTests "c++abi")
- endif(OPENMITTSU_LINK_LIBCXXABI)
-
- # Targets, CPACK...
-@@ -438,10 +408,6 @@
- RUNTIME
- DESTINATION bin
- COMPONENT installComponent)
--install(TARGETS openMittsuTests
-- RUNTIME
-- DESTINATION bin
-- COMPONENT installComponent)
-
- if (MSVC)
- set(OPENMITTSU_WINDEPLOYQT_EXE "${Qt5Core_DIR}/../../../bin/windeployqt.exe")