summaryrefslogtreecommitdiff
path: root/net-im/mcabber/mcabber-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-09-30 11:19:18 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-09-30 11:19:18 +0100
commit62f67115b5c46134c34f88f4b1cbdacc19384c0a (patch)
tree0a76b14de203a4c23040e5665e39df8de9867745 /net-im/mcabber/mcabber-9999.ebuild
parent265dbe5dbc14c199299496c6db8fce3f76647015 (diff)
gentoo resync : 30.09.2018
Diffstat (limited to 'net-im/mcabber/mcabber-9999.ebuild')
-rw-r--r--net-im/mcabber/mcabber-9999.ebuild58
1 files changed, 21 insertions, 37 deletions
diff --git a/net-im/mcabber/mcabber-9999.ebuild b/net-im/mcabber/mcabber-9999.ebuild
index ed7b028ed100..2f8476b1c214 100644
--- a/net-im/mcabber/mcabber-9999.ebuild
+++ b/net-im/mcabber/mcabber-9999.ebuild
@@ -1,22 +1,28 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit flag-o-matic autotools-utils mercurial
+inherit flag-o-matic readme.gentoo-r1
DESCRIPTION="A small Jabber console client with various features, like MUC, SSL, PGP"
HOMEPAGE="http://mcabber.com/"
-EHG_REPO_URI="https://bitbucket.org/McKael/mcabber"
-EHG_CHECKOUT_DIR="${WORKDIR}"
-EHG_BOOTSTRAP="autogen.sh"
-S="${WORKDIR}/${PN}"
+
+if [[ "${PV}" == 9999 ]]; then
+ inherit mercurial
+ EHG_REPO_URI="https://bitbucket.org/McKael/mcabber"
+ EHG_CHECKOUT_DIR="${WORKDIR}"
+ EHG_BOOTSTRAP="autogen.sh"
+ S="${WORKDIR}/${PN}"
+else
+ SRC_URI="http://mcabber.com/files/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+fi
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS=""
-IUSE="aspell crypt idn modules otr spell ssl vim-syntax"
+IUSE="aspell crypt idn otr spell ssl vim-syntax"
LANGS="cs de fr it nl pl ru uk"
# localized help versions are installed only, when L10N var is set
@@ -28,7 +34,7 @@ RDEPEND="crypt? ( >=app-crypt/gpgme-1.0.0 )
otr? ( >=net-libs/libotr-3.1.0 )
aspell? ( app-text/aspell )
vim-syntax? ( || ( app-editors/vim app-editors/gvim ) )
- idn? ( net-dns/libidn )
+ idn? ( net-dns/libidn:= )
spell? ( app-text/enchant )
dev-libs/glib:2
net-libs/libnsl:0=
@@ -37,9 +43,6 @@ RDEPEND="crypt? ( >=app-crypt/gpgme-1.0.0 )
DEPEND="${RDEPEND}
virtual/pkgconfig"
-## autotools-utils.eclass settings
-AUTOTOOLS_AUTORECONF="1"
-AUTOTOOLS_IN_SOURCE_BUILD="1"
DOCS=( AUTHORS ChangeLog NEWS README TODO mcabberrc.example doc/README_PGP.txt )
pkg_setup() {
@@ -49,19 +52,17 @@ pkg_setup() {
}
src_configure() {
- local myeconfargs=(
+ econf \
+ --enable-modules \
$(use_enable crypt gpgme) \
$(use_enable otr) \
$(use_enable aspell) \
$(use_enable spell enchant) \
- $(use_enable modules) \
$(use_with idn libidn)
- )
- autotools-utils_src_configure
}
src_install() {
- autotools-utils_src_install
+ default
# clean unneeded language documentation
for i in ${LANGS}; do
@@ -89,27 +90,10 @@ src_install() {
insinto /usr/share/vim/vimfiles/ftdetect
doins mcabber_log-ftdetect.vim
fi
+
+ readme.gentoo_create_doc
}
pkg_postinst() {
- elog
- elog "MCabber requires you to create a subdirectory .mcabber in your home"
- elog "directory and to place a configuration file there."
- elog "An example mcabberrc was installed as part of the documentation."
- elog "To create a new mcabberrc based on the example mcabberrc, execute the"
- elog "following commands:"
- elog
- elog " mkdir -p ~/.mcabber"
- elog " bzcat ${EROOT}usr/share/doc/${PF}/mcabberrc.example.bz2 >~/.mcabber/mcabberrc"
- elog
- elog "Then edit ~/.mcabber/mcabberrc with your favorite editor."
- elog
- elog "See the CONFIGURATION FILE and FILES sections of the mcabber"
- elog "manual page (section 1) for more information."
- elog
- elog "From version 0.9.0 on, MCabber supports PGP encryption of messages."
- elog "See README_PGP.txt for details."
- echo
- einfo "Check out ${EROOT}usr/share/${PN} for contributed themes and event scripts."
- echo
+ readme.gentoo_print_elog
}