summaryrefslogtreecommitdiff
path: root/net-im/kouchat/kouchat-1.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-im/kouchat/kouchat-1.1.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-im/kouchat/kouchat-1.1.0.ebuild')
-rw-r--r--net-im/kouchat/kouchat-1.1.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/net-im/kouchat/kouchat-1.1.0.ebuild b/net-im/kouchat/kouchat-1.1.0.ebuild
new file mode 100644
index 000000000000..3c7522dc9b9c
--- /dev/null
+++ b/net-im/kouchat/kouchat-1.1.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+JAVA_PKG_IUSE=""
+
+inherit eutils java-pkg-2 java-ant-2
+
+DESCRIPTION="KouChat is a simple serverless chat client for local area networks"
+HOMEPAGE="https://kouchat.googlecode.com/"
+SRC_URI="https://kouchat.googlecode.com/files/${P}-src.tar.gz
+ https://dev.gentoo.org/~serkan/distfiles/${P}-buildfiles.tar.gz"
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.6"
+DEPEND=">=virtual/jdk-1.6"
+
+S=${WORKDIR}/${P}-src
+
+src_install() {
+ java-pkg_newjar target/${P}.jar ${PN}.jar
+ java-pkg_dolauncher ${PN} --main net.usikkert.kouchat.KouChat
+ java-pkg_dolauncher ${PN}-console --main net.usikkert.kouchat.KouChat --pkg_args "--console"
+ newicon kou_shortcut.png ${PN}.png
+ make_desktop_entry ${PN} "KouChat"
+}