summaryrefslogtreecommitdiff
path: root/net-im/cpop
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-19 06:33:49 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-19 06:33:49 +0000
commit78634f348a30a55cc55606ee1ecde032241ceaeb (patch)
tree528e39df571e37b31bfca1811c69bcc06c4af22f /net-im/cpop
parent434fbe89e81a1fe06d92676be72ab7f862cc3f53 (diff)
gentoo auto-resync : 19:03:2023 - 06:33:49
Diffstat (limited to 'net-im/cpop')
-rw-r--r--net-im/cpop/Manifest3
-rw-r--r--net-im/cpop/cpop-0.0.4-r2.ebuild (renamed from net-im/cpop/cpop-0.0.4-r1.ebuild)20
-rw-r--r--net-im/cpop/files/cpop-0.0.4-implicit-func-decls.patch19
3 files changed, 37 insertions, 5 deletions
diff --git a/net-im/cpop/Manifest b/net-im/cpop/Manifest
index e87f4ca41114..b1a7c6560414 100644
--- a/net-im/cpop/Manifest
+++ b/net-im/cpop/Manifest
@@ -1,4 +1,5 @@
AUX cpop-0.0.4-implicit-exit_memset_strlen.patch 1223 BLAKE2B f7cfc23d7adaa39ee1d0be5dc90562bcd9e427ea97f02ee217f8752195d030aaea441384dcc8fc2007531c5a36fa548b7f868ba7f49a4bec61dc37d609979ba7 SHA512 e8b9c2a6943b788c494495f0603672f4088cc38543637e77bb0b60036c905d2f80aeafba56fd49b27a980a509337352cdc18e113c131e2726218a1e2f947f529
+AUX cpop-0.0.4-implicit-func-decls.patch 413 BLAKE2B f53a6596dd22a25593f1ca8a8a60be1204318d8070b4324441169cfc25e42ff9f4495e72e9e64106beaf5e1b58f38c376d575b8cfdb91132e53b4b6d8f8b2b29 SHA512 f3edf358749bbcb0ae087addb05520044cca0d41a18381854bde3ed57da6814e6b2a8e21bab60931f5572ed21707f75a63b314b53d1d11fb381c02ee0db7a15b
DIST cpop-0.0.4.tar.gz 68544 BLAKE2B 243c5e38c798e741cdf6afc6ebf955f98d659b09d37039a471f662ce8fd672d75985235e59cd0b169d32c8250a0230527349dbbcbfac26ae19012b80895480c8 SHA512 c7f4dbff7f8702a8a32447c09457fa6f0810768a41450c43ae71aa67c6fb2d40af634713d1a703dd7f1a9a97ac534f2dab11f8f3f88a79c549224e8b375d721a
-EBUILD cpop-0.0.4-r1.ebuild 546 BLAKE2B a80f6aecdbf8ff1fbecbde51a629aa4bc544a49d930b7c32fc49034a2011695ce970d8ba7dbc2436db15c8b20367732a1fe280a046cee21c9e533bfbf66e99fa SHA512 b0f563ba2eda00b4040015860ea1301a1234619a3b5e94276509c45f00b477da6c035ad8a613cb36f03042312114d7756b733227d8cc3554ab8848466bafb0d0
+EBUILD cpop-0.0.4-r2.ebuild 681 BLAKE2B 0431132fe2fc35b35765458527b92ae8e857db1c205bd906e4806743dab7764984cee6dcc883095999982507f359ffade7ebf61a9beaa714bccd4ae5739cb92f SHA512 1bfb524494419bb642467cc7860bdf743c602547a9cb77b4aca2d72424911e3477d70d856431cf525f0b9ac044010753238aae22b8f80b4cb465d5a9abb9abd6
MISC metadata.xml 167 BLAKE2B 868e3b584722eaacf68273db062bb773d8c7e5d7ab2b81ca7e8397643bf7cc106c3a1033594401c99c54f667bb45d6b73f9048fc335580bbd44b4589ad26a832 SHA512 30caadd1496c3b9969136038239a1d8e01f236726b4022c2d7e19ca7575f25f735e556835e581afbf44fbd3e4104c40f2b5ef5fa70118d75c881fdf871962d0a
diff --git a/net-im/cpop/cpop-0.0.4-r1.ebuild b/net-im/cpop/cpop-0.0.4-r2.ebuild
index 9315a2381ea0..77c21027edcc 100644
--- a/net-im/cpop/cpop-0.0.4-r1.ebuild
+++ b/net-im/cpop/cpop-0.0.4-r2.ebuild
@@ -1,7 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+
+inherit autotools
DESCRIPTION="GTK+ network popup message client. Compatible with the jpop protocol"
HOMEPAGE="http://www.draxil.uklinux.net/hip/index.pl?page=cpop"
@@ -11,14 +13,24 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-RDEPEND="dev-libs/glib:2
- x11-libs/gtk+:2"
+RDEPEND="
+ dev-libs/glib:2
+ x11-libs/gtk+:2
+"
DEPEND="${RDEPEND}"
PATCHES=(
"${FILESDIR}"/${P}-implicit-exit_memset_strlen.patch
+ "${FILESDIR}"/${P}-implicit-func-decls.patch
)
+src_prepare() {
+ default
+
+ # Clang 16, bug #900072
+ eautoreconf
+}
+
src_install() {
emake DESTDIR="${D}" install
dodoc README
diff --git a/net-im/cpop/files/cpop-0.0.4-implicit-func-decls.patch b/net-im/cpop/files/cpop-0.0.4-implicit-func-decls.patch
new file mode 100644
index 000000000000..ff3977e18055
--- /dev/null
+++ b/net-im/cpop/files/cpop-0.0.4-implicit-func-decls.patch
@@ -0,0 +1,19 @@
+https://bugs.gentoo.org/885705
+--- a/pop_client.c
++++ b/pop_client.c
+@@ -2,6 +2,7 @@
+ #include <stdlib.h>
+ #include <string.h>
+ #include <sys/socket.h>
++#include <unistd.h>
+ #include <netinet/in.h>
+ #include <arpa/inet.h>
+ #include <errno.h>
+--- a/pop_common.h
++++ b/pop_common.h
+@@ -3,4 +3,5 @@
+ #define CP_MSGSIZE 2048
+ #define CP_PORT 3233
+ void errquit(char *message);
++void printquit(char *message);
+ #endif