summaryrefslogtreecommitdiff
path: root/net-im/cpop
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-im/cpop
reinit the tree, so we can have metadata
Diffstat (limited to 'net-im/cpop')
-rw-r--r--net-im/cpop/Manifest6
-rw-r--r--net-im/cpop/cpop-0.0.4-r1.ebuild27
-rw-r--r--net-im/cpop/files/cpop-0.0.4-implicit-exit_memset_strlen.patch38
-rw-r--r--net-im/cpop/metadata.xml5
4 files changed, 76 insertions, 0 deletions
diff --git a/net-im/cpop/Manifest b/net-im/cpop/Manifest
new file mode 100644
index 000000000000..830c8b835835
--- /dev/null
+++ b/net-im/cpop/Manifest
@@ -0,0 +1,6 @@
+AUX cpop-0.0.4-implicit-exit_memset_strlen.patch 1211 SHA256 9a51c665e4184d26edbcd220c30626f01c814e9b4e717939ca6e6ecf0cf9dd55 SHA512 a6b1d15f2e65528489f0bfa38e0f50af268912490fe853ea29eb786e5682d19b224b6a16fcaa3ce56421a9c3a2206beb689e5830914bcabbc1692476cef96f8d WHIRLPOOL 7ecb588810a26963b63dd6ad9bf3b26c8132c6c668fc76405880c1d6bb66ef99e32906400c301c47f3084a723a5b6197c1433202f6f81394806dd18ff28bae72
+DIST cpop-0.0.4.tar.gz 68544 SHA256 68855387c20ce2adaf5a51464b68fc756acfe197ab9b53dbde910757526f45a8 SHA512 c7f4dbff7f8702a8a32447c09457fa6f0810768a41450c43ae71aa67c6fb2d40af634713d1a703dd7f1a9a97ac534f2dab11f8f3f88a79c549224e8b375d721a WHIRLPOOL 20bd2fc1b9d4e4e4d794a917861fc66dd90ebadf01fb8ab1531715beb05ce3504a381aa6623955fde1dc0fda1ef5a8026823124720b1d6b144e93a9e0f33c674
+EBUILD cpop-0.0.4-r1.ebuild 585 SHA256 64ba45193cf32133be9e857d5e675865c87cc0ada6b82b787d5f4b08968948fb SHA512 d349c62543e5133f5ba38dc1d08ef3d3e479768a4edfac8da54a9663986cd36e948e1cfb74f64807ea008c5f4f0ed8c846b5dee9ed392acb51655c7ce5304de8 WHIRLPOOL 8dbc77f9cf16934f1416475d1e249c191ff5765779fa4bbc8ea8e0d2702bf3877fc22b5eb139d19dd0b55074083a669bf5bd396c53e878c8a539fff4d3b42ad2
+MISC ChangeLog 2504 SHA256 c2ddb2952ff730cf738854e5bd0ed0b51042d3f15b8b9f3cad7ad4e2ea63b39f SHA512 468ffce13955186164fd62f00ba40e752d9aa22729645c1c39b39cc11b8d5e51346f5ccdf4b19831e4d952423e5849992df515bd37a9008252849a402b54f92e WHIRLPOOL 47bb495fbb2f4157dd9b4f51a92765f0ca1fd6d283f7b33697f7dd1219a11fcf16a49d9a4d4e2aa585d92f5902c0751d8f801bd98b60b926d9b39a252b5fb9d9
+MISC ChangeLog-2015 1207 SHA256 6b89fb889459a7456f40a20c61881f846ca0be0255479610859705e125079ae7 SHA512 dc87f1984957edc13b206879dfa6a347d87cce54511a378c1fcb9c28458ec526ba6ae22285614158de34a1382be9cbab27be246d5dc2d8acf426835e8b3711e7 WHIRLPOOL 9666c491e62142a1c9cb8efff67d30625ed0fee8b5e2c69a2cf7d722296d381b836f5dd860f9643825cce1cfbf801bf2d6168ccf7dd54abac52bcb08a77c430b
+MISC metadata.xml 166 SHA256 2caff447f5bd2701d8456ada5cc633c41ef4373fa4bfeabeb73599d40bcc941b SHA512 a56648c974a1d14dd4c18237532773c72057a13ab90c58b5da04f185e3c12a8bd8d5c21fb06053507f31766291a82dc7d87b34cd65fd94cfe2af7295c813ef84 WHIRLPOOL 1ff70497eca6531f0e0614c72a19f4b8e5ff486a58d369f4f0b36308d1d6b01168f9da887740e3b9f536236be251d3fe05f904d27a9233a7cf613416ba882968
diff --git a/net-im/cpop/cpop-0.0.4-r1.ebuild b/net-im/cpop/cpop-0.0.4-r1.ebuild
new file mode 100644
index 000000000000..b86f14d8e51d
--- /dev/null
+++ b/net-im/cpop/cpop-0.0.4-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="GTK+ network popup message client. Compatible with the jpop protocol"
+HOMEPAGE="http://www.draxil.uklinux.net/hip/index.pl?page=cpop"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="dev-libs/glib:2
+ x11-libs/gtk+:2"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-implicit-exit_memset_strlen.patch
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc README
+}
diff --git a/net-im/cpop/files/cpop-0.0.4-implicit-exit_memset_strlen.patch b/net-im/cpop/files/cpop-0.0.4-implicit-exit_memset_strlen.patch
new file mode 100644
index 000000000000..3ce224c2910a
--- /dev/null
+++ b/net-im/cpop/files/cpop-0.0.4-implicit-exit_memset_strlen.patch
@@ -0,0 +1,38 @@
+pop_common.c:5:3: warning: incompatible implicit declaration of built-in function ‘exit’
+pop_common.c:10:3: warning: incompatible implicit declaration of built-in function ‘exit’
+pop_client.c:61:3: warning: incompatible implicit declaration of built-in function ‘exit’
+pop_gui_client.c:58:4: warning: incompatible implicit declaration of built-in function ‘memset’
+pop_gui_client.c:72:27: warning: incompatible implicit declaration of built-in function ‘strlen’
+pop_gui_client.c:128:3: warning: incompatible implicit declaration of built-in function ‘exit’
+
+--- pop_client.c
++++ pop_client.c
+@@ -1,11 +1,11 @@
+ #include <stdio.h>
++#include <stdlib.h>
+ #include <string.h>
+ #include <sys/socket.h>
+ #include <netinet/in.h>
+ #include <arpa/inet.h>
+ #include <errno.h>
+ #include <glib.h>
+-#include <stdio.h>
+ #include <netdb.h>
+ #include "pop_common.h"
+ #include "pop_client.h"
+--- pop_common.c
++++ pop_common.c
+@@ -1,4 +1,5 @@
+ #include <stdio.h>
++#include <stdlib.h>
+ void errquit(char *message)
+ {
+ perror(message);
+--- pop_gui_client.c
++++ pop_gui_client.c
+@@ -1,3 +1,5 @@
++#include <stdlib.h>
++#include <string.h>
+ #include <netdb.h>
+ #include <netinet/in.h>
+ #include <arpa/inet.h>
diff --git a/net-im/cpop/metadata.xml b/net-im/cpop/metadata.xml
new file mode 100644
index 000000000000..6f49eba8f496
--- /dev/null
+++ b/net-im/cpop/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<!-- maintainer-needed -->
+</pkgmetadata>