summaryrefslogtreecommitdiff
path: root/net-im/coturn/coturn-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /net-im/coturn/coturn-9999.ebuild
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'net-im/coturn/coturn-9999.ebuild')
-rw-r--r--net-im/coturn/coturn-9999.ebuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/net-im/coturn/coturn-9999.ebuild b/net-im/coturn/coturn-9999.ebuild
index a1fe9ad57b2c..4a1fd7499733 100644
--- a/net-im/coturn/coturn-9999.ebuild
+++ b/net-im/coturn/coturn-9999.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit eutils user systemd tmpfiles
+EAPI=7
+inherit eutils systemd tmpfiles
DESCRIPTION="coturn TURN server project"
-HOMEPAGE="https://github.com/${PN}/${PN}"
+HOMEPAGE="https://github.com/coturn/coturn"
if [ ${PV} = 9999 ]; then
KEYWORDS=""
@@ -20,7 +20,9 @@ fi
LICENSE="BSD"
SLOT="0"
IUSE="mongodb mysql postgres redis sqlite"
-RDEPEND="|| ( dev-libs/libevent[-ssl,libressl] dev-libs/libevent[ssl,-libressl] >dev-libs/libevent-2.1.8[ssl,libressl] )
+RDEPEND="acct-group/turnserver
+ acct-user/turnserver
+ || ( dev-libs/libevent[-ssl,libressl] dev-libs/libevent[ssl,-libressl] >dev-libs/libevent-2.1.8[ssl,libressl] )
mongodb? ( dev-libs/mongo-c-driver )
mysql? ( dev-db/mysql-connector-c )
postgres? ( dev-db/postgresql:* )
@@ -64,8 +66,6 @@ src_install() {
pkg_postinst() {
tmpfiles_process "${PN}.conf"
- enewgroup turnserver
- enewuser turnserver -1 -1 -1 turnserver
elog "You need to copy /etc/turnserver.conf.default to"
elog "/etc/turnserver.conf and do your settings there."
}