summaryrefslogtreecommitdiff
path: root/net-im/coturn/coturn-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /net-im/coturn/coturn-9999.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'net-im/coturn/coturn-9999.ebuild')
-rw-r--r--net-im/coturn/coturn-9999.ebuild31
1 files changed, 21 insertions, 10 deletions
diff --git a/net-im/coturn/coturn-9999.ebuild b/net-im/coturn/coturn-9999.ebuild
index 4f65686782b4..d3a3c8813604 100644
--- a/net-im/coturn/coturn-9999.ebuild
+++ b/net-im/coturn/coturn-9999.ebuild
@@ -2,14 +2,14 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit systemd tmpfiles
+
+inherit toolchain-funcs systemd tmpfiles
DESCRIPTION="coturn TURN server project"
HOMEPAGE="https://github.com/coturn/coturn"
if [ ${PV} = 9999 ]; then
EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
inherit git-r3
- DEPEND="dev-vcs/git"
# S="${WORKDIR}/${PN}-master"
else
KEYWORDS="~amd64 ~x86"
@@ -20,15 +20,20 @@ LICENSE="BSD"
SLOT="0"
IUSE="mongodb mysql postgres redis sqlite"
RDEPEND="acct-group/turnserver
- acct-user/turnserver
- >dev-libs/libevent-2.1.8:=
- mongodb? ( dev-libs/mongo-c-driver )
- mysql? ( dev-db/mysql-connector-c:= )
- postgres? ( dev-db/postgresql:* )
- redis? ( dev-libs/hiredis:= )
- sqlite? ( dev-db/sqlite )"
-
+ acct-user/turnserver
+ >dev-libs/libevent-2.1.8:=
+ dev-libs/openssl:=
+ mongodb? ( dev-libs/mongo-c-driver )
+ mysql? ( dev-db/mysql-connector-c:= )
+ postgres? ( dev-db/postgresql:* )
+ redis? ( dev-libs/hiredis:= )
+ sqlite? ( dev-db/sqlite )"
DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.5.2-respect-TMPDIR.patch
+)
src_configure() {
if [ -n "${AR}" ]; then
@@ -56,7 +61,13 @@ src_configure() {
if ! use sqlite; then
export TURN_NO_SQLITE=yes
fi
+
+ tc-export CC
+
+ export ARCHIVERCMD="$(tc-getAR) -r"
+ export PKGCONFIG="$(tc-getPKG_CONFIG)"
export DOCSDIR="/usr/share/doc/${PN}-${PV}"
+
econf $(use_with sqlite)
}