summaryrefslogtreecommitdiff
path: root/net-im/cawbird
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-24 23:59:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-24 23:59:54 +0000
commit401101f9c8077911929d3f2b60a37098460a5d89 (patch)
treec2bef4719f6787550f0916aeaa8f4f403a9296af /net-im/cawbird
parent4cbcc855382a06088e2f016f62cafdbcb7e40665 (diff)
gentoo resync : 25.03.2022
Diffstat (limited to 'net-im/cawbird')
-rw-r--r--net-im/cawbird/Manifest3
-rw-r--r--net-im/cawbird/cawbird-1.5-r1.ebuild66
-rw-r--r--net-im/cawbird/metadata.xml11
3 files changed, 80 insertions, 0 deletions
diff --git a/net-im/cawbird/Manifest b/net-im/cawbird/Manifest
new file mode 100644
index 000000000000..361159e7bf85
--- /dev/null
+++ b/net-im/cawbird/Manifest
@@ -0,0 +1,3 @@
+DIST cawbird-1.5.tar.gz 675527 BLAKE2B d94bf61faba01fc1159fabbf0da24ab49a697112ccd5bb631133c21f52ffe29e9ede214c9eccf553cbbb039b08e487467e4ecc56d0e0ef63f68d4c23d39414aa SHA512 917480ac79606a1ab572f0837fd48e100bbb6d70ad3551a8d86486843d9bfb0e4814c75c56ff0e2aa41fd7d32a614bbff4e6121831b3da7da7614fb5a0d3f6e1
+EBUILD cawbird-1.5-r1.ebuild 1357 BLAKE2B 21e0cbbbc8667d56ae263780a21f7ae4abef9ecc4e9881fe20e5726b04dea5f404757c820c23a7e94b2c2ac423994881854a223c9065e9fc4a9a69b2db74a71f SHA512 e30f1ba05839dd9a09c5f5fd2617f7fb692ac798ef90eb8e4185ecf53ad49e70b35514e06b6f4a0e75ebc076d76e18b5174bf205cc44283021ce6ff17ba067fb
+MISC metadata.xml 324 BLAKE2B f548750610b0b02bf35efb78ee01ef1d2d7a68d65d9d1e88b29639ad576b139fecd3d8b40a2c9ff88f4613a1b6e8fea28efccfcdbc6e83d32855c4414ede7728 SHA512 4aed49f42c279faf8c819e1a1cb1bf0aad5ccd46de295fff062734e68f98aee1cdc96f383a3c45a452fb7cf9e344ddde1f33e3b9287535fec1edfb4f710d6a8a
diff --git a/net-im/cawbird/cawbird-1.5-r1.ebuild b/net-im/cawbird/cawbird-1.5-r1.ebuild
new file mode 100644
index 000000000000..f7f08d155805
--- /dev/null
+++ b/net-im/cawbird/cawbird-1.5-r1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome2-utils meson vala xdg
+
+DESCRIPTION="Twitter client"
+HOMEPAGE="https://ibboard.co.uk/cawbird/ https://github.com/IBBoard/cawbird"
+SRC_URI="https://github.com/IBBoard/cawbird/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${P}
+
+LICENSE="CC-BY-3.0 GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="gstreamer spell"
+
+RDEPEND="
+ dev-db/sqlite:3
+ dev-libs/atk
+ dev-libs/glib:2
+ dev-libs/json-glib
+ net-libs/liboauth
+ net-libs/libsoup:2.4
+ net-libs/rest:0.7
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+ x11-libs/libX11
+ x11-libs/pango
+ gstreamer? ( media-plugins/gst-plugins-meta[ffmpeg,http,X] )
+ spell? ( app-text/gspell:=[vala] )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ $(vala_depend)
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+ vala_setup
+}
+
+src_configure() {
+ local emesonargs=(
+ # these keys are taken from the readme of cawbird
+ -Dconsumer_key_base64='VmY5dG9yRFcyWk93MzJEZmhVdEk5Y3NMOA=='
+ -Dconsumer_secret_base64='MThCRXIxbWRESDQ2Y0podzVtVU13SGUyVGlCRXhPb3BFRHhGYlB6ZkpybG5GdXZaSjI='
+ -Dexamples=false
+ $(meson_use spell spellcheck)
+ $(meson_use gstreamer video)
+ -Dx11=true
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ xdg_pkg_postinst
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+ xdg_pkg_postrm
+}
diff --git a/net-im/cawbird/metadata.xml b/net-im/cawbird/metadata.xml
new file mode 100644
index 000000000000..d1905ebb02b4
--- /dev/null
+++ b/net-im/cawbird/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+ <email>matthew@gentoo.org</email>
+ <name>Matthew Smith</name>
+</maintainer>
+<upstream>
+ <remote-id type="github">IBBoard/cawbird</remote-id>
+</upstream>
+</pkgmetadata>