summaryrefslogtreecommitdiff
path: root/net-im/bitlbee/files/bitlbee-3.6-system-json-parser.patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-23 08:44:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-23 08:44:14 +0100
commit05a34d98821265bf73820931936f86704b9002c6 (patch)
tree0695bbc0d5d5ec59f2d1d6a1a99d4717d5294fe4 /net-im/bitlbee/files/bitlbee-3.6-system-json-parser.patch
parentf019a919bf109460ee009a5f9210b99d0467db97 (diff)
gentoo auto-resync : 23:08:2022 - 08:44:14
Diffstat (limited to 'net-im/bitlbee/files/bitlbee-3.6-system-json-parser.patch')
-rw-r--r--net-im/bitlbee/files/bitlbee-3.6-system-json-parser.patch23
1 files changed, 20 insertions, 3 deletions
diff --git a/net-im/bitlbee/files/bitlbee-3.6-system-json-parser.patch b/net-im/bitlbee/files/bitlbee-3.6-system-json-parser.patch
index 02d57e02d6d2..0a9c197d763d 100644
--- a/net-im/bitlbee/files/bitlbee-3.6-system-json-parser.patch
+++ b/net-im/bitlbee/files/bitlbee-3.6-system-json-parser.patch
@@ -1,13 +1,16 @@
This is adapted patch from upstream PR 151. Original PR defines
--external-json-parser which breaks configuration, see [1]. It was changed to
--externaljsonparser and $external_json_parser to $externaljsonparser.
+Additionally, LDFLAGS_CHECK variable was introduced in order to make
+tests working, see [2] and #865667.
[1] https://github.com/bitlbee/bitlbee/pull/151#issuecomment-1201181905
+[2] https://github.com/bitlbee/bitlbee/pull/151#issuecomment-1219254239
Upstream-PR: https://github.com/bitlbee/bitlbee/pull/151
diff --git a/configure b/configure
-index 4640c806..77b1213b 100755
+index fd8d363a..39495515 100755
--- a/configure
+++ b/configure
@@ -47,6 +47,7 @@ plugins=1
@@ -26,7 +29,7 @@ index 4640c806..77b1213b 100755
--target=... Cross compilation target same as host
-@@ -398,6 +400,20 @@ else
+@@ -398,6 +400,21 @@ else
fi
echo 'EVENT_HANDLER=events_'$events'.o' >> Makefile.settings
@@ -41,13 +44,14 @@ index 4640c806..77b1213b 100755
+if [ "$externaljsonparser" = "1" ]; then
+ echo "CFLAGS+=$(pkg-config --cflags json-parser)" >> Makefile.settings
+ echo "LDFLAGS_BITLBEE+=$(pkg-config --libs json-parser)" >> Makefile.settings
++ echo "LDFLAGS_CHECK+=$(pkg-config --libs json-parser)" >> Makefile.settings
+fi
+
+
detect_gnutls()
{
if $PKG_CONFIG --exists gnutls; then
-@@ -979,6 +995,12 @@ else
+@@ -979,6 +996,12 @@ else
echo ' systemd disabled.'
fi
@@ -77,6 +81,19 @@ index fc46aedc..ad95d9cb 100644
LFLAGS += -r
+diff --git a/tests/Makefile b/tests/Makefile
+index 76122a2f..2235bf1d 100644
+--- a/tests/Makefile
++++ b/tests/Makefile
+@@ -20,7 +20,7 @@ test_objs = check.o check_util.o check_nick.o check_md5.o check_arc.o check_irc.
+
+ check: $(test_objs) $(addprefix ../, $(main_objs)) ../protocols/protocols.o ../lib/lib.o
+ @echo '*' Linking $@
+- $(VERBOSE) $(CC) $(CFLAGS) -o $@ $^ $(LFLAGS) $(EFLAGS)
++ $(VERBOSE) $(CC) $(CFLAGS) -o $@ $^ $(LFLAGS) $(LDFLAGS_CHECK) $(EFLAGS)
+
+ %.o: $(_SRCDIR_)%.c
+ @echo '*' Compiling $<
--
2.35.1