summaryrefslogtreecommitdiff
path: root/net-ftp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-21 02:09:25 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-21 02:09:25 +0000
commitafcb9236a72cf602364c28b9bde6648e4a7f1ca5 (patch)
tree9608aa2c881b2688207832334c938f0e38d5c71c /net-ftp
parentd3419aa304ff2564036398be5e8ed4bdeaeaa007 (diff)
gentoo auto-resync : 21:01:2024 - 02:09:25
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/Manifest.gzbin3180 -> 3183 bytes
-rw-r--r--net-ftp/frox/Manifest1
-rw-r--r--net-ftp/frox/frox-0.7.18-r9.ebuild93
3 files changed, 94 insertions, 0 deletions
diff --git a/net-ftp/Manifest.gz b/net-ftp/Manifest.gz
index 7ed1fca4af24..275adcc4c6e4 100644
--- a/net-ftp/Manifest.gz
+++ b/net-ftp/Manifest.gz
Binary files differ
diff --git a/net-ftp/frox/Manifest b/net-ftp/frox/Manifest
index f0d7333803ea..f8c757fd5aa3 100644
--- a/net-ftp/frox/Manifest
+++ b/net-ftp/frox/Manifest
@@ -5,4 +5,5 @@ AUX frox-0.7.18-no-common.patch 1644 BLAKE2B a84e686a1bffa8d8adb92bbc030b1fa61df
AUX frox.initd 873 BLAKE2B 1f4182a11bd42d091b9d6cbba4b2115327766787f329c6c113e43070f8fc6a8867017bdf009a2c97a94b16e958888384dc604dfc06ecf5df0cc711f212b11d76 SHA512 26bc18f28cf46184b0c387196958f9236ec0cd70fe43ac8b18de66e69c42d73087ed5063f3ecc1b1d5c0880b2047293403e4cfbb15f5a23ca5d6fc521021f364
DIST frox-0.7.18.tar.bz2 173355 BLAKE2B 70e51ef14fd16dfeb8c2b8c42acf32b4fc8456622f6258aca7faee49e59ccd4e3cb563620a50a4cb877401d9154311dd2f88e76a94c48974bf9b77ad558a6d9f SHA512 bdffe4b70c91b920378a422dcf386088c3bb34f26e10de8ff57f487ccef6356803c93057eee2b3801a79120a6b2e1618a51dde5bc8c42e13211abf4182c4ff8c
EBUILD frox-0.7.18-r8.ebuild 1899 BLAKE2B 69b44a1a481786424b4da09b3c31c450eaf24a7ab4a00c064d5a676606187494d5e5fffa27de48326ca25ad23401f35864df879ec4824715d9030dc8ea5d0551 SHA512 150792890883cefe7c5ee7c0e4a5bb3ab214b35b08cd728151697261da68c225250cbe27345cae160da47b6a42570998ea94398070f5ed71f4ac1f7eb3eb203e
+EBUILD frox-0.7.18-r9.ebuild 1961 BLAKE2B eb01882e0389b70a173ee4a91c917c031627e98889ff14afff103de6829f62457311a3aff4141cb3e8c5dbe9711f41e02ba7c484056d645288ef35b0f9fdd9ed SHA512 48bcdaf10754401fb4ffbdacc82896a10e2e22186736eb8e194caf65b77166d7dcea6ef7cbe07b05ba2f31f2a3ac3be83e4e1024738a5e9bb671757ada2b6518
MISC metadata.xml 623 BLAKE2B ebe352b066faf827000496491e2570a28b62f5ae484f780c912fe18a8447b277fae392c19eaa97e7014bf01bd1500d8c4cc37968536c550c645953e821f0818b SHA512 27db1dfd65ecef394d8b5b9d289b0063b37b28a365380c34ba60188385e93ae8eb7387dfdc07df2a36666d08bcf8499a05d7c47b1f7208d6c3be478255b590bb
diff --git a/net-ftp/frox/frox-0.7.18-r9.ebuild b/net-ftp/frox/frox-0.7.18-r9.ebuild
new file mode 100644
index 000000000000..3adb233d8114
--- /dev/null
+++ b/net-ftp/frox/frox-0.7.18-r9.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="Transparent ftp proxy"
+HOMEPAGE="https://frox.sourceforge.net/"
+SRC_URI="https://frox.sourceforge.net/download/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="clamav ssl transparent"
+
+DEPEND="
+ acct-group/ftpproxy
+ acct-user/ftpproxy
+ clamav? ( >=app-antivirus/clamav-0.80 )
+ kernel_linux? ( >=sys-kernel/linux-headers-2.6 )
+ ssl? (
+ dev-libs/openssl:0=
+ )
+"
+
+RDEPEND="${DEPEND}"
+
+# INSTALL has useful filewall rules
+DOCS=(
+ BUGS README
+ doc/CREDITS doc/ChangeLog doc/FAQ doc/INSTALL
+ doc/INTERNALS doc/README.transdata doc/RELEASE
+ doc/SECURITY doc/TODO
+)
+
+pkg_setup() {
+ use clamav && ewarn "Virus scanner potentialy broken in chroot - see bug #81035"
+}
+
+src_prepare() {
+ HTML_DOCS=( doc/*.html doc/*.sgml )
+
+ default
+
+ eapply "${FILESDIR}/${PV}-respect-CFLAGS.patch"
+ eapply "${FILESDIR}/${PV}-netfilter-includes.patch"
+ eapply "${FILESDIR}/${P}-config.patch"
+ eapply "${FILESDIR}/${P}-no-common.patch"
+
+ if use clamav ; then
+ sed -e "s:^# VirusScanner.*:# VirusScanner '\"/usr/bin/clamscan\" \"%s\"':" \
+ -i "src/${PN}.conf" || die
+ fi
+
+ mv configure.in configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-http-cache --enable-local-cache
+ --enable-procname
+ --enable-configfile=/etc/frox.conf
+ $(use_enable !kernel_linux libiptc)
+ $(use_enable clamav virus-scan)
+ $(use_enable ssl)
+ $(use_enable transparent transparent-data)
+ $(use_enable !transparent ntp)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}
+
+src_install() {
+ default
+
+ keepdir /var/log/"${PN}"
+
+ fowners ftpproxy:ftpproxy /var/log/frox
+
+ newman "doc/${PN}.man" "${PN}.man.8"
+ newman "doc/${PN}.conf.man" "${PN}.conf.man.5"
+
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+
+ insinto /etc
+ newins "src/${PN}.conf" "${PN}.conf.example"
+}