summaryrefslogtreecommitdiff
path: root/net-ftp/uftpd/uftpd-2.15-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-02 21:10:25 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-02 21:10:25 +0000
commitd05150f06fa67b115a83f822b1e285dca011e1b7 (patch)
tree86d728b5108b361faf2f421e2d4f3b03a85b7837 /net-ftp/uftpd/uftpd-2.15-r1.ebuild
parentbe524496e3171d5eab8c56570dd4342a880c3264 (diff)
gentoo auto-resync : 02:11:2022 - 21:10:25
Diffstat (limited to 'net-ftp/uftpd/uftpd-2.15-r1.ebuild')
-rw-r--r--net-ftp/uftpd/uftpd-2.15-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/net-ftp/uftpd/uftpd-2.15-r1.ebuild b/net-ftp/uftpd/uftpd-2.15-r1.ebuild
new file mode 100644
index 000000000000..d936b50b56a2
--- /dev/null
+++ b/net-ftp/uftpd/uftpd-2.15-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="The no nonsense TFTP/FTP server"
+HOMEPAGE="https://github.com/troglobit/uftpd"
+SRC_URI="https://github.com/troglobit/${PN}/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ >=dev-libs/libite-1.5
+ >=dev-libs/libuev-2.2"
+RDEPEND="
+ ${DEPEND}
+ !net-misc/uftp
+ !net-ftp/atftp
+ !net-ftp/tftp-hpa[server(+)]"
+BDEPEND="
+ virtual/pkgconfig
+ test? (
+ net-ftp/ftp
+ net-ftp/tnftp
+ >=net-ftp/tftp-hpa-5.2-r2[client]
+ )"
+
+src_test() {
+ # can't run the tests in parallel since the order matters
+ emake -j 1 check
+}
+
+src_install() {
+ default
+ newinitd "${FILESDIR}"/uftpd.init uftpd
+ newconfd "${FILESDIR}"/uftpd.confd uftpd
+}