summaryrefslogtreecommitdiff
path: root/net-ftp/pybootd
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-ftp/pybootd
reinit the tree, so we can have metadata
Diffstat (limited to 'net-ftp/pybootd')
-rw-r--r--net-ftp/pybootd/Manifest6
-rw-r--r--net-ftp/pybootd/files/pybootd-scripts.patch36
-rw-r--r--net-ftp/pybootd/metadata.xml9
-rw-r--r--net-ftp/pybootd/pybootd-1.5.0_pre20110524131526.ebuild27
4 files changed, 78 insertions, 0 deletions
diff --git a/net-ftp/pybootd/Manifest b/net-ftp/pybootd/Manifest
new file mode 100644
index 000000000000..1983b4bc7dfd
--- /dev/null
+++ b/net-ftp/pybootd/Manifest
@@ -0,0 +1,6 @@
+AUX pybootd-scripts.patch 1055 SHA256 457d5d5335d70872aa443fd7597496bd122150e63c0109c3704116096e1b4208 SHA512 b3727ac420ab322742bfcbba6f59aea4e30d592549c1652ae092d93c4918d2d83ee9252058f4bf35dd0a3a3e20e97f2c032a6a2b014cc132ab7cc9e9a61c8933 WHIRLPOOL de1958afbe244a1264be482fc18700d9dd0bdae474867308abf052818d65226539de9e85a9244e4605c46fe473547b0d3e08a5203c62a7fcc5a38b9dc7992dfe
+DIST pybootd-1.5.0_pre20110524131526.tar.gz 21855 SHA256 55c7f74f32ac160a47631d2ef2f2962c2ea6c3321a3a5ef4dc8aac8be252468d SHA512 113a2195d33ba5a0196810370fedd582204de5f8323ecec37e6209fc7074cde06ba80cb8113fd83be70685c8ea18c6167d751085ea9bee5c1ab34dab152eea71 WHIRLPOOL 967322a33ae6a39f137910af9aa11f58ce58c3e0739817678d071356fa9d2a973411ca56bcdc056c2e0be1b95c410d12ee06dbbeffc960a9bc9125ccfdafdec8
+EBUILD pybootd-1.5.0_pre20110524131526.ebuild 597 SHA256 148928fde78013b7aa523040b94edffd1ee5643ce74b5e83a56a2ee604d02670 SHA512 6429cce2e69904a29d373096989d9d035c01cf344c46e22782c056eeaa4f9776335a040f3fc2d2174ef65279b7c7a4222a4f88831b68584d6bcc6a41da4f1816 WHIRLPOOL e7b76dd4760966bf968bd24cdeb6efc5b1e56d7f3362dafcac743d2aac45c60adad5fc056a6546186538082dc0cab80c29739c7b85c97561b8e3365ccca31239
+MISC ChangeLog 2597 SHA256 2162de2929bda0b238a12b1b36c80f0e14b8499ce964ffff29c729c5c9f54568 SHA512 3a08b2256c6689ce4b92d478e13ece56da8e78b77ba259c4ba7ea5b4a3e91a37f2e6044a1a0708befc81015acee45a56e02acc3ed8dbfa4289af97433a5c71e3 WHIRLPOOL 191ff48767e03273ef2c4e561c9cd784e30a4108c89bbdf6a9de8e2166eb3c5899aa8a9b4f72d548526dbe01819eb877280a82968e912b92b2c0bc7da9449030
+MISC ChangeLog-2015 427 SHA256 548afa7f8ea26692a11dd27248d0dabb313326437126a08e7a66cf957be1b596 SHA512 39ef863ac4568c6ff442b6618ea244a138b5a41d6e9230446b4d4a2ba2b69cbe89a70a88f3154039227b30b12fc9654c9335ca0d42025795e90ce47b9f03823d WHIRLPOOL 8cf9118bbb696837d89be331eba229dcb39474c2f5ad0d5ccc2c3c64080bf8b840098ac4cfe1039ca93e96cd501a33a06eda02f2c301af538291a161ab641818
+MISC metadata.xml 290 SHA256 0bcc4597dc32bba48111f8b124e554f1958cfb211d77bfde896ef312cc93f045 SHA512 b0756ada0e59328587d68c99d9ce401c0e2f3f5a402719a5e9b67b7969b56fd55c4930c63e1209e01d58562f09c45cbcedb758204efec65d09f82c4595e39ce5 WHIRLPOOL a420c5ec0dbbf309754ed3897e0550506a902ad0b2181fec82d2fa9c2240ce85e2a7413253023585dfff8d2dab8d59834fed3dc78797f32db4250ba9db31e1d9
diff --git a/net-ftp/pybootd/files/pybootd-scripts.patch b/net-ftp/pybootd/files/pybootd-scripts.patch
new file mode 100644
index 000000000000..71a001f44798
--- /dev/null
+++ b/net-ftp/pybootd/files/pybootd-scripts.patch
@@ -0,0 +1,36 @@
+install the pybootd.py helper as pybootd otherwise the import gets confused
+
+--- a/setup.py
++++ b/setup.py
+@@ -18,13 +18,23 @@
+ # License along with this library; if not, write to the Free Software
+ # Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+
++import shutil
+ from distutils.core import setup
++import distutils.command.install_scripts
+
+
+ def _read(fname):
+ import os
+ return open(os.path.join(os.path.dirname(__file__), fname)).read()
+
++class script_rename(distutils.command.install_scripts.install_scripts):
++
++ def run(self):
++ distutils.command.install_scripts.install_scripts.run(self)
++ for script in self.get_outputs():
++ if script.endswith('.py'):
++ shutil.move(script, script[:-3])
++
+ setup(
+ name='pybootd',
+ version='1.5.0',
+@@ -56,5 +66,7 @@ setup(
+ package_data = {
+ '': ['etc/*.ini', 'etc/*.cfg'],
+ },
++ cmdclass = {'install_scripts': script_rename},
++ scripts = ['pybootd.py'],
+ long_description=_read('README.rst'),
+ )
diff --git a/net-ftp/pybootd/metadata.xml b/net-ftp/pybootd/metadata.xml
new file mode 100644
index 000000000000..236bb92992dd
--- /dev/null
+++ b/net-ftp/pybootd/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <upstream>
+ <remote-id type="pypi">pybootd</remote-id>
+ <remote-id type="github">eblot/pybootd</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-ftp/pybootd/pybootd-1.5.0_pre20110524131526.ebuild b/net-ftp/pybootd/pybootd-1.5.0_pre20110524131526.ebuild
new file mode 100644
index 000000000000..ba6a2718f413
--- /dev/null
+++ b/net-ftp/pybootd/pybootd-1.5.0_pre20110524131526.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+GIT_HASH="7fd7d045fd4b4cdeebf4d07c1c5cd9649c2172b8"
+
+DESCRIPTION="Simplified BOOTP/DHCP/PXE/TFTP server"
+HOMEPAGE="https://github.com/eblot/pybootd"
+SRC_URI="https://github.com/eblot/pybootd/archive/${GIT_HASH:0:6}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-python/netifaces-0.5"
+DEPEND=""
+
+S="${WORKDIR}/pybootd-${GIT_HASH}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-scripts.patch
+)