summaryrefslogtreecommitdiff
path: root/net-ftp/filezilla/filezilla-3.39.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /net-ftp/filezilla/filezilla-3.39.0.ebuild
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'net-ftp/filezilla/filezilla-3.39.0.ebuild')
-rw-r--r--net-ftp/filezilla/filezilla-3.39.0.ebuild78
1 files changed, 0 insertions, 78 deletions
diff --git a/net-ftp/filezilla/filezilla-3.39.0.ebuild b/net-ftp/filezilla/filezilla-3.39.0.ebuild
deleted file mode 100644
index 94eaa9c0660f..000000000000
--- a/net-ftp/filezilla/filezilla-3.39.0.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-WX_GTK_VER="3.0-gtk3"
-
-inherit autotools flag-o-matic gnome2-utils wxwidgets
-
-MY_PV=${PV/_/-}
-MY_P="FileZilla_${MY_PV}"
-
-DESCRIPTION="FTP client with lots of useful features and an intuitive interface"
-HOMEPAGE="https://filezilla-project.org/"
-SRC_URI="https://download.filezilla-project.org/client/${MY_P}_src.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~ia64 ~ppc x86"
-IUSE="dbus nls test"
-
-# pugixml 1.7 minimal dependency is for c++11 proper configuration
-RDEPEND=">=app-eselect/eselect-wxwidgets-0.7-r1
- >=dev-libs/nettle-3.1:=
- >=dev-db/sqlite-3.7
- >=dev-libs/libfilezilla-0.15.1
- <dev-libs/libfilezilla-0.16.0
- >=dev-libs/pugixml-1.7
- >=net-libs/gnutls-3.4.15
- >=x11-libs/wxGTK-3.0.4:${WX_GTK_VER}[X]
- x11-misc/xdg-utils
- dbus? ( sys-apps/dbus )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- >=sys-devel/libtool-1.4
- nls? ( >=sys-devel/gettext-0.11 )
- test? ( >=dev-util/cppunit-1.13.0 )"
-
-RESTRICT="!test? ( test )"
-
-S="${WORKDIR}"/${PN}-${MY_PV}
-
-DOCS=(AUTHORS ChangeLog NEWS )
-
-PATCHES=(
- "${FILESDIR}"/${PN}-3.22.1-debug.patch
-)
-
-pkg_pretend() {
- if [[ ${MERGE_TYPE} != binary ]]; then
- if ! test-flag-CXX -std=c++14; then
- eerror "${P} requires C++14-capable C++ compiler. Your current compiler"
- eerror "does not seem to support -std=c++14 option. Please upgrade your compiler"
- eerror "to gcc-4.9 or an equivalent version supporting C++14."
- die "Currently active compiler does not support -std=c++14"
- fi
- fi
-}
-
-src_prepare() {
- setup-wxwidgets
- default
- eautoreconf
-}
-
-src_configure() {
- econf $(use_with dbus) $(use_enable nls locales) \
- --with-pugixml=system \
- --disable-autoupdatecheck
-}
-
-pkg_postinst() {
- gnome2_icon_cache_update
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
-}