summaryrefslogtreecommitdiff
path: root/net-fs/libnfs/libnfs-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-07 11:42:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-07 11:42:03 +0100
commitf70601e0934acd62f6c5d06c5ede4cc607179514 (patch)
tree0b337390375de04b950fc4b45edc0f895a4701a4 /net-fs/libnfs/libnfs-9999.ebuild
parentb2be182d49eea46686b5cf2680d457df61e89dc4 (diff)
gentoo resync : 07.07.2018
Diffstat (limited to 'net-fs/libnfs/libnfs-9999.ebuild')
-rw-r--r--net-fs/libnfs/libnfs-9999.ebuild31
1 files changed, 19 insertions, 12 deletions
diff --git a/net-fs/libnfs/libnfs-9999.ebuild b/net-fs/libnfs/libnfs-9999.ebuild
index 958c36a1dd24..96606a99d49c 100644
--- a/net-fs/libnfs/libnfs-9999.ebuild
+++ b/net-fs/libnfs/libnfs-9999.ebuild
@@ -1,42 +1,48 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI=6
-AUTOTOOLS_AUTORECONF="1"
-
-inherit autotools autotools-utils eutils
+inherit autotools
if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/sahlberg/${PN}.git"
inherit git-r3
+ EGIT_REPO_URI="https://github.com/sahlberg/${PN}.git"
else
SRC_URI="https://github.com/sahlberg/${PN}/archive/${P}.tar.gz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~x86"
+ S="${WORKDIR}/${PN}-${P}"
fi
DESCRIPTION="Client library for accessing NFS shares over a network"
HOMEPAGE="https://github.com/sahlberg/libnfs"
LICENSE="LGPL-2.1 GPL-3"
-SLOT="0/11" # sub-slot matches SONAME major
-IUSE="examples static-libs"
+SLOT="0/12" # sub-slot matches SONAME major
+IUSE="examples static-libs utils"
RDEPEND=""
DEPEND="${RDEPEND}
virtual/pkgconfig"
-S="${WORKDIR}/${PN}-${P}"
+PATCHES=(
+ "${FILESDIR}/${PN}-3.0.0-utils.patch"
+)
src_prepare() {
default
-
- epatch_user
-
eautoreconf
}
+src_configure() {
+ local myeconfargs=(
+ $(use_enable static-libs static)
+ $(use_enable utils)
+ )
+ econf "${myeconfargs[@]}"
+}
+
src_install() {
- autotools-utils_src_install
+ default
if use examples; then
# --enable-examples configure switch just compiles them
# better install sources instead
@@ -45,4 +51,5 @@ src_install() {
doexe examples/${program}.c
done
fi
+ find "${ED}" -name "*.la" -delete || die
}