summaryrefslogtreecommitdiff
path: root/net-firewall/nftables/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-30 17:36:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-30 17:36:28 +0100
commit7014a5a3ea0feffab9701fdd6b64cc7667a985af (patch)
treef2cbbaa8bb9209cd15208721103228336149b799 /net-firewall/nftables/files
parent7a86906b67693cc65671d3e1476835d3a7e13092 (diff)
gentoo resync : 30.06.2019
Diffstat (limited to 'net-firewall/nftables/files')
-rw-r--r--net-firewall/nftables/files/nftables-0.9.1-avoid_dive_into_py_subdir.patch49
-rw-r--r--net-firewall/nftables/files/nftables-0.9.1-python_build.patch45
2 files changed, 94 insertions, 0 deletions
diff --git a/net-firewall/nftables/files/nftables-0.9.1-avoid_dive_into_py_subdir.patch b/net-firewall/nftables/files/nftables-0.9.1-avoid_dive_into_py_subdir.patch
new file mode 100644
index 000000000000..8ff4b85d88a8
--- /dev/null
+++ b/net-firewall/nftables/files/nftables-0.9.1-avoid_dive_into_py_subdir.patch
@@ -0,0 +1,49 @@
+From c5ca85848c2fe28366d286a5b000f99d927516d3 Mon Sep 17 00:00:00 2001
+From: Jan Engelhardt <jengelh@inai.de>
+Date: Tue, 25 Jun 2019 08:58:34 +0200
+Subject: build: avoid recursion into py/ if not selected
+
+Signed-off-by: Jan Engelhardt <jengelh@inai.de>
+Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
+---
+ Makefile.am | 6 ++++--
+ py/Makefile.am | 3 ---
+ 2 files changed, 4 insertions(+), 5 deletions(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index e567d32d..4a17424d 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -3,8 +3,10 @@ ACLOCAL_AMFLAGS = -I m4
+ SUBDIRS = src \
+ include \
+ files \
+- doc \
+- py
++ doc
++if HAVE_PYTHON
++SUBDIRS += py
++endif
+
+ EXTRA_DIST = tests \
+ files
+diff --git a/py/Makefile.am b/py/Makefile.am
+index 9fce7c9e..5f4e1f6f 100644
+--- a/py/Makefile.am
++++ b/py/Makefile.am
+@@ -1,7 +1,5 @@
+ EXTRA_DIST = setup.py __init__.py nftables.py schema.json
+
+-if HAVE_PYTHON
+-
+ all-local:
+ cd $(srcdir) && \
+ $(PYTHON_BIN) setup.py build --build-base $(abs_builddir)
+@@ -28,4 +26,3 @@ clean-local:
+
+ distclean-local:
+ rm -f version
+-endif
+--
+cgit v1.2.1
+
diff --git a/net-firewall/nftables/files/nftables-0.9.1-python_build.patch b/net-firewall/nftables/files/nftables-0.9.1-python_build.patch
new file mode 100644
index 000000000000..81f65524ce7d
--- /dev/null
+++ b/net-firewall/nftables/files/nftables-0.9.1-python_build.patch
@@ -0,0 +1,45 @@
+From 1f7e4deb527db32c55646e6e5baedb2ff2aa205e Mon Sep 17 00:00:00 2001
+From: Jan Engelhardt <jengelh@inai.de>
+Date: Tue, 25 Jun 2019 08:58:33 +0200
+Subject: build: unbreak non-functionality of --disable-python
+
+Signed-off-by: Jan Engelhardt <jengelh@inai.de>
+Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
+---
+ configure.ac | 11 +++++++----
+ 1 file changed, 7 insertions(+), 4 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 75cf9199..b71268e8 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -103,11 +103,14 @@ AC_ARG_WITH([python_bin],
+ )
+
+ AS_IF([test "x$PYTHON_BIN" = "x"], [
+- AS_IF([test "x$enable_python" = "xyes"], [AC_MSG_ERROR([Python asked but not found])])
+- AS_IF([test "x$enable_python" = "xcheck"], [AC_MSG_WARN([Python not found, continuing anyway])])
++ AS_IF([test "x$enable_python" = "xyes"], [AC_MSG_ERROR([Python asked but not found])],
++ [test "x$enable_python" = "xcheck"], [
++ AC_MSG_WARN([Python not found, continuing anyway])
++ enable_python=no
+ ])
++])
+
+-AM_CONDITIONAL([HAVE_PYTHON], [test "x$PYTHON_BIN" != "x"])
++AM_CONDITIONAL([HAVE_PYTHON], [test "$enable_python" != "no"])
+
+ AC_CONFIG_FILES([ \
+ Makefile \
+@@ -138,7 +141,7 @@ nft configuration:
+ libxtables support: ${with_xtables}
+ json output support: ${with_json}"
+
+-AS_IF([test "x$PYTHON_BIN" != "x"], [
++AS_IF([test "$enable_python" != "no"], [
+ echo " enable Python: yes (with $PYTHON_BIN)"
+ ], [
+ echo " enable Python: no"
+--
+cgit v1.2.1
+