summaryrefslogtreecommitdiff
path: root/net-firewall/ipkungfu/ipkungfu-0.6.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-firewall/ipkungfu/ipkungfu-0.6.1-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-firewall/ipkungfu/ipkungfu-0.6.1-r1.ebuild')
-rw-r--r--net-firewall/ipkungfu/ipkungfu-0.6.1-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/net-firewall/ipkungfu/ipkungfu-0.6.1-r1.ebuild b/net-firewall/ipkungfu/ipkungfu-0.6.1-r1.ebuild
new file mode 100644
index 000000000000..94f6785c0b8e
--- /dev/null
+++ b/net-firewall/ipkungfu/ipkungfu-0.6.1-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="A nice iptables firewall script"
+HOMEPAGE="http://www.linuxkungfu.org/"
+SRC_URI="http://www.linuxkungfu.org/ipkungfu/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="net-firewall/iptables"
+RDEPEND="${DEPEND}
+ virtual/logger"
+
+src_prepare() {
+ eapply "${FILESDIR}/ipkungfu_noiseless.patch"
+ eapply_user
+}
+
+src_install() {
+ default
+
+ # Install configuration files
+ emake DESTDIR="${D}" install-config
+
+ # Install Gentoo init script
+ newinitd "${FILESDIR}"/ipkungfu.init ipkungfu
+}
+
+pkg_postinst() {
+ # Remove the cache dir so ipkungfu won't fail when running for
+ # the first time, in case 0.6.0 was installed before.
+ rm -rf /etc/ipkungfu/cache
+
+ einfo "Be sure, before running ipkungfu, to edit the config files in:"
+ einfo "/etc/ipkungfu/"
+ einfo
+ einfo "Also, be sure to run ipkungfu prior to rebooting,"
+ einfo "especially if you you're updating from <0.6.0 to >=0.6.0."
+ einfo "There are some significant configuration changes on this"
+ einfo "release covered by the ipkungfu script."
+}