summaryrefslogtreecommitdiff
path: root/net-dns/resolv_wrapper/resolv_wrapper-1.1.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /net-dns/resolv_wrapper/resolv_wrapper-1.1.6.ebuild
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'net-dns/resolv_wrapper/resolv_wrapper-1.1.6.ebuild')
-rw-r--r--net-dns/resolv_wrapper/resolv_wrapper-1.1.6.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/net-dns/resolv_wrapper/resolv_wrapper-1.1.6.ebuild b/net-dns/resolv_wrapper/resolv_wrapper-1.1.6.ebuild
new file mode 100644
index 000000000000..98ba5d7cdd3d
--- /dev/null
+++ b/net-dns/resolv_wrapper/resolv_wrapper-1.1.6.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_ECLASS=cmake
+inherit cmake-multilib
+
+DESCRIPTION="Wrapper for DNS name resolving or DNS faking"
+HOMEPAGE="https://cwrap.org/resolv_wrapper.html"
+SRC_URI="https://ftp.samba.org/pub/cwrap/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+# Work around a problem with >=dev-util/cmake-3.3.0 (bug #558340)
+# Because of this we cannot use cmake-multilib_src_configure() here.
+multilib_src_configure() {
+ local mycmakeargs=( -DCMAKE_LIBRARY_PATH=/usr/$(get_libdir) )
+ cmake_src_configure
+}