summaryrefslogtreecommitdiff
path: root/net-dns/openresolv/openresolv-3.12.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /net-dns/openresolv/openresolv-3.12.0-r1.ebuild
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'net-dns/openresolv/openresolv-3.12.0-r1.ebuild')
-rw-r--r--net-dns/openresolv/openresolv-3.12.0-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/net-dns/openresolv/openresolv-3.12.0-r1.ebuild b/net-dns/openresolv/openresolv-3.12.0-r1.ebuild
new file mode 100644
index 000000000000..f70291af0349
--- /dev/null
+++ b/net-dns/openresolv/openresolv-3.12.0-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A framework for managing DNS information"
+HOMEPAGE="https://roy.marples.name/projects/openresolv"
+SRC_URI="https://roy.marples.name/downloads/${PN}/${P}.tar.xz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
+IUSE="selinux"
+
+RDEPEND="!sys-apps/systemd[resolvconf]
+ selinux? ( sec-policy/selinux-resolvconf )"
+
+src_configure() {
+ local myeconfargs=(
+ --prefix="${EPREFIX}"
+ --rundir="${EPREFIX}"/var/run
+ --libexecdir="${EPREFIX}"/lib/resolvconf
+ )
+ econf "${myeconfargs[@]}"
+}
+
+pkg_config() {
+ if [[ -n ${ROOT} ]]; then
+ eerror "We cannot configure unless \$ROOT is empty"
+ return 1
+ fi
+
+ if [[ -n "$(resolvconf -l)" ]]; then
+ einfo "${PN} already has DNS information"
+ else
+ ebegin "Copying /etc/resolv.conf to resolvconf -a dummy"
+ resolvconf -a dummy </etc/resolv.conf
+ eend $? || return $?
+ einfo "The dummy interface will disappear when you next reboot"
+ fi
+}
+
+DOCS=( LICENSE README.md )