summaryrefslogtreecommitdiff
path: root/net-dns/mdns-repeater/mdns-repeater-1.11.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
commit8b4ace9c50842c5b83401ea7b179dcab940387e1 (patch)
tree230f3135ceaace633cf93e9838b185c4a6664c2e /net-dns/mdns-repeater/mdns-repeater-1.11.ebuild
parent9ee6d97c2883d42f204a533a8bc1f4562df778fb (diff)
gentoo resync : 23.09.2020
Diffstat (limited to 'net-dns/mdns-repeater/mdns-repeater-1.11.ebuild')
-rw-r--r--net-dns/mdns-repeater/mdns-repeater-1.11.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/net-dns/mdns-repeater/mdns-repeater-1.11.ebuild b/net-dns/mdns-repeater/mdns-repeater-1.11.ebuild
new file mode 100644
index 000000000000..70e66393f0c6
--- /dev/null
+++ b/net-dns/mdns-repeater/mdns-repeater-1.11.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Multicast DNS repeater"
+HOMEPAGE="https://github.com/kennylevinsen/mdns-repeater"
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm"
+
+SRC_URI="https://github.com/kennylevinsen/mdns-repeater/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+PATCHES=(
+ "${FILESDIR}/${P}-system-compiler-options.patch"
+)
+
+src_compile() {
+ emake HGVERSION="${PV}" CC=$(tc-getCC)
+}
+
+src_install() {
+ dobin "${PN}"
+ dodoc README.txt
+}