summaryrefslogtreecommitdiff
path: root/net-dns/libidn2/libidn2-2.3.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-14 23:53:26 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-14 23:53:26 +0000
commit3bd85407abc9ed4434c2d3741f84fdb512638b1c (patch)
tree15a296c276aca23d87cb4f2181f2249d706ca05f /net-dns/libidn2/libidn2-2.3.4.ebuild
parenta90c84e720803f3d26c0ade8f1f1e405ca97502a (diff)
gentoo auto-resync : 14:01:2023 - 23:53:26
Diffstat (limited to 'net-dns/libidn2/libidn2-2.3.4.ebuild')
-rw-r--r--net-dns/libidn2/libidn2-2.3.4.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/net-dns/libidn2/libidn2-2.3.4.ebuild b/net-dns/libidn2/libidn2-2.3.4.ebuild
index abe76b1078f5..7f65dd252bed 100644
--- a/net-dns/libidn2/libidn2-2.3.4.ebuild
+++ b/net-dns/libidn2/libidn2-2.3.4.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit multilib-minimal toolchain-funcs verify-sig
+inherit flag-o-matic multilib-minimal toolchain-funcs verify-sig
DESCRIPTION="An implementation of the IDNA2008 specifications (RFCs 5890, 5891, 5892, 5893)"
HOMEPAGE="
@@ -37,6 +37,13 @@ BDEPEND="
VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/libidn.asc
multilib_src_configure() {
+ # ideally we want !tc-ld-is-bfd for best future-proofing, but it needs
+ # https://github.com/gentoo/gentoo/pull/28355
+ # mold needs this too but right now tc-ld-is-mold is also not available
+ if tc-ld-is-lld; then
+ append-ldflags -Wl,--undefined-version
+ fi
+
local myconf=(
CC_FOR_BUILD="$(tc-getBUILD_CC)"
$(use_enable static-libs static)