summaryrefslogtreecommitdiff
path: root/net-dns/dnscrypt-proxy/dnscrypt-proxy-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
commit24fd814c326e282c4321965c31f341dad77e270d (patch)
tree033d63b33c21a3209964ab56005bb9bdd523630d /net-dns/dnscrypt-proxy/dnscrypt-proxy-9999.ebuild
parent129160ec854dca4c3fedb5bcfbcb56930371da0f (diff)
gentoo resync : 08.01.2021
Diffstat (limited to 'net-dns/dnscrypt-proxy/dnscrypt-proxy-9999.ebuild')
-rw-r--r--net-dns/dnscrypt-proxy/dnscrypt-proxy-9999.ebuild13
1 files changed, 7 insertions, 6 deletions
diff --git a/net-dns/dnscrypt-proxy/dnscrypt-proxy-9999.ebuild b/net-dns/dnscrypt-proxy/dnscrypt-proxy-9999.ebuild
index 4f7ddaa4a1b8..43359636f250 100644
--- a/net-dns/dnscrypt-proxy/dnscrypt-proxy-9999.ebuild
+++ b/net-dns/dnscrypt-proxy/dnscrypt-proxy-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -12,7 +12,7 @@ if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://${EGO_PN}.git"
else
SRC_URI="https://${EGO_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
fi
DESCRIPTION="A flexible DNS proxy, with support for encrypted DNS protocols"
@@ -23,7 +23,6 @@ SLOT="0"
IUSE="pie"
BDEPEND=">=dev-lang/go-1.13"
-
RDEPEND="
acct-group/dnscrypt-proxy
acct-user/dnscrypt-proxy
@@ -31,7 +30,9 @@ RDEPEND="
FILECAPS=( cap_net_bind_service+ep usr/bin/dnscrypt-proxy )
-PATCHES=( "${FILESDIR}"/config-full-paths-r11.patch )
+PATCHES=(
+ "${FILESDIR}/${PN}-2.0.45-config-full-paths.patch"
+)
src_compile() {
pushd "${PN}" >/dev/null || die
@@ -51,13 +52,13 @@ src_install() {
insinto /etc/dnscrypt-proxy
newins example-dnscrypt-proxy.toml dnscrypt-proxy.toml
- doins example-{blacklist.txt,whitelist.txt}
+ doins example-{allowed,blocked}-{ips.txt,names.txt}
doins example-{cloaking-rules.txt,forwarding-rules.txt}
popd >/dev/null || die
insinto /usr/share/dnscrypt-proxy
- doins -r "utils/generate-domains-blacklists/."
+ doins -r "utils/generate-domains-blocklist/."
newinitd "${FILESDIR}"/dnscrypt-proxy.initd dnscrypt-proxy
newconfd "${FILESDIR}"/dnscrypt-proxy.confd dnscrypt-proxy