summaryrefslogtreecommitdiff
path: root/net-dns/ddclient/ddclient-3.9.1-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /net-dns/ddclient/ddclient-3.9.1-r2.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'net-dns/ddclient/ddclient-3.9.1-r2.ebuild')
-rw-r--r--net-dns/ddclient/ddclient-3.9.1-r2.ebuild67
1 files changed, 67 insertions, 0 deletions
diff --git a/net-dns/ddclient/ddclient-3.9.1-r2.ebuild b/net-dns/ddclient/ddclient-3.9.1-r2.ebuild
new file mode 100644
index 000000000000..b7461a66f5c5
--- /dev/null
+++ b/net-dns/ddclient/ddclient-3.9.1-r2.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit systemd tmpfiles
+
+DESCRIPTION="Perl client used to update dynamic DNS entries"
+HOMEPAGE="https://ddclient.net/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv ~sparc x86"
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="examples iproute2 selinux"
+
+RDEPEND="
+ acct-group/ddclient
+ acct-user/ddclient
+ dev-lang/perl
+ dev-perl/Data-Validate-IP
+ dev-perl/Digest-SHA1
+ dev-perl/IO-Socket-INET6
+ dev-perl/IO-Socket-SSL
+ virtual/perl-Digest-SHA
+ virtual/perl-JSON-PP
+ iproute2? ( sys-apps/iproute2 )
+ selinux? ( sec-policy/selinux-ddclient )
+"
+
+src_prepare() {
+ # Remove PID setting, to reliably setup the environment for the init script
+ sed -e '/^pid/d' -i sample-etc_ddclient.conf || die
+
+ # Remove windows executable
+ if use examples; then
+ rm sample-etc_dhcpc_dhcpcd-eth0.exe || die
+ fi
+
+ # Use sys-apps/iproute2 instead of sys-apps/net-tools
+ use iproute2 && eapply "${FILESDIR}"/${PN}-3.9.0-use_iproute2.patch
+
+ default
+}
+
+src_install() {
+ dobin ddclient
+
+ insinto /etc/ddclient
+ insopts -m 0600 -o ddclient -g ddclient
+ newins sample-etc_ddclient.conf ddclient.conf
+
+ newinitd "${FILESDIR}"/ddclient.initd-r6 ddclient
+ systemd_newunit "${FILESDIR}"/ddclient.service-r1 ddclient.service
+ newtmpfiles "${FILESDIR}"/ddclient.tmpfiles ddclient.conf
+
+ dodoc Change* README* RELEASENOTE TODO UPGRADE
+
+ if use examples; then
+ docinto examples
+ dodoc sample-*
+ fi
+}
+
+pkg_postinst() {
+ tmpfiles_process ddclient.conf
+}