summaryrefslogtreecommitdiff
path: root/net-dns/bind-tools
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-19 14:14:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-19 14:14:48 +0100
commit5cfef3c94cd7e82136c69a0322f5ba21f7e64632 (patch)
tree8f255dfacbacb657e3ac3654d01c1e11e651c066 /net-dns/bind-tools
parent8aebb228036d5e2863b7eaa6e319ab41c1669269 (diff)
gentoo resync : 19.04.2018
Diffstat (limited to 'net-dns/bind-tools')
-rw-r--r--net-dns/bind-tools/Manifest2
-rw-r--r--net-dns/bind-tools/bind-tools-9.12.1.ebuild143
2 files changed, 145 insertions, 0 deletions
diff --git a/net-dns/bind-tools/Manifest b/net-dns/bind-tools/Manifest
index 21b57aa8b0e0..ae13e4dea533 100644
--- a/net-dns/bind-tools/Manifest
+++ b/net-dns/bind-tools/Manifest
@@ -1,4 +1,6 @@
AUX bind-tools-9.5.0_p1-lwconfig.patch 1856 BLAKE2B 3f65aaf584ced53a098cd9536eb4e8fd243b50ef0845be3008066fa0b45915f4e2db585d3f64896782e7bf94362235fc31c1f869169d92996cdaf081935a4047 SHA512 f46290cddfb39b077269cd2198d04eef6a7e680b5f0f8dcf471e551a61b4b7a56871a56cdd20afdeaa86edb790513d8c522032fb725a266c18e0e59eee803dcc
DIST bind-9.11.2_p1.tar.gz 9783329 BLAKE2B 5a3bbd87112064231bd5e6b09ebb4014f9d5cf65cb601c03555ff540a22d87aec3990cd8e37ce5ff09e9a149bdf122d20ecb01f87731e6c79d80379a6926014f SHA512 168f27f580e3be2f7ada27afa2f72e715e750eec76831cf01bd32fabc1fa65dc29dab0eb7ed1682b076d3be99269897ddbc2c10551631a3911d9e5ae1aa40597
+DIST bind-9.12.1.tar.gz 9302783 BLAKE2B 731ce67acb22f72e54de1122c5d5c3c1f0663c400bdff9545578a45e5fe3094c6d754351e57dd5c52cdfe1528305dfde25eba7382a723a60b8bfdfeebb9536cd SHA512 701e34a0a3313568c8e5cf76668fefc2a1fceb2ade0de201b8f678401569f1c622c3d1657a71772fa3298efc8b3cdefe974d98432c0087e8b45af3d50a4262fb
EBUILD bind-tools-9.11.2_p1.ebuild 3152 BLAKE2B 814d08d064071658a17a8e6e3beb069cf8567a11e1ec74bb78f823a3d03feb0429b41feddd97b04d24deb76f92c963d6633f1f84a08a9392eedd5e7b9d745db5 SHA512 40d646ff0b6e45b18de53360b27d3d3d1211606d2f28ef4708bc69a055565962cedb2ac75e24ac9e27b94ce36cb53273e85e4555827ff7a0b7b106aa21ad36f8
+EBUILD bind-tools-9.12.1.ebuild 3339 BLAKE2B ebae2c28743ae946728bd4be3d1c3240a27d7014b03b1c6c90e00173e7516c6e0fd244be2a0d98cdde6e5eec6768cee94f6e83b958e8abc4d19af9a4cf1557cc SHA512 18521742cf8b7bcbec0785b8573de49bb18ed7832a8406bf4e34b3d501cc895aeaa2742d55a32427a2035086cea9eed4b4edab673314123bb26af36f0db12323
MISC metadata.xml 513 BLAKE2B bfb78568f9c2b262000c297e06791ddee8455c24a29e0fc822e272ed7d1cc3b90cd106f4faf3eff1da3824aca8dbe359b7fb3f767d72a967464edc649728066e SHA512 5c817f1afce4f096d912de9f0cd82b92e2b97f86db24de5eae8aa1a877c78e1800582b4615666c43f139049e179dbc30134692d7039517f97cf53ba9a2dcbd4d
diff --git a/net-dns/bind-tools/bind-tools-9.12.1.ebuild b/net-dns/bind-tools/bind-tools-9.12.1.ebuild
new file mode 100644
index 000000000000..9e9247ebe9a0
--- /dev/null
+++ b/net-dns/bind-tools/bind-tools-9.12.1.ebuild
@@ -0,0 +1,143 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit eutils autotools flag-o-matic toolchain-funcs
+
+MY_PN=${PN//-tools}
+MY_PV=${PV/_p/-P}
+MY_PV=${MY_PV/_rc/rc}
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="bind tools: dig, nslookup, host, nsupdate, dnssec-keygen"
+HOMEPAGE="http://www.isc.org/software/bind"
+SRC_URI="https://www.isc.org/downloads/file/${MY_P}/?version=tar-gz -> ${MY_PN}-${PV}.tar.gz"
+
+LICENSE="Apache-2.0 BSD BSD-2 GPL-2 HPND ISC MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc gost gssapi idn ipv6 libedit libressl readline seccomp ssl urandom xml"
+# no PKCS11 currently as it requires OpenSSL to be patched, also see bug 409687
+
+REQUIRED_USE="gost? ( !libressl ssl )"
+
+CDEPEND="
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:= )
+ )
+ gost? ( >=dev-libs/openssl-1.0.0:0=[-bindist] )
+ xml? ( dev-libs/libxml2 )
+ idn? ( <net-dns/idnkit-2:= )
+ gssapi? ( virtual/krb5 )
+ libedit? ( dev-libs/libedit )
+ !libedit? (
+ readline? ( sys-libs/readline:0= )
+ )
+ seccomp? ( sys-libs/libseccomp )"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${CDEPEND}
+ !<net-dns/bind-9.10.2"
+
+S="${WORKDIR}/${MY_P}"
+
+# bug 479092, requires networking
+RESTRICT="test"
+
+src_prepare() {
+ # Disable tests for now, bug 406399
+ sed -i '/^SUBDIRS/s:tests::' bin/Makefile.in lib/Makefile.in || die
+
+ # bug #220361
+ rm aclocal.m4
+ rm -rf libtool.m4/
+
+ mv configure.in configure.ac || die # configure.in is deprecated
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=
+
+ if use urandom; then
+ myconf="${myconf} --with-randomdev=/dev/urandom"
+ else
+ myconf="${myconf} --with-randomdev=/dev/random"
+ fi
+
+ # bug 607400
+ if use libedit ; then
+ myconf+=' --with-readline=-ledit'
+ elif use readline ; then
+ myconf+=' --with-readline=-lreadline'
+ else
+ myconf+=' --without-readline'
+ fi
+
+ # bug 344029
+ append-cflags "-DDIG_SIGCHASE"
+
+ # localstatedir for nsupdate -l, bug 395785
+ tc-export BUILD_CC
+ econf \
+ --localstatedir=/var \
+ --without-python \
+ --without-libjson \
+ --without-zlib \
+ --without-lmdb \
+ --disable-openssl-version-check \
+ $(use_enable ipv6) \
+ $(use_with idn) \
+ $(usex idn --with-idnlib=-lidnkit '') \
+ $(use_enable seccomp) \
+ $(use_with ssl openssl) \
+ $(use_with xml libxml2) \
+ $(use_with gssapi) \
+ $(use_with readline) \
+ $(use_with gost) \
+ ${myconf}
+
+ # bug #151839
+ echo '#undef SO_BSDCOMPAT' >> config.h
+}
+
+src_compile() {
+ local AR=$(tc-getAR)
+
+ emake AR="${AR}" -C lib/
+ emake AR="${AR}" -C bin/delv/
+ emake AR="${AR}" -C bin/dig/
+ emake AR="${AR}" -C bin/nsupdate/
+ emake AR="${AR}" -C bin/dnssec/
+}
+
+src_install() {
+ dodoc README CHANGES
+
+ cd "${S}"/bin/delv
+ dobin delv
+ doman delv.1
+
+ cd "${S}"/bin/dig
+ dobin dig host nslookup
+ doman {dig,host,nslookup}.1
+
+ cd "${S}"/bin/nsupdate
+ dobin nsupdate
+ doman nsupdate.1
+ if use doc; then
+ dohtml nsupdate.html
+ fi
+
+ cd "${S}"/bin/dnssec
+ for tool in dsfromkey importkey keyfromlabel keygen \
+ revoke settime signzone verify; do
+ dobin dnssec-"${tool}"
+ doman dnssec-"${tool}".8
+ if use doc; then
+ dohtml dnssec-"${tool}".html
+ fi
+ done
+}