summaryrefslogtreecommitdiff
path: root/net-dialup/pppconfig
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /net-dialup/pppconfig
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'net-dialup/pppconfig')
-rw-r--r--net-dialup/pppconfig/Manifest4
-rw-r--r--net-dialup/pppconfig/pppconfig-2.3.21.ebuild13
-rw-r--r--net-dialup/pppconfig/pppconfig-2.3.25.ebuild56
3 files changed, 66 insertions, 7 deletions
diff --git a/net-dialup/pppconfig/Manifest b/net-dialup/pppconfig/Manifest
index a6b6dd7c1aa9..49faa778fc56 100644
--- a/net-dialup/pppconfig/Manifest
+++ b/net-dialup/pppconfig/Manifest
@@ -1,4 +1,6 @@
AUX pppconfig 219 BLAKE2B 2772adf47e4360af993e4011e3c4e51cc000cb891d624c44494cff400a89768f05c384b69d786f73df0c0bc710417d1ec583d71b3c390d153285f4bce08d3c49 SHA512 1fce4236bc67ff9f9c5d5d273794863504dd93f75c6383ac921028ed255b3b7830ae4dd7182cf0f93241e350a7ef0619ad9f8bd38c50d20b4baf86421bc075d9
DIST pppconfig_2.3.21.tar.gz 397243 BLAKE2B 5816d9b1e832bd0e694718960ea45c0996fa7a459f3a38e03b0021d20549b81e5a74111c03f7f485bd4dbd408b2859864a69c55858cb0a4f70283971a64192bb SHA512 e6297a6834eb806d591aee44343c6e64536e260ea8e637f3a4d4b5a752e26ae90d467ca12dd83022e071f7c2c4f111660418a6b953c4a02f5618fc54a89c2893
-EBUILD pppconfig-2.3.21.ebuild 1051 BLAKE2B 0bf27d25d4794a3db7e37cfab6632e169b69f43edb4dacc11f3d3ba1895239c0ed60e34d0ce0b606e2f1c4eb34efa364404c93d3f7be6d50e46f943bf1ca4fff SHA512 1c7a3f4a9908f3cef58e2a07e580c4945a69064a6d099fc810002fdd0fade46c5db37156c4983e6ff500e74da635fd2272fcb417ad8df18a3e79f56b469aa26e
+DIST pppconfig_2.3.25.tar.gz 392316 BLAKE2B 7c30db92cff0c9e80e04e4e7a83ccc22e2c1380831fcbc1ebd36bc4d30044c0b32669546907318be3c43061d1ea9f44b0a471f56847e75b0470f18f1aa10bf7a SHA512 6874b93ae34edb2a0ba06a669d930f5023a3eae38b6d10a78179eb69990a8280d41ebc2049461b54b03bd19904d13d2ebb57997599ed650660d0b34c958ad977
+EBUILD pppconfig-2.3.21.ebuild 1052 BLAKE2B 9c7c177b6fb81fa648f10be54d4eccf63a1728d28412f73660ccb53db3d155320156603f34c436c523415dd261233fbf17a48bf2317abfe0ded19f1f1c97f7f8 SHA512 c5cb821726dc3760de1d6f59fd238b91ce29a2400178a488c279352df67a0e01ee765804c1b17470c1dcda7834530d8232745a2661a0ac74118cbd9d0a8599c4
+EBUILD pppconfig-2.3.25.ebuild 1060 BLAKE2B bce1a83286dbcda0820c55b1d312610907f6eb479387b153a80c4968e3671c0f6e3e0fefbe8af6dbe6ace8814eb220dbc1fc1f2642a49ab2f4200954a107b868 SHA512 e7e76e1445fb1eef0831c83f08d6edc28a79a7ab9fa2ddb3376ff183751fa4ef473decf27e7a8285e89946447e5bf3d7a42ebf9a39f754b7b21ebdf26ef270c8
MISC metadata.xml 167 BLAKE2B 868e3b584722eaacf68273db062bb773d8c7e5d7ab2b81ca7e8397643bf7cc106c3a1033594401c99c54f667bb45d6b73f9048fc335580bbd44b4589ad26a832 SHA512 30caadd1496c3b9969136038239a1d8e01f236726b4022c2d7e19ca7575f25f735e556835e581afbf44fbd3e4104c40f2b5ef5fa70118d75c881fdf871962d0a
diff --git a/net-dialup/pppconfig/pppconfig-2.3.21.ebuild b/net-dialup/pppconfig/pppconfig-2.3.21.ebuild
index 808ccc0a705e..b2560f286d53 100644
--- a/net-dialup/pppconfig/pppconfig-2.3.21.ebuild
+++ b/net-dialup/pppconfig/pppconfig-2.3.21.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=8
inherit strip-linguas
@@ -14,15 +14,16 @@ LICENSE="GPL-2"
KEYWORDS="amd64 ppc x86"
IUSE="nls"
-RDEPEND="net-dialup/ppp
+RDEPEND="
+ net-dialup/ppp
dev-util/dialog
dev-lang/perl"
-DEPEND="nls? ( sys-devel/gettext )"
+BDEPEND="nls? ( sys-devel/gettext )"
src_prepare() {
- if use nls; then
- strip-linguas -i po/
- fi
+ default
+
+ use nls && strip-linguas -i po/
}
src_compile() {
diff --git a/net-dialup/pppconfig/pppconfig-2.3.25.ebuild b/net-dialup/pppconfig/pppconfig-2.3.25.ebuild
new file mode 100644
index 000000000000..5816bbea39c4
--- /dev/null
+++ b/net-dialup/pppconfig/pppconfig-2.3.25.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit strip-linguas
+
+DESCRIPTION="A text menu based utility for configuring ppp"
+HOMEPAGE="https://tracker.debian.org/pkg/pppconfig"
+SRC_URI="mirror://debian/pool/main/p/${PN}/${P/-/_}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="nls"
+
+RDEPEND="net-dialup/ppp
+ dev-util/dialog
+ dev-lang/perl"
+BDEPEND="nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ default
+
+ if use nls; then
+ strip-linguas -i po/
+ fi
+}
+
+src_compile() {
+ default
+
+ if use nls; then
+ local lang
+ for lang in ${LINGUAS}; do
+ msgfmt -o po/${lang}.{m,p}o || die
+ done
+ fi
+}
+
+src_install() {
+ keepdir /etc/chatscripts /etc/ppp/resolv
+ dosbin 0dns-down 0dns-up dns-clean
+ newsbin pppconfig pppconfig.real
+ dosbin "${FILESDIR}/pppconfig"
+ doman man/pppconfig.8
+ dodoc debian/{copyright,changelog}
+
+ if use nls; then
+ local lang
+ for lang in ${LINGUAS}; do
+ insinto /usr/share/locale/${lang}/LC_MESSAGES
+ newins po/${lang}.mo pppconfig.mo
+ done
+ fi
+}