summaryrefslogtreecommitdiff
path: root/net-dialup/ppp/ppp-2.4.7-r6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-23 07:00:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-23 07:00:28 +0100
commite23cdda4dbb0c83b9e682ab5e916085a35203da5 (patch)
tree5a4ac448a3b288b731c24d947e0ce52df3cab07b /net-dialup/ppp/ppp-2.4.7-r6.ebuild
parent8187a741807f3e9a9e26304973cf18087dcf2560 (diff)
gentoo resync : 23.06.2018
Diffstat (limited to 'net-dialup/ppp/ppp-2.4.7-r6.ebuild')
-rw-r--r--net-dialup/ppp/ppp-2.4.7-r6.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/net-dialup/ppp/ppp-2.4.7-r6.ebuild b/net-dialup/ppp/ppp-2.4.7-r6.ebuild
index 5e0743255bf3..b60a527f75cb 100644
--- a/net-dialup/ppp/ppp-2.4.7-r6.ebuild
+++ b/net-dialup/ppp/ppp-2.4.7-r6.ebuild
@@ -14,7 +14,7 @@ SRC_URI="https://download.samba.org/pub/ppp/${P}.tar.gz
LICENSE="BSD GPL-2"
SLOT="0/${PV}"
-KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ia64 ~mips ~ppc ~ppc64 ~s390 ~sh sparc x86"
+KEYWORDS="~alpha amd64 ~arm ~arm64 hppa ia64 ~mips ~ppc ~ppc64 ~s390 ~sh sparc x86"
IUSE="activefilter atm dhcp eap-tls gtk ipv6 libressl pam radius"
DEPEND="activefilter? ( net-libs/libpcap )
@@ -86,11 +86,19 @@ src_prepare() {
sed -i -e '/+= radius/s:^:#:' pppd/plugins/Makefile.linux || die
fi
+ # Respect our pkg-config settings.
+ sed -i \
+ -e 's:pkg-config:$(PKG_CONFIG):' \
+ contrib/pppgetpass/Makefile.linux || die
+ sed -i \
+ -e '/^LIBS/{s:-L/usr/local/ssl/lib::;s:-lcrypto:`$(PKG_CONFIG) --libs libcrypto`:}' \
+ pppd/Makefile.linux || die
+
eapply_user #549588
}
src_compile() {
- tc-export AR CC
+ tc-export AR CC PKG_CONFIG
emake COPTS="${CFLAGS} -D_GNU_SOURCE"
# build pppgetpass