summaryrefslogtreecommitdiff
path: root/net-dialup/minicom/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /net-dialup/minicom/files
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'net-dialup/minicom/files')
-rw-r--r--net-dialup/minicom/files/minicom-2.7.1-musl.patch24
-rw-r--r--net-dialup/minicom/files/minicom-2.8-gentoo-runscript.patch42
-rw-r--r--net-dialup/minicom/files/minicom-2.8-lockdir.patch14
3 files changed, 80 insertions, 0 deletions
diff --git a/net-dialup/minicom/files/minicom-2.7.1-musl.patch b/net-dialup/minicom/files/minicom-2.7.1-musl.patch
new file mode 100644
index 000000000000..da4ce13d0b8f
--- /dev/null
+++ b/net-dialup/minicom/files/minicom-2.7.1-musl.patch
@@ -0,0 +1,24 @@
+--- a/src/dial.c
++++ b/src/dial.c
+@@ -39,11 +39,9 @@
+ #include "intl.h"
+
+ #ifdef VC_MUSIC
+-# if defined(__GLIBC__)
+ # include <sys/ioctl.h>
+ # include <sys/kd.h>
+ # include <sys/time.h>
+-# endif
+ #endif
+
+ enum { CURRENT_VERSION = 6 };
+--- a/src/getsdir.h
++++ b/src/getsdir.h
+@@ -22,6 +22,7 @@
+ * and licensing conditions. See the source, Luke.
+ */
+
++#include <sys/param.h>
+ #include <dirent.h>
+
+ typedef struct dirEntry { /* structure of data item */
diff --git a/net-dialup/minicom/files/minicom-2.8-gentoo-runscript.patch b/net-dialup/minicom/files/minicom-2.8-gentoo-runscript.patch
new file mode 100644
index 000000000000..97c53e91c8ef
--- /dev/null
+++ b/net-dialup/minicom/files/minicom-2.8-gentoo-runscript.patch
@@ -0,0 +1,42 @@
+--- a/man/minicom.1
++++ b/man/minicom.1
+@@ -469,7 +469,7 @@
+ .TP 0.5i
+ .B D - Script program
+ Which program to use as the script interpreter. Defaults to the
+-program "runscript", but if you want to use something else (eg,
++program "/usr/bin/runscript", but if you want to use something else (eg,
+ /bin/sh or "expect") it is possible. Stdin and stdout are connected
+ to the modem, stderr to the screen.
+ .RS 0.5i
+--- a/man/runscript.1
++++ b/man/runscript.1
+@@ -5,7 +5,7 @@
+ .\" for conditions under which this file may be redistributed.
+ .TH RUNSCRIPT 1 "$Date: 2007-10-07 18:13:51 $" "User's Manual"
+ .SH NAME
+-runscript \- script interpreter for minicom
++/usr/bin/runscript \- script interpreter for minicom
+ .SH SYNOPSIS
+ .B runscript
+ .RI "scriptname [logfile [homedir]]"
+--- a/src/rwconf.c
++++ b/src/rwconf.c
+@@ -105,7 +105,7 @@
+ { N_("No"), 0, "kermreal" },
+ { "3", 0, "colusage" },
+ /* The script program */
+- { "runscript", 0, "scriptprog" },
++ { "/usr/bin/runscript", 0, "scriptprog" },
+ /* Modem parameters */
+ { "", 0, "minit" },
+ { "", 0, "mreset" },
+@@ -245,7 +245,7 @@
+ int matched;
+
+ if (conftype == CONFIG_GLOBAL)
+- strcpy(P_SCRIPTPROG, "runscript");
++ strcpy(P_SCRIPTPROG, "/usr/bin/runscript");
+
+ line = malloc(line_size);
+ if (!line) {
diff --git a/net-dialup/minicom/files/minicom-2.8-lockdir.patch b/net-dialup/minicom/files/minicom-2.8-lockdir.patch
new file mode 100644
index 000000000000..17fb635cd9bc
--- /dev/null
+++ b/net-dialup/minicom/files/minicom-2.8-lockdir.patch
@@ -0,0 +1,14 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -219,7 +219,10 @@
+
+ if test "x$UUCPLOCK" != x
+ then
+- if test -d $UUCPLOCK
++ dnl If a lock directory was manually specified, do not test it actually,
++ dnl as that might not be true during a chroot build, and the
++ dnl packager is responsible for making sure it exists at runtime.
++ if true
+ then
+ AC_MSG_RESULT($UUCPLOCK)
+ AC_DEFINE_UNQUOTED(UUCPLOCK, "$UUCPLOCK", [Lock directory])