summaryrefslogtreecommitdiff
path: root/net-dialup/mgetty/mgetty-1.1.37-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-01 03:04:39 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-01 03:04:39 +0000
commit407525b571b48cfd65e1ad7a02d250a927c967c9 (patch)
tree844bea44d85dc7218f54970af1c42cc9d55c3f1a /net-dialup/mgetty/mgetty-1.1.37-r1.ebuild
parent89c6c06b8c42107dd231687a1012354e7d3039fc (diff)
gentoo resync : 01.12.2017
Diffstat (limited to 'net-dialup/mgetty/mgetty-1.1.37-r1.ebuild')
-rw-r--r--net-dialup/mgetty/mgetty-1.1.37-r1.ebuild33
1 files changed, 18 insertions, 15 deletions
diff --git a/net-dialup/mgetty/mgetty-1.1.37-r1.ebuild b/net-dialup/mgetty/mgetty-1.1.37-r1.ebuild
index f071ac4d388e..a6305c0271c8 100644
--- a/net-dialup/mgetty/mgetty-1.1.37-r1.ebuild
+++ b/net-dialup/mgetty/mgetty-1.1.37-r1.ebuild
@@ -1,14 +1,15 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit eutils flag-o-matic toolchain-funcs user
+EAPI=6
+inherit flag-o-matic toolchain-funcs user
DESCRIPTION="fax and voice modem programs"
SRC_URI="ftp://mgetty.greenie.net/pub/mgetty/source/1.1/${PN}${PV}-Jun05.tar.gz"
HOMEPAGE="http://mgetty.greenie.net/"
-DEPEND="doc? ( virtual/latex-base virtual/texi2dvi )
+DEPEND="
+ doc? ( virtual/latex-base virtual/texi2dvi )
>=sys-apps/sed-4
sys-apps/groff
dev-lang/perl
@@ -17,9 +18,11 @@ DEPEND="doc? ( virtual/latex-base virtual/texi2dvi )
fax? (
!net-misc/efax
!net-misc/hylafax
- )"
+ )
+"
RDEPEND="${DEPEND}
- fax? ( media-libs/netpbm app-text/ghostscript-gpl )"
+ fax? ( media-libs/netpbm app-text/ghostscript-gpl )
+"
SLOT="0"
LICENSE="GPL-2"
@@ -32,12 +35,13 @@ pkg_setup() {
}
src_prepare() {
- epatch "${FILESDIR}/${P}-gentoo.patch"
- epatch "${FILESDIR}/${P}-qa-fixes.patch"
- epatch "${FILESDIR}/${PN}-1.1.36-callback.patch" # add callback install to Makefile
- epatch "${FILESDIR}/Lucent.c.patch" # Lucent modem CallerID patch - bug #80366
- use fax || epatch "${FILESDIR}/${P}-nofax.patch" # don't install fax related files - bug #195467
- epatch "${FILESDIR}/${PN}-1.1.36-tmpfile.patch" # fix security bug 235806
+ eapply "${FILESDIR}/${P}-gentoo.patch"
+ eapply "${FILESDIR}/${P}-qa-fixes.patch"
+ eapply "${FILESDIR}/${PN}-1.1.36-callback.patch" # add callback install to Makefile
+ eapply "${FILESDIR}/Lucent.c.patch" # Lucent modem CallerID patch - bug #80366
+ use fax || eapply "${FILESDIR}/${P}-nofax.patch" # don't install fax related files - bug #195467
+ eapply "${FILESDIR}/${PN}-1.1.36-tmpfile.patch" # fix security bug 235806
+ eapply "${FILESDIR}/${P}-gcc7.patch"
sed -e 's:var/log/mgetty:var/log/mgetty/mgetty:' \
-e 's:var/log/sendfax:var/log/mgetty/sendfax:' \
@@ -60,6 +64,8 @@ src_prepare() {
# Support user's CFLAGS and LDFLAGS.
sed -e "s/\$(CFLAGS) -o newslock/${CFLAGS} ${LDFLAGS} -Wall -o newslock/" \
-e "s/\$(LDLAGS)/${LDFLAGS}/" -i {,fax/}Makefile || die
+
+ default
}
src_compile() {
@@ -157,7 +163,4 @@ pkg_postinst() {
elog
elog "If you want to grab voice messages from a remote location, you must save"
elog "the password in /var/spool/voice/.code file"
- echo
- ewarn "/var/spool/voice/.code and /var/spool/voice/messages/Index"
- ewarn "are not longer created by this automatically!"
}