summaryrefslogtreecommitdiff
path: root/net-analyzer
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-10 12:32:09 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-10 12:32:09 +0100
commitbcb1bf8297438e33e98fec6991ba68dec0f4dd7c (patch)
tree641656fce8ff13ec9fae86d68bd03073d9afc4a0 /net-analyzer
parentfb0d4b003026d01b3d52956c7a0069b9363efff8 (diff)
gentoo auto-resync : 10:04:2024 - 12:32:09
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/Manifest.gzbin43620 -> 43628 bytes
-rw-r--r--net-analyzer/pontos/Manifest2
-rw-r--r--net-analyzer/pontos/pontos-24.3.2.ebuild44
3 files changed, 46 insertions, 0 deletions
diff --git a/net-analyzer/Manifest.gz b/net-analyzer/Manifest.gz
index d3c127bc1eda..d3eed783baf6 100644
--- a/net-analyzer/Manifest.gz
+++ b/net-analyzer/Manifest.gz
Binary files differ
diff --git a/net-analyzer/pontos/Manifest b/net-analyzer/pontos/Manifest
index 19c089c14777..1d35db8c7b16 100644
--- a/net-analyzer/pontos/Manifest
+++ b/net-analyzer/pontos/Manifest
@@ -1,3 +1,5 @@
DIST pontos-24.1.2.tar.gz 379930 BLAKE2B b0c9fd02c17ca0fed7468e34264f8e41e87b4c50f6254d8d4d9ee5c7a8444a7acfbf3c113483e26831be68279d7c08bf412634fff5e3454dc0e7ec5273ddcdd6 SHA512 55fcb768d89b0fd478bbf14a435d7d42c6c9ae2ff2a834ce685e25b105ed071d156d1afbc0231d80dd8d5c844f33b648b08772a0aab943127c58f9a475f267d9
+DIST pontos-24.3.2.tar.gz 378585 BLAKE2B cb6a89a2fbfefe1b038b5886dc7a278657d36a05bab818335efd029d6320b8b60defcd73c3e94df17008ab611434898b565cb7057e1f0198113bd8a7a0600934 SHA512 4ed6a79097197da01d35a660ce13edfa028c11b082626038ea037b99b1f365b054d2c07ae841c739735da057e2d8d9fc64b63f18ad3aa941e14ff725261dde80
EBUILD pontos-24.1.2.ebuild 1274 BLAKE2B 6f1619401dc82a4f0283f3e925a57db91a7b9e7d5f5604827b519071185579c4a07982d2ad6c860d75d2d7474e0762ae2a867043bde557f4f50fc1e1425e9002 SHA512 3ad731ebd0ccf1f218d4526abef414c5593bae4fd0f88958013e6a295d55f10796a962e18f781180ade52b17415906338eff0f340c57a5494d5ce5eea07b6244
+EBUILD pontos-24.3.2.ebuild 1325 BLAKE2B 11d2ab12b6403bc0775097e88d183c8af9426478167c1bb54b954afb6f7dab4ffa0813ec096413fa0c3fd38784e01b5b573d11cda5949184092231f60fb82197 SHA512 bf69c9a12d648e1d997727b036e1a4e2a18500ff36c67a08f9be7e848e418e3106c3bb4d7efe609dda5eb446dd05d7ecdf89c818951f2afed4494d1e6376ccc8
MISC metadata.xml 731 BLAKE2B 3c04d3cc6cbf0398dbbefd010187d660a1070f6c65c8227f76c9b33525af61d1c5178a96557f9c160df530619607fc792faf0b5d9f6716339bef8976c60e725c SHA512 cc37e6efd9a25f6984c96607bc4deae3305e165368a5d80a9a306d3802c223109d4afdcf950ee19444ebd6e1c23954749c6f0c18f0ca8744e5671da4ceb1039c
diff --git a/net-analyzer/pontos/pontos-24.3.2.ebuild b/net-analyzer/pontos/pontos-24.3.2.ebuild
new file mode 100644
index 000000000000..bf8315f7c568
--- /dev/null
+++ b/net-analyzer/pontos/pontos-24.3.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+DISTUTILS_USE_PEP517=poetry
+
+inherit distutils-r1
+
+DESCRIPTION="Common utilities and tools maintained by Greenbone Networks"
+HOMEPAGE="
+ https://www.greenbone.net
+ https://github.com/greenbone/pontos/
+ https://greenbone.github.io/pontos/
+"
+
+SRC_URI="https://github.com/greenbone/pontos/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-3+"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/colorful-0.5.4[${PYTHON_USEDEP}]
+ >=dev-python/tomlkit-0.5.11[${PYTHON_USEDEP}]
+ >=dev-python/packaging-20.3[${PYTHON_USEDEP}]
+ >=dev-python/httpx-0.23[${PYTHON_USEDEP}]
+ >=dev-python/rich-12.4.4[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.8.2[${PYTHON_USEDEP}]
+ >=dev-python/semver-2.13[${PYTHON_USEDEP}]
+ >=dev-python/lxml-4.9.0[${PYTHON_USEDEP}]
+ >=dev-python/shtab-1.7.0[${PYTHON_USEDEP}]
+"
+
+DEPEND="${RDEPEND}"
+
+EPYTEST_DESELECT=(
+ tests/git/test_git.py::GitExtendedTestCase::test_git_error
+ tests/version/commands/test_java.py::GetCurrentJavaVersionCommandTestCase::test_getting_version_without_version_config
+ tests/version/commands/test_java.py::VerifyJavaVersionCommandTestCase::test_verify_version_does_not_match
+)
+
+distutils_enable_tests pytest