summaryrefslogtreecommitdiff
path: root/net-analyzer
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-17 06:49:08 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-17 06:49:08 +0000
commit2bf68d7062b64d9f815f3b8ce6942a66afe53b0d (patch)
treeac1e773aaa4d3575d18d178ae260cab963bbf64c /net-analyzer
parentcd356b722fd8d162f02a5059fae1a66e00be52e3 (diff)
gentoo auto-resync : 17:03:2024 - 06:49:08
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/Manifest.gzbin43621 -> 43609 bytes
-rw-r--r--net-analyzer/fping/Manifest2
-rw-r--r--net-analyzer/fping/files/fping-5.1-c99-musl.patch39
-rw-r--r--net-analyzer/fping/fping-5.1-r1.ebuild35
4 files changed, 76 insertions, 0 deletions
diff --git a/net-analyzer/Manifest.gz b/net-analyzer/Manifest.gz
index a653562b5805..66689109ba7c 100644
--- a/net-analyzer/Manifest.gz
+++ b/net-analyzer/Manifest.gz
Binary files differ
diff --git a/net-analyzer/fping/Manifest b/net-analyzer/fping/Manifest
index 1a3b300592d4..958c16f58129 100644
--- a/net-analyzer/fping/Manifest
+++ b/net-analyzer/fping/Manifest
@@ -1,3 +1,5 @@
+AUX fping-5.1-c99-musl.patch 1244 BLAKE2B 131b192dff128f58e3092e79f59258453baba77bb2d9be6dc0bf31cdc779d4c97b6e1a4f3d4e5d2edc241bceb076238e1cb573a780c50e342f6af01998617c74 SHA512 823b8995718248cfe6dd326f7ecf4f7ddcca52e113d1bad323a1373554fc3fa2432daaed57b0a743fcb7ded68e7f7944dc0bf4150b15cef7892a485d5c770ed4
DIST fping-5.1.tar.gz 191224 BLAKE2B 2fb344e650b5a359fb8780f2c599455d39405ae823edf695ee4385aa2661dc5811e088bafa1b9f53846ee90c0afa959a92832381a03346d1fda048eb4e7ee098 SHA512 1a208da8dcd99093d0512af5d85ba5e7b5743ec97993d24c1fe612bb58d93090ac1ba0952f648aa075f16d390a77c4be65e394ae56dbede2a6914e0e8c68e2bd
+EBUILD fping-5.1-r1.ebuild 688 BLAKE2B 629c808c0c7bcffbc766bf87300082cba8a650e09467a61d249e83fe1ee711e299218179ca76b9d2e6a05a640dc879339c3dcd17c526daee725f79a7e6238966 SHA512 7bd5b76449aea8447563ef26ddf0cd109051eca3424e5dec5fd8c38a1604a6bdeb4d378fca626a02c416070080af5b58947d1ec77074a19057f51c7ba82b4262
EBUILD fping-5.1.ebuild 630 BLAKE2B 10f707b93715dffdcdec1560f1346ed76a187c9ac36794e0b832163ddd9aa3b29540bedfe36773759cf3735302b42ac98ac1183cd7eb6e4c0dda1d597236e6e4 SHA512 b228f6b1fbf70ddbc15bb8546f2ba3d9816653b901d8ac056d463acefc7df7e47ce3423bad446eba0f15a04e3e50d7b7f20e4556d48bff6c2d66e90ee9549f28
MISC metadata.xml 412 BLAKE2B cf9f74189166e68b3610dee763397a10855494947d30405ca374b52f22a634a052ffd486542d7147ad50bfadc66fb23ae20a654ff1f6ded2176085001e659bd6 SHA512 86a0ef3b8758b2ed892ca33a3a631ae6fb95d6414f4adaa952fbb44897a842df3873bdcd90729cfd71636f6643d9feb0855fb309a84eb9d8ad8324d03194fa5b
diff --git a/net-analyzer/fping/files/fping-5.1-c99-musl.patch b/net-analyzer/fping/files/fping-5.1-c99-musl.patch
new file mode 100644
index 000000000000..d56bb501682c
--- /dev/null
+++ b/net-analyzer/fping/files/fping-5.1-c99-musl.patch
@@ -0,0 +1,39 @@
+https://bugs.gentoo.org/895182
+https://github.com/schweikert/fping/commit/c0fbccb977c523ba671afdf0f37de40d26351f77
+
+From c0fbccb977c523ba671afdf0f37de40d26351f77 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Mon, 29 Aug 2022 15:41:51 -0700
+Subject: [PATCH] fping: Initialize msghdr struct in a portable way
+
+Initializing the structure assuming glibc layout results in
+compile errors on musl, therefore do partial intialization and then
+assigning the members individually.
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+--- a/src/fping.c
++++ b/src/fping.c
+@@ -1962,15 +1962,13 @@ int receive_packet(int64_t wait_time,
+ reply_buf,
+ reply_buf_len
+ };
+- struct msghdr recv_msghdr = {
+- reply_src_addr,
+- reply_src_addr_len,
+- &msg_iov,
+- 1,
+- &msg_control,
+- sizeof(msg_control),
+- 0
+- };
++ struct msghdr recv_msghdr = {0};
++ recv_msghdr.msg_name = reply_src_addr;
++ recv_msghdr.msg_namelen = reply_src_addr_len;
++ recv_msghdr.msg_iov = &msg_iov;
++ recv_msghdr.msg_iovlen = 1;
++ recv_msghdr.msg_control = &msg_control;
++ recv_msghdr.msg_controllen = sizeof(msg_control);
+ #if HAVE_SO_TIMESTAMPNS
+ struct cmsghdr *cmsg;
+ #endif
+
diff --git a/net-analyzer/fping/fping-5.1-r1.ebuild b/net-analyzer/fping/fping-5.1-r1.ebuild
new file mode 100644
index 000000000000..ddd1e6978d3a
--- /dev/null
+++ b/net-analyzer/fping/fping-5.1-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit fcaps
+
+DESCRIPTION="A utility to ping multiple hosts at once"
+HOMEPAGE="https://fping.org/ https://github.com/schweikert/fping/"
+SRC_URI="https://fping.org/dist/${P}.tar.gz"
+
+LICENSE="fping"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="suid"
+
+FILECAPS=( cap_net_raw+ep usr/sbin/fping )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-5.1-c99-musl.patch
+)
+
+src_configure() {
+ econf --enable-ipv6
+}
+
+src_install() {
+ default
+
+ if use suid; then
+ fperms u+s /usr/sbin/fping
+ fi
+
+ dosym fping /usr/sbin/fping6
+}