summaryrefslogtreecommitdiff
path: root/net-analyzer
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-23 07:07:57 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-23 07:07:57 +0000
commitbed152ba1fc2f1316eaefb5c3d24d48195560f76 (patch)
tree0564fbaf0c7ff23390031d68b741e89a40071333 /net-analyzer
parent57c2e006d0af9ab77ced676461d7100cade4a716 (diff)
gentoo auto-resync : 23:11:2022 - 07:07:57
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/Manifest.gzbin44552 -> 44868 bytes
-rw-r--r--net-analyzer/shodan/Manifest4
-rw-r--r--net-analyzer/shodan/metadata.xml22
-rw-r--r--net-analyzer/shodan/shodan-1.28.0.ebuild36
-rw-r--r--net-analyzer/shodan/shodan-9999.ebuild36
-rw-r--r--net-analyzer/wtfis/Manifest4
-rw-r--r--net-analyzer/wtfis/metadata.xml22
-rw-r--r--net-analyzer/wtfis/wtfis-0.4.0.ebuild38
-rw-r--r--net-analyzer/wtfis/wtfis-9999.ebuild38
-rw-r--r--net-analyzer/yersinia/Manifest1
-rw-r--r--net-analyzer/yersinia/files/yersinia-9999-tinfo.patch27
11 files changed, 200 insertions, 28 deletions
diff --git a/net-analyzer/Manifest.gz b/net-analyzer/Manifest.gz
index 1d839a443dda..0c1ddf1e3fae 100644
--- a/net-analyzer/Manifest.gz
+++ b/net-analyzer/Manifest.gz
Binary files differ
diff --git a/net-analyzer/shodan/Manifest b/net-analyzer/shodan/Manifest
new file mode 100644
index 000000000000..d71ade2af473
--- /dev/null
+++ b/net-analyzer/shodan/Manifest
@@ -0,0 +1,4 @@
+DIST shodan-1.28.0.gh.tar.gz 51277 BLAKE2B e2cd4c322ccdd1d81c998dc810c56b85de903afe9c3a59adc231d382779806909a78e994ff163639468dd9af1e8f7a547953b0e2304ac167ed7cf9c437d69adc SHA512 cb2476faf2c435d29823635e5262bdf6b224b2a5f19b77513fb6e920f4d042b15a7fd23cea7e2a29bc73b00be188dfac16f945fba090da28a72d0342357232c3
+EBUILD shodan-1.28.0.ebuild 887 BLAKE2B c570b05ccb40ac49e283d19c14037df36f336c160bf9b574b300b6471d05d379bd284ff1967785289780ffafe0f66f98f9101288394e33fae223ca02f937f8d9 SHA512 64c05f77a2a1dcd7cfb843cf3fb74b0b7ba0a458515a3040612c1ee2c8640634a70d01d523cfcb4ad54bce918d53086999ef66f732a228e4377b11e94a4330a8
+EBUILD shodan-9999.ebuild 887 BLAKE2B c570b05ccb40ac49e283d19c14037df36f336c160bf9b574b300b6471d05d379bd284ff1967785289780ffafe0f66f98f9101288394e33fae223ca02f937f8d9 SHA512 64c05f77a2a1dcd7cfb843cf3fb74b0b7ba0a458515a3040612c1ee2c8640634a70d01d523cfcb4ad54bce918d53086999ef66f732a228e4377b11e94a4330a8
+MISC metadata.xml 864 BLAKE2B 1eeb1a52185cac9195cc62b3e74d0dfb7df895666303bbbf562a4b75363b0179137de3cf99c8d650f59a13f972bfbdece972783ba282870a501289950d9cec6c SHA512 737b931e809418e0fe940ac6026d52edce42d0b5da30372394403210688caab00d8c99807b640de74383f3e4daafc3e09764bdde31e54d9898a11aff60f4f2c4
diff --git a/net-analyzer/shodan/metadata.xml b/net-analyzer/shodan/metadata.xml
new file mode 100644
index 000000000000..506479336f85
--- /dev/null
+++ b/net-analyzer/shodan/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>mario.haustein@hrz.tu-chemnitz.de</email>
+ <name>Mario Haustein</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ Shodan is a search engine for Internet-connected devices. Google lets
+ you search for websites, Shodan lets you search for devices. This
+ library provides developers easy access to all of the data stored in
+ Shodan in order to automate tasks and integrate into existing tools.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">achillean/shodan-python</remote-id>
+ <remote-id type="pypi">shodan</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-analyzer/shodan/shodan-1.28.0.ebuild b/net-analyzer/shodan/shodan-1.28.0.ebuild
new file mode 100644
index 000000000000..c66417af8251
--- /dev/null
+++ b/net-analyzer/shodan/shodan-1.28.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="The official Python library for Shodan"
+HOMEPAGE="https://github.com/achillean/shodan-python"
+
+MY_PN="${PN}-python"
+
+if [[ ${PV} = "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/achillean/shodan-python.git"
+else
+ SRC_URI="https://github.com/achillean/shodan-python/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
+ S="${WORKDIR}/${MY_PN}-${PV}"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/click-plugins[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.2.1[${PYTHON_USEDEP}]
+ dev-python/xlsxwriter[${PYTHON_USEDEP}]
+"
+
+# Test requires API key
+RESTRICT="test"
diff --git a/net-analyzer/shodan/shodan-9999.ebuild b/net-analyzer/shodan/shodan-9999.ebuild
new file mode 100644
index 000000000000..c66417af8251
--- /dev/null
+++ b/net-analyzer/shodan/shodan-9999.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="The official Python library for Shodan"
+HOMEPAGE="https://github.com/achillean/shodan-python"
+
+MY_PN="${PN}-python"
+
+if [[ ${PV} = "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/achillean/shodan-python.git"
+else
+ SRC_URI="https://github.com/achillean/shodan-python/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
+ S="${WORKDIR}/${MY_PN}-${PV}"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/click-plugins[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.2.1[${PYTHON_USEDEP}]
+ dev-python/xlsxwriter[${PYTHON_USEDEP}]
+"
+
+# Test requires API key
+RESTRICT="test"
diff --git a/net-analyzer/wtfis/Manifest b/net-analyzer/wtfis/Manifest
new file mode 100644
index 000000000000..2d89135f714b
--- /dev/null
+++ b/net-analyzer/wtfis/Manifest
@@ -0,0 +1,4 @@
+DIST wtfis-0.4.0.gh.tar.gz 459363 BLAKE2B 10338f17700815aa8f25bd1e9587855795710925481ea3d7bd85782fea657055053d965977f601bc25d624352c97c639008d33d30aa3ac248ea7504c7e0ceaa7 SHA512 bb19923668e8172fd07b86159839c95a1b32d9975edcf1e9ab99bb574eae24f70c3a6bf83cc8ade66c1e5f57632625e7f604966ee06445839df87a9af4962573
+EBUILD wtfis-0.4.0.ebuild 964 BLAKE2B 66c5cbfee274186ae7a8f898bcbb7b1b1e3df9f956ef42cc82fe3c8e74dc0e7282b2a4a813dfcb4b42f2a0e6fd78a73fe77143f41f0dbaf847d642335d4c4866 SHA512 baa1c98f33251815252d6f972040bebcbec92f32867bfddf628a4b176c396068b5ad1e3161bb599100f12936315f5590b99d29ea3c395f9227e6edcc58e14432
+EBUILD wtfis-9999.ebuild 964 BLAKE2B 66c5cbfee274186ae7a8f898bcbb7b1b1e3df9f956ef42cc82fe3c8e74dc0e7282b2a4a813dfcb4b42f2a0e6fd78a73fe77143f41f0dbaf847d642335d4c4866 SHA512 baa1c98f33251815252d6f972040bebcbec92f32867bfddf628a4b176c396068b5ad1e3161bb599100f12936315f5590b99d29ea3c395f9227e6edcc58e14432
+MISC metadata.xml 855 BLAKE2B 552b9998e0eada39d9a0f0e092c566e9a75c5ac2e2360df66d9b7334e663a9fb4a82be51f31623f31644e2863d78570405dc94e36769be7cbbcc3539cf49d920 SHA512 56593e8b58a019e4cdbf23946331c34f66fc72e318271916b33f3f63ccfb2d7a546dcbf05fcd0bd0bce9e5e0ce8f7b0cfd621b4b938c0eed135c34d025fdfc32
diff --git a/net-analyzer/wtfis/metadata.xml b/net-analyzer/wtfis/metadata.xml
new file mode 100644
index 000000000000..495aa987e99e
--- /dev/null
+++ b/net-analyzer/wtfis/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>mario.haustein@hrz.tu-chemnitz.de</email>
+ <name>Mario Haustein</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ wtfis is a commandline tool that gathers information about a domain,
+ FQDN or IP address using various OSINT services. Unlike other tools of
+ its kind, it's built specifically for human consumption, providing
+ results that are pretty (YMMV) and easy to read and understand.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">pirxthepilot/wtfis</remote-id>
+ <remote-id type="pypi">wtfis</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-analyzer/wtfis/wtfis-0.4.0.ebuild b/net-analyzer/wtfis/wtfis-0.4.0.ebuild
new file mode 100644
index 000000000000..f8b9786fcce5
--- /dev/null
+++ b/net-analyzer/wtfis/wtfis-0.4.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Passive hostname, domain and IP lookup tool for non-robots"
+HOMEPAGE="https://github.com/pirxthepilot/wtfis"
+
+if [[ ${PV} = "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/pirxthepilot/wtfis.git"
+else
+ SRC_URI="https://github.com/pirxthepilot/wtfis/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/pydantic-1.10.2[${PYTHON_USEDEP}]
+ >=dev-python/python-dotenv-0.21.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.28.1[${PYTHON_USEDEP}]
+ >=dev-python/rich-12.6.0[${PYTHON_USEDEP}]
+ >=net-analyzer/shodan-1.28.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/rich[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
diff --git a/net-analyzer/wtfis/wtfis-9999.ebuild b/net-analyzer/wtfis/wtfis-9999.ebuild
new file mode 100644
index 000000000000..f8b9786fcce5
--- /dev/null
+++ b/net-analyzer/wtfis/wtfis-9999.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Passive hostname, domain and IP lookup tool for non-robots"
+HOMEPAGE="https://github.com/pirxthepilot/wtfis"
+
+if [[ ${PV} = "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/pirxthepilot/wtfis.git"
+else
+ SRC_URI="https://github.com/pirxthepilot/wtfis/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/pydantic-1.10.2[${PYTHON_USEDEP}]
+ >=dev-python/python-dotenv-0.21.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.28.1[${PYTHON_USEDEP}]
+ >=dev-python/rich-12.6.0[${PYTHON_USEDEP}]
+ >=net-analyzer/shodan-1.28.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/rich[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
diff --git a/net-analyzer/yersinia/Manifest b/net-analyzer/yersinia/Manifest
index 65dc4c8683a1..51e678b60fe6 100644
--- a/net-analyzer/yersinia/Manifest
+++ b/net-analyzer/yersinia/Manifest
@@ -2,7 +2,6 @@ AUX yersinia-0.7.1-no-ncurses.patch 330 BLAKE2B 86c2cb84542012c6424fdcae398e0776
AUX yersinia-0.7.3-tinfo.patch 563 BLAKE2B 6203584c6ff7b8e5438f57ad74b5b1ee7ee61d08b2bee21234fd4cfbb6aa37b9b1cb69b4a7af11e57434b215e346f6384a195ffdd47b9504fe6eb93b3d2109e9 SHA512 9a53505e050a9658f49809ad989d534e542fb0cf21ae70a9271b536a9a478a4306e49c9b0493ab522d5ffb82849eed043b212e399505c916792372a64d96c319
AUX yersinia-0.8.2-configure-clang16-deux.patch 1385 BLAKE2B 95f406b11d9b662a79df56118604bca3935a88f99348875f86dbd4126f96d2bc3876cfc39a56e7c41928214cff1a2cec74ae5c1f43680de0651d0963c8359c60 SHA512 717ff843b3b9daa689e4c08edb3d0bd92808653782cc465b851fdc5d891c2b626e6cb63738ee0aa85244dde544f1b7a0fbd26bf57517c5c33c62068bc32a3b98
AUX yersinia-0.8.2-configure-clang16.patch 1705 BLAKE2B b9cf0fc0181f85894331b2f020fc962b644ace2bc2c8590ebb1ef597999c126dcb7c6537241ade7c3984200dd2e03abf84ef87854ade1fe6c2b28c2510f1bb48 SHA512 93c6698591648cdc332d73148e512818777dc34edb6892df51f123dbe191be5287c8a7a3b3fdb15bea9dad28e35b5b18adf96d38572d297961bfaae03ffc4c27
-AUX yersinia-9999-tinfo.patch 563 BLAKE2B ef2b554f82037dde165373fd6db71503ee124062cef4689062e7e1799f5ae26afd5758468f3c860690046aa4cb6e12dafd7ed3189a765a52565b5530a322d11a SHA512 a0edb5a47281bc66f0296914597fc4a9901f0e50640b43b6b31a30ddc4b6a5202220207039c3936f32769161f2c61d78afc5a3d7725d04ea41afd301312efa24
DIST yersinia-0.8.2.tar.gz 387889 BLAKE2B 67fe92b9cd1253874c61fa38c8e89e023f7d0ec3b83fe3001b5bc203d4033e36cb94b453ed56426b34d942036a143bd135f247466425337478f292797a433652 SHA512 2c7c89f19b6791150c472a6066b6ffaf9ac5b3d1a3d2e6a27f91293bba9a0f72d147266731e5e2670e4bf7e67ccf04b6e353071ca42d3d281b25126c9bfcb1dd
EBUILD yersinia-0.8.2-r2.ebuild 1188 BLAKE2B 7c615e24f538ccf2bdf7e8d7e07d62600a7c4f588bec17a060d07b3033ace3489c88f6873b576bad4026557f989d7a191a4b6094c11e426ea0311120486e0caf SHA512 c739777ae2945244409189b05ea96ac767fa24419e1e831cbf976dde5fb61bb550bb9b5822ad2ea9e00da7f860008b099b873c1ce38d5f03a38efaba3106449e
MISC metadata.xml 602 BLAKE2B 17ecc301b7c25dfbe55ca622e293154a6802050de8ea0674697f36418af73c37258e76d191449686d0475368ec3532e66102e85d93ba7c0fb7eb77280ace59a7 SHA512 9fcebd2cd58ae500fc4211de33a31b01a4cfaf67555b6ae1c5b6aa64ba68c53cfe22bc5b93f603919b1cd0653b1885b62cddca15dd6c6597dbea9f363da043fa
diff --git a/net-analyzer/yersinia/files/yersinia-9999-tinfo.patch b/net-analyzer/yersinia/files/yersinia-9999-tinfo.patch
deleted file mode 100644
index b5bf566c107d..000000000000
--- a/net-analyzer/yersinia/files/yersinia-9999-tinfo.patch
+++ /dev/null
@@ -1,27 +0,0 @@
---- a/configure.ac
-+++ b/configure.ac
-@@ -467,6 +467,7 @@
- AC_DEFINE(HAVE_REMOTE_ADMIN)
- fi
-
-+PKG_CHECK_MODULES(ncurses,ncurses)
-
- dnl Curses detection: Munged from Midnight Commander's configure.in
- dnl
-@@ -616,6 +617,16 @@
- AC_DEFINE(USE_NCURSES)
- AC_DEFINE(HAS_CURSES)
- has_curses=true
-+ else
-+ if test "$ncurses_LIBS" ; then
-+ CURSES_LIBS="$ncurses_LIBS"
-+ CURSES_INCLUDEDIR="$ncurses_CFLAGS"
-+ search_ncurses=false
-+ screen_manager="ncurses"
-+ AC_DEFINE(USE_NCURSES)
-+ AC_DEFINE(HAS_CURSES)
-+ has_curses=true
-+ fi
- fi
- )
-